LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 07-21-2003, 06:09 PM   #1
firefly2442
Member
 
Registered: Apr 2003
Location: USA
Distribution: Ubuntu
Posts: 95

Rep: Reputation: 15
Disable GUI Login and Config StartX


Hi, I would like to disable my GUI login that starts up every time I boot. Is this how you do it? I found this on another thread. Will this work for all distros?
Quote:
If you want Linux to boot in console mode (non-GUI) at startup.
You need to edit the /etc/inittab

On the line
id:5:initdefault:

change the 5 to a 3
id:3:initdefault:
And I want to be able to configure startx so that I can switch from KDE and Gnome and any more that I install. How can I do this? Thank you.
 
Old 07-21-2003, 06:12 PM   #2
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 58
yes that is how you would setup your machine to boot directly to console for the GUI will not startup automatically....as for switching between KDE && Gnome, you can do that from within X, just use the desktop switching utility...and i don't know about your graphical login screen but on some distros you can choose kde or gnome before you type your username/password in...
 
Old 07-21-2003, 06:14 PM   #3
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 58
also i think it is the file .Xclients-default in redhat which is in your home directory, you can edit it manually to say :
exec startkde
or
exec gnome-session
whichever you are wanting to use...
 
Old 07-21-2003, 07:05 PM   #4
firefly2442
Member
 
Registered: Apr 2003
Location: USA
Distribution: Ubuntu
Posts: 95

Original Poster
Rep: Reputation: 15
Thank you very much.
 
Old 07-21-2003, 08:02 PM   #5
firefly2442
Member
 
Registered: Apr 2003
Location: USA
Distribution: Ubuntu
Posts: 95

Original Poster
Rep: Reputation: 15
In ".Xclients-default" how do you change it back to default KDE? Exec kde?
 
Old 07-21-2003, 08:09 PM   #6
firefly2442
Member
 
Registered: Apr 2003
Location: USA
Distribution: Ubuntu
Posts: 95

Original Poster
Rep: Reputation: 15
Found it:

exec startkde
 
Old 07-21-2003, 11:02 PM   #7
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 58
hehehh i was going to say, i thought i mentioned that
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
gui login failed despite users created. but Text mode + root + startx works OK Emmanuel_uk VectorLinux 2 11-21-2005 03:41 PM
X server - how to disable the -nolisten tcp startx default? lugoteehalt Debian 3 05-04-2004 07:12 AM
Disable GUI in Redhat 8.0 TexasDex Linux - General 3 03-24-2003 12:12 PM
Must type startx after login to get itno gui? HellBound Linux - General 7 10-04-2002 10:40 AM
startx does not bring up KDE gui slackerboy Slackware 5 07-15-2002 03:25 AM


All times are GMT -5. The time now is 07:24 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration