LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 02-16-2003, 01:56 PM   #1
TexasDex
Member
 
Registered: Feb 2003
Location: The Attic. Nowhere near Texas.
Distribution: Gentoo, Kubuntu, formerly LFS, SuSE, and RedHat
Posts: 133

Rep: Reputation: 15
Question Disable GUI in Redhat 8.0


I have a Pentium II (233MHz) PC using Redhat 8.0 with the GRUB loader. I would like to use it as a family SMB and HTTP server. Because this machine is hardly state of the art I would like to be able to get the most out of the machine. Therefore I'd like to be able to turn off the GUI to save resources when I am not using the machine. How do I do this?

I have very little experience with Linux, I have only used it for a few months. The only clue I have to this problem is it may have something to do with runlevels, though I'm not even sure what they are.
 
Old 02-16-2003, 02:33 PM   #2
fancypiper
Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 57
You could edit /etc/inittab and set the default runlevel to Full multiuser mode, then it would boot into the console command line.

If you need to use X, log into an account and command startx
Code:
#
# inittab       This file describes how the INIT process should set up
#               the system in a certain run-level.
#
# Author:       Miquel van Smoorenburg, <miquels@drinkel.nl.mugnet.org>
#               Modified for RHS Linux by Marc Ewing and Donnie Barnes
#

# Default runlevel. The runlevels used by RHS are:
#   0 - halt (Do NOT set initdefault to this)
#   1 - Single user mode
#   2 - Multiuser, without NFS (The same as 3, if you do not have networking)
#   3 - Full multiuser mode
#   4 - unused
#   5 - X11
#   6 - reboot (Do NOT set initdefault to this)
#
id:3:initdefault:
 
Old 03-24-2003, 11:22 AM   #3
TexasDex
Member
 
Registered: Feb 2003
Location: The Attic. Nowhere near Texas.
Distribution: Gentoo, Kubuntu, formerly LFS, SuSE, and RedHat
Posts: 133

Original Poster
Rep: Reputation: 15
Thanks!

I got that, but I was wondering how to turn it off through GRUB. Is that possible?
 
Old 03-24-2003, 12:12 PM   #4
fancypiper
Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 57
Have you tried passing linux 3 or linux single to grub?

I never use gui login, so I'm not much help

Last edited by fancypiper; 03-24-2003 at 12:14 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Disable GUI Desktop on Solaris 10. Zepiroth Solaris / OpenSolaris 2 11-04-2005 08:31 AM
Disable Firewall in Redhat 9 PacMansRancor Linux - General 3 09-26-2005 08:29 PM
Disable firewall in Redhat 8.0! -mk- Linux - Newbie 4 07-26-2004 05:09 PM
How to disable Redhat firewall? xbbd Linux - Newbie 3 03-05-2004 08:54 PM
Disable GUI Login and Config StartX firefly2442 Linux - Newbie 6 07-21-2003 11:02 PM


All times are GMT -5. The time now is 09:10 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration