LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-14-2002, 05:21 PM   #1
slackerboy
Member
 
Registered: Jul 2002
Location: USA
Distribution: Slackware, Red Hat, Ubuntu
Posts: 58

Rep: Reputation: 15
Angry startx does not bring up KDE gui


Hi,
I am a new Slackware v7.0 user and the problem
I am having is that I cannot bring up the KDE gui
after I enter startx at the command prompt. I get
the error 'command startx not found'.

I can play music (via kscd) when I invoke a window
manager not tied up to KDE. Neither KDE nor GNOME
are working in my box. I am at a lost as to what to
do to use these two gui's. Any ideas?

Thank in advance.
 
Old 07-14-2002, 06:12 PM   #2
progster
Member
 
Registered: Feb 2002
Distribution: ubuntu
Posts: 76

Rep: Reputation: 15
[edit]wrong info but can't delete?[/edit]

~Progster

Last edited by progster; 07-14-2002 at 06:13 PM.
 
Old 07-14-2002, 10:43 PM   #3
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 45
Slack 7 is ancient, Nov99 on my CD's. But it included versions of both desktops. I suspect you haven't configured the X Windows system as yet.

Try the command "xf86config"

I believe the X server you would have is a version 3 server. So be carefull about what you read that may be in reference to the newer version 4 X server. There are big differences in the config and the server engine itself.

Cheers!
 
Old 07-14-2002, 11:05 PM   #4
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 45
Sorry about the last. It does appear that you are able to run X windows. I didn't read your post close enough. The startx command is usually located in the /usr/X11/bin or /usr/X11R6/bin directory. To locate it type the command "whereis startx" and see what the response is. If you can enter the full path and execute it, then the problem is in your path statement. If it is not located, then something must not be installed.

KDE and Gnome also had to be installed to begin with. Did you do a full install?

Another way to start the X server is through the run level. You could try the command "telinit 4". It should present the a login manager if available if I remember correctly. Probably kdm, it should allow you to choose the desktop you desire. This is the method that I use.

In any event, I am not sure how you are running any window manager if X will not start. Because, I thought that XFree86 was the only X server distributed with Slack.

Good luck.
 
Old 07-15-2002, 01:00 AM   #5
slackerboy
Member
 
Registered: Jul 2002
Location: USA
Distribution: Slackware, Red Hat, Ubuntu
Posts: 58

Original Poster
Rep: Reputation: 15
Hi Excalibur,
Thanks for coming to the rescue. I left out the fact that
I am using UMSDOS (BigSlack) and I just installed whatever
was included there. You may be right in that I have not
installed either gui (KDE or GNOME). However, I ran xf86config and can run a couple of win managers included in
Slack 7.0. I am even able to play music with workman...

I'll continue checking based on your sugestions above. Thanks again.
 
Old 07-15-2002, 03:25 AM   #6
slackerboy
Member
 
Registered: Jul 2002
Location: USA
Distribution: Slackware, Red Hat, Ubuntu
Posts: 58

Original Poster
Rep: Reputation: 15
Ok, I am happy to report that I resolved my problem: I got
kdebase.tgz which for some reason had been corrupted,
installed it, updated my xinitrc, and now I
have a nice KDE gui! Yeepee! Now my next project is to
bring up GNOME. Wish me luck...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't get suse 9.2 to bring up kde on Toshiba laptop gmfisher Linux - Hardware 6 02-14-2005 06:53 PM
empty slackware 10 GUI with startx rsumbeling Linux - Networking 2 11-13-2004 10:53 AM
when i startx the kde bring 2 bash program by it self Paxmaster Linux - General 1 11-11-2004 07:09 PM
booting into GUI: Gnome, Startx:KDE!!!! Krenn Slackware 6 07-19-2004 08:28 AM
My Redhat 8.0 server will not bring up the gui arlene Linux - Newbie 2 04-06-2004 05:11 PM


All times are GMT -5. The time now is 07:27 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration