LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 04-30-2004, 09:09 AM   #1
lugoteehalt
Senior Member
 
Registered: Sep 2003
Location: UK
Distribution: Debian
Posts: 1,215
Blog Entries: 2

Rep: Reputation: 49
X server - how to disable the -nolisten tcp startx default?


Understand Debian has as default the '-nolisten tcp' option set when it starts the X server. Have tried various stuff (for example created a ~/.xserverrc file with exec X :0 in it - incidentally its OT but if there is no 'exec' the startup of X is slowed right down) but seem uable to countermand this. For example if I do:

xfstt &

on a remote computer (trying to use the X server on the local computer) it says: 'Cannot open TCPIP port 7107'

Thanks any help.

Last edited by lugoteehalt; 04-30-2004 at 09:59 AM.
 
Old 04-30-2004, 12:25 PM   #2
mrcheeks
Senior Member
 
Registered: Mar 2004
Location: far enough
Distribution: OS X 10.6.7
Posts: 1,690

Rep: Reputation: 50
check your .xserverrc file or modify the global XFree options and remove no-listen line
 
Old 05-01-2004, 11:42 AM   #3
zuralin
Member
 
Registered: Sep 2003
Distribution: Debian testing/unstable
Posts: 225

Rep: Reputation: 30
/etc/X11/xinit/xserverrc
 
Old 05-04-2004, 07:12 AM   #4
lugoteehalt
Senior Member
 
Registered: Sep 2003
Location: UK
Distribution: Debian
Posts: 1,215
Blog Entries: 2

Original Poster
Rep: Reputation: 49
Thanks. Do not have an xserverrc file by default on Debian. Created a .xserverrc and just put exec X :0 in it.

Did this: Removed .xinitrc and .xsessions and just started X with 'xinit' (so it had no window manager and only an xterm). Would this mean the -nolisten tcp option was not done?

What I'm trying to do is get true type fonts served from a remote computer. X doesn't seem to open the right port and the font server xfstt complains variously, often that it cannot open a port.

 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
--nolisten tcp glock19 Linux - General 11 02-05-2013 03:45 PM
-nolisten tcp for X ferreter Fedora 3 07-19-2004 02:38 PM
SuSE 9.1 eliminating -nolisten tcp jdeisenberg Linux - Software 1 06-04-2004 04:38 PM
startx -nolisten tcp shanenin Slackware 2 11-12-2003 04:00 PM
-nolisten tcp Xgates Linux - Security 4 01-23-2003 04:48 AM


All times are GMT -5. The time now is 01:44 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration