LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices



Reply
 
Search this Thread
Old 08-07-2002, 10:00 AM   #1
HellBound
Member
 
Registered: Aug 2002
Distribution: RedHat 8.0 & Suse 8.1
Posts: 58

Rep: Reputation: 15
Must type startx after login to get itno gui?


I heard its suppose to just start up automaticly but it doesn't I have to type startx everytime I want to get in to the gui.
Any idea what the problem is?
Or is this normal?
 
Old 08-07-2002, 10:25 AM   #2
jetblackz
Member
 
Registered: Mar 2002
Location: Debian Galaxy
Distribution: Debian
Posts: 711

Rep: Reputation: 30
Depending on your distro & login gui, normally, you make sure this is the case

/etc/inittab

id5:initdefault:

I suppose yours is id3.
 
Old 08-07-2002, 11:20 AM   #3
HellBound
Member
 
Registered: Aug 2002
Distribution: RedHat 8.0 & Suse 8.1
Posts: 58

Original Poster
Rep: Reputation: 15
no I forgot to mention it also says its in N 5 when I check the level.
 
Old 08-07-2002, 01:05 PM   #4
dorward
Member
 
Registered: Sep 2001
Distribution: Gentoo
Posts: 760

Rep: Reputation: 31
Check that you have an RPM for one of the following installed:

"kdm"
"gdm"
"xdm"
 
Old 08-07-2002, 03:37 PM   #5
rooman
Member
 
Registered: Mar 2002
Location: Lausanne, Switzerland
Distribution: Mandriva 2007.0
Posts: 223

Rep: Reputation: 30
autostart your GUI

Hi there, you must have a control panel somewhere in RH which will have the option to automatically start the GUI on startup.
 
Old 09-05-2002, 09:01 PM   #6
gbrad
Member
 
Registered: Sep 2002
Location: St. Louis, MO
Distribution: Red Hat 8
Posts: 89

Rep: Reputation: 15
Or, you can just add the following line:

startx

to a file that runs during init (such as the hidden .bash_profile in your home directory). Doing so will load your default GUI at login.
 
Old 09-08-2002, 11:22 AM   #7
jetblackz
Member
 
Registered: Mar 2002
Location: Debian Galaxy
Distribution: Debian
Posts: 711

Rep: Reputation: 30
Or you missed the option that asked you during install if you wanted to start x at startup.
 
Old 10-04-2002, 11:40 AM   #8
jrclare
LQ Newbie
 
Registered: Apr 2001
Location: Washtenaw County
Posts: 18

Rep: Reputation: 0
warning--maybe misguided though.

don't put startx in your root .bash_profile--if you have a problem with X you might go into an endless error loop.

if you are a newbie don't put anything in the root hidden files.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
installing redhat 8.0 when text login in I cannot type password?? I type root scrist Linux - General 4 04-22-2006 03:20 AM
gui login failed despite users created. but Text mode + root + startx works OK Emmanuel_uk VectorLinux 2 11-21-2005 04:41 PM
WHY should I type startx twice to startx? hiux Debian 6 09-09-2005 10:12 AM
Why is it so slow, and why does it freeze after i type startx? potenza Slackware - Installation 7 03-12-2004 11:10 AM
Disable GUI Login and Config StartX firefly2442 Linux - Newbie 6 07-22-2003 12:02 AM


All times are GMT -5. The time now is 11:07 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration