LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 08-13-2003, 10:56 PM   #1
richardg
LQ Newbie
 
Registered: Jul 2003
Location: Southwest USA
Distribution: FC4 2.6.14-1.1644_FC4
Posts: 19

Rep: Reputation: 0
commands work with interactive grub, but not in grub.conf


I have win98 on hda, and RH8.0 on hdb. I have GRUB, installed by 'grub-install /dev/hdb'. When I use grub interactively, from a grub floppy, the commands

root (hd1,0)
kernel /boot/vmlinuz ro root=/dev/hdb1 hdd=ide-scsi
boot

get me into linux just fine. Same commands in /etc/grub.conf cause errors.

the details.
interactively, when I type root (hd1,0)
I get:
filename type is ext2fs, partition type 0x83
which makes sense, 'cause that's what it is.

non-interactively (booting from the second HD using bios), I get

root (hd1,0)
filesystem is fat, partition type is 0x0c

then the 'kernel' command exits with a 'file not found' because I have apparently set root to the windows partition, which is on hd0, I thought.
What's happening?


Anybody know what is going on?
 
Old 11-23-2003, 03:58 AM   #2
aus9
Guru
 
Registered: Oct 2003
Posts: 5,056

Rep: Reputation: Disabled
Could you post the results of fdisk /dev/hda and /dev/hdc and /etc/fstab
root (hd1,0) = /dev/hdc1 MUST be where your /boot partition is
You don't mention you have checked your /boot files are ok or output of /boot/grub/menu.1st.

we should be able to just edit this last file.
 
Old 11-23-2003, 04:36 AM   #3
Demonbane
Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
Because grub doesnt care about which ide channel the drives are on, but the order which the bios sees the drives.
When you set the bios to boot from the second HD you're effectively setting it to hd0(from grub's point of view), note that this is another story once you get inside linux.
I suppose the solution would be installing grub to the MBR of the first HDD, and set the bios to boot from it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
nano -w /boot/grub/grub.conf Tbagz Linux - Newbie 2 10-31-2005 06:42 PM
GRUB commands??? anjum Linux - Software 5 08-09-2005 12:07 PM
grub refuses to read grub.conf 0pal_t0ad Linux - Newbie 2 03-27-2005 04:40 AM
create lilo.conf or grub.conf through commands newpenguin Linux - Software 1 11-28-2003 08:22 PM
lilo.conf and grub.conf no read access shanenin Linux - Software 1 10-02-2003 03:53 PM


All times are GMT -5. The time now is 06:35 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration