LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 08-22-2005, 07:58 AM   #1
DJOtaku
Member
 
Registered: Oct 2004
Location: USA
Distribution: Fedora 20; Arch; Kubuntu; Debian
Posts: 711

Rep: Reputation: 31
Annoying Firefox/Laptop touchpad behavior


I have searched through all the options menus and have yet to see how to fix this problem I'm having with Firefox. No matter which window manager I'm using, if I am using Firefox and moving the mouse cursor around with the laptop's touchpad, if I move too fast in the left direction Firefox thinks I want to go back a page. Also, if I move too fast in the up direction, Firefox thinks I want to back up a page. Has anyone experienced this? How do I turn it off?
 
Old 08-22-2005, 10:07 AM   #2
900i
Member
 
Registered: Nov 2004
Location: Wakefield, UK
Distribution: Linux Mint 2.1
Posts: 33

Rep: Reputation: 15
If your using KDE, install ksynaptics package and reconfigure the touchpad.
 
Old 08-22-2005, 11:46 AM   #3
craigevil
Senior Member
 
Registered: Apr 2005
Location: OZ
Distribution: Debian Sid
Posts: 4,733
Blog Entries: 12

Rep: Reputation: 457Reputation: 457Reputation: 457Reputation: 457Reputation: 457
Good luck, a lot of people have noticed problems with a touchpad and Firefox. I am pretty sure it is a bug. I gave up and just use a mouse.

If you search the Firefox forum at http://forums.mozillazine.org/index.php
you will notice a couple of long threads. Although most of them involved people using windows.


There a couple of ways you can try to tackel the problem. Try looking for one of the following packages. (Sorry I know nothing about Fedora other than it is based on RH).
xfree86-driver-synaptics
tpconfig
qsynaptics
ksynaptics
cpad-common

Either ksynaptics or qtsynaptics should help you configure the touchpad. Or you can manually edit the xfree86 config file.

Hope some of this helped.
 
Old 08-23-2005, 07:57 AM   #4
dracolich
Senior Member
 
Registered: Jul 2005
Distribution: Slackware
Posts: 1,173

Rep: Reputation: 47
I, too, have noticed this. I don't believe it's a bug. It only happened after I upgraded to a 2.6.x kernel and had to install the synaptics driver for my touchpad. This "feature" has to do with the synaptics configuration in Xorg.conf. I haven't experimented to find out exactly which settings affect this. It happens if your movement begins fron the bottom of the touchpad. Example: \ = back one page, / = forward one page.
 
Old 08-29-2005, 12:29 PM   #5
phillfri
LQ Newbie
 
Registered: Nov 2004
Posts: 18

Rep: Reputation: 0
I think this problem might be a combination of issues. I use a mouse on my laptop and when typing in firefox (like writing this post) my cursor often jumps up into the middle of text that I've already written. Very annoying.

I also find that in MepisLinux I can't seem to turn the touchpad off. It just stays on. I found that by turning off the KDE key-repeat feature the problem is at least minimized. Absent turning key-repeat off, firefox is practically unuseable. So even KDE might be partly responsible.
 
Old 12-02-2005, 08:07 PM   #6
DeltaXFX
Member
 
Registered: Feb 2004
Location: USA
Distribution: Arch
Posts: 30

Rep: Reputation: 15
Smile

Try the following as a boot option:
psmouse.proto=exps

It worked great for me. FC4 with 2.6.11
I got it out of another thread from LQ:
http://www.linuxquestions.org/questi...d+back+forward
 
Old 12-03-2005, 02:39 PM   #7
biophysics
Member
 
Registered: Jan 2002
Location: Germany
Distribution: Kubuntu
Posts: 444

Rep: Reputation: 30
Better:
Change your xorg.conf and include/add this line in synapctic-touchpad section:

Option "BottomEdge" "9000"

Restart your X-server (Ctrl ALt Backspace)
Or
Type about:config in firefox and change the parameters as given below:
mousewheel.horizscroll.withnokey.action => 0

mousewheel.horizscroll.withnokey.sysnumlines => true
 
Old 12-04-2005, 01:34 AM   #8
uglydot
Member
 
Registered: Mar 2003
Distribution: Gentoo
Posts: 232

Rep: Reputation: 30
Interesting. I have Slack 10.2 running on 2.6.13.3 and whatever version of Firefox comes stock with 10.2(I think 1.0.6). The touchpad on my Inspiron 2200 does nothing like what you are describing. It just works normally.
 
Old 12-04-2005, 03:58 PM   #9
sam.pedraglio
Member
 
Registered: Jul 2005
Distribution: Mint 14 64bit
Posts: 68

Rep: Reputation: 16
I never found this strange behaviour with all the Mandrake/Mandriva I tried.
Both Firefox and Konqueror go back a page only if I use the touchpad on the lower side.
Sorry for your problem.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
annoying vim behavior pauloco Linux - Software 0 09-27-2005 01:10 PM
erroneous touchpad behavior Mr_C Linux - Laptop and Netbook 2 04-10-2005 07:24 PM
annoying behavior with DCHP-discover Burgin Debian 3 02-27-2005 06:42 PM
IBM laptop & touchpad & TrackPoint - touchpad doesn't work! espinosa_cz Linux - Laptop and Netbook 1 08-20-2004 01:45 PM
VERY annoying bug's / behavior ! qwijibow Linux - Software 3 11-05-2003 02:14 PM


All times are GMT -5. The time now is 09:06 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration