LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   Annoying Firefox/Laptop touchpad behavior (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/annoying-firefox-laptop-touchpad-behavior-355756/)

DJOtaku 08-22-2005 06:58 AM

Annoying Firefox/Laptop touchpad behavior
 
I have searched through all the options menus and have yet to see how to fix this problem I'm having with Firefox. No matter which window manager I'm using, if I am using Firefox and moving the mouse cursor around with the laptop's touchpad, if I move too fast in the left direction Firefox thinks I want to go back a page. Also, if I move too fast in the up direction, Firefox thinks I want to back up a page. Has anyone experienced this? How do I turn it off?

900i 08-22-2005 09:07 AM

If your using KDE, install ksynaptics package and reconfigure the touchpad.

craigevil 08-22-2005 10:46 AM

Good luck, a lot of people have noticed problems with a touchpad and Firefox. I am pretty sure it is a bug. I gave up and just use a mouse.

If you search the Firefox forum at http://forums.mozillazine.org/index.php
you will notice a couple of long threads. Although most of them involved people using windows.


There a couple of ways you can try to tackel the problem. Try looking for one of the following packages. (Sorry I know nothing about Fedora other than it is based on RH).
xfree86-driver-synaptics
tpconfig
qsynaptics
ksynaptics
cpad-common

Either ksynaptics or qtsynaptics should help you configure the touchpad. Or you can manually edit the xfree86 config file.

Hope some of this helped. :)

dracolich 08-23-2005 06:57 AM

I, too, have noticed this. I don't believe it's a bug. It only happened after I upgraded to a 2.6.x kernel and had to install the synaptics driver for my touchpad. This "feature" has to do with the synaptics configuration in Xorg.conf. I haven't experimented to find out exactly which settings affect this. It happens if your movement begins fron the bottom of the touchpad. Example: \ = back one page, / = forward one page.

phillfri 08-29-2005 11:29 AM

I think this problem might be a combination of issues. I use a mouse on my laptop and when typing in firefox (like writing this post) my cursor often jumps up into the middle of text that I've already written. Very annoying.

I also find that in MepisLinux I can't seem to turn the touchpad off. It just stays on. I found that by turning off the KDE key-repeat feature the problem is at least minimized. Absent turning key-repeat off, firefox is practically unuseable. So even KDE might be partly responsible.

DeltaXFX 12-02-2005 07:07 PM

Try the following as a boot option:
psmouse.proto=exps

It worked great for me. FC4 with 2.6.11
I got it out of another thread from LQ:
http://www.linuxquestions.org/questi...d+back+forward

biophysics 12-03-2005 01:39 PM

Better:
Change your xorg.conf and include/add this line in synapctic-touchpad section:

Option "BottomEdge" "9000"

Restart your X-server (Ctrl ALt Backspace)
Or
Type about:config in firefox and change the parameters as given below:
mousewheel.horizscroll.withnokey.action => 0

mousewheel.horizscroll.withnokey.sysnumlines => true

uglydot 12-04-2005 12:34 AM

Interesting. I have Slack 10.2 running on 2.6.13.3 and whatever version of Firefox comes stock with 10.2(I think 1.0.6). The touchpad on my Inspiron 2200 does nothing like what you are describing. It just works normally.

sam.pedraglio 12-04-2005 02:58 PM

I never found this strange behaviour with all the Mandrake/Mandriva I tried.
Both Firefox and Konqueror go back a page only if I use the touchpad on the lower side.
Sorry for your problem.


All times are GMT -5. The time now is 07:45 PM.