LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 10-07-2004, 10:26 AM   #1
Dooley
Member
 
Registered: Jun 2004
Location: Lighting Capitol Of The World
Distribution: Debian
Posts: 56

Rep: Reputation: 15
Having trouble unmounting floppy


Hello everyone, I have searched these forums also Google and have
read all I can find on unmounting a floppy in MDK 10, but I can't seem
to figure out why I have to shut the system down in order to format a
floppy after I have written something to another floppy.

I know I am not the brightest bulb in the box, but if I read things
right, MDK 10 has automount and should unmount without a problem.

From what I have read there should be a unmount from the right click
menu on the floppy icon on the desktop, no cigar, there is no unmount
on the right click menu, only Open and Properties.

It should be logical for one to think, if it is this way on one system using
the same distro it should be the same for all. If this is not the case why
are they different. I have spent more time trying to get this thing to work
than I do getting my work done.

My fstab are as follows:

/dev/hda1 / ext3 defaults 1 1
none /dev/pts devpts mode=0620 0 0
/dev/hda6 /home ext3 defaults 1 2
/dev/hdb /mnt/cdrom auto umask=0,user,iocharset=iso8859-1,
codepage=850,noauto,ro,exec 0 0
none /mnt/floppy supermount dev=/dev/fd0,fs=ext2:vfat,--,umask=0,
codepage=852,sync,iocharset=iso8859-2 0 0
none /proc proc defaults 0 0
/dev/hda5 swap swap defaults 0 0

Any help would be appreciated, it is not very productive to take the time
to rewrite the code for the OS to get everything working correctly.

Thanks in advance.
Dooley
 
Old 10-07-2004, 01:09 PM   #2
Mathieu
Senior Member
 
Registered: Feb 2001
Location: Montreal, Quebec, Canada
Distribution: RedHat, Fedora, CentOS, SUSE
Posts: 1,403

Rep: Reputation: 46
Unlike the cd-rom, the automount feature for floppies is not perfect.
The best way is to it manually at the command line (console).

If you want to mount a floppy, type:
Code:
mount /mnt/floppy
To un-mount it, type:
Code:
umount /mnt/floppy
 
Old 10-08-2004, 08:49 AM   #3
Dooley
Member
 
Registered: Jun 2004
Location: Lighting Capitol Of The World
Distribution: Debian
Posts: 56

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by Mathieu
Unlike the cd-rom, the automount feature for floppies is not perfect.
The best way is to it manually at the command line (console).

If you want to mount a floppy, type:
Code:
mount /mnt/floppy
To un-mount it, type:
Code:
umount /mnt/floppy
I appreciate the answer Mathieu but again, no cigar.

When I use the mnt command from the console (which I hate, I am no CLI person as I am always leaving something out, such a period, a comma or something and have to go back and search to see what went wrong) the floppy will not run and I get the following
message.

according to mtab, none is already mounted on /mnt/floppy
mount failed.

When I try to unmount I get this message:

umount: only root can unmount none from /mnt/floppy

Again, I am not the brightest bulb in the box but it sure seems to be very counterproductive to have a floppy drive which I should be able to use as both user and root but am only allowed to unmout as root which doesn't work either.

Again Thanks,
Dooley
 
Old 10-11-2004, 08:35 PM   #4
Mathieu
Senior Member
 
Registered: Feb 2001
Location: Montreal, Quebec, Canada
Distribution: RedHat, Fedora, CentOS, SUSE
Posts: 1,403

Rep: Reputation: 46
The problem is with the supermount.
I have never really used it.

If you want, you can replace the floppy supermount line with the following,
but you will mount and unmount the floppy manually.
Code:
/dev/fd0             /media/floppy        auto       noauto,user,sync      0 0
 
Old 10-12-2004, 02:03 AM   #5
opjose
Senior Member
 
Registered: Sep 2004
Location: Outlying D.C.
Distribution: Mandriva
Posts: 2,090

Rep: Reputation: 46
Actuall the problem is not with supermount (not that he is wrong btw), but rather that some floppy drives do not correctly report back a "status change" to the kernel which causes supermount to mount or unmount a floppy automatically.

With such brain dead floppies you'll need to do as he says and create a manual mount point.
 
Old 10-12-2004, 06:59 AM   #6
otish1000c
Member
 
Registered: May 2004
Location: Pennsylvania, USA
Distribution: dual boot.... Mandrake 10.0OE/10.xcooker
Posts: 611

Rep: Reputation: 30
you could also just simply do away with supermount by issuing the following command in terminal as root............

Code:
supermount -i disable
similarly, to re-enable it (if you want to do so)........

Code:
supermount -i enable
supermount/automount has always less than flawless (IMHO). i'd suggest just leaving it permanently disabled & mounting/unmount manually. you wouldn't even need to do that via CLI. just right click on a desktop icon for cdroms or floppys & choose "mount"/"umount" from the drop down list.

otis
 
Old 10-12-2004, 08:22 AM   #7
Dooley
Member
 
Registered: Jun 2004
Location: Lighting Capitol Of The World
Distribution: Debian
Posts: 56

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by otish1000c
you could also just simply do away with supermount by issuing the following command in terminal as root............

Code:
supermount -i disable
similarly, to re-enable it (if you want to do so)........

Code:
supermount -i enable
supermount/automount has always less than flawless (IMHO). i'd suggest just leaving it permanently disabled & mounting/unmount manually. you wouldn't even need to do that via CLI. just right click on a desktop icon for cdroms or floppys & choose "mount"/"umount" from the drop down list.

otis
Thanks otis and the others for the help but I guess I must be missing something.

I am using MDK 10 and the floppy icon on the desktop has no menu which lets me mount/unmount the floppy it only has open and properties. I have also created a new floppy device on the desktop with the same results, there is no mount/unmount.

Should I disable supermount before I create a new floppy device on the desk top in order to have mount/unmount in the dropdown menu, which would be great, as I said before I am no CLI person, I was terrible with DOS and am no better with Linux.

Again thanks to all.
Dooley
 
Old 10-12-2004, 09:31 AM   #8
opjose
Senior Member
 
Registered: Sep 2004
Location: Outlying D.C.
Distribution: Mandriva
Posts: 2,090

Rep: Reputation: 46
Trash the default icon and create a new one.

You can then add the mount and unmount commands to it.
 
Old 10-12-2004, 10:02 AM   #9
otish1000c
Member
 
Registered: May 2004
Location: Pennsylvania, USA
Distribution: dual boot.... Mandrake 10.0OE/10.xcooker
Posts: 611

Rep: Reputation: 30
right click the desktop->configure desktop->behaviour->device icons tab. unselect mounted/unmounted cd-rom, writer, & floppy. "apply"->"ok". right click desktop again->create new->device. one at a time choose a shortcut for your rom, writer, & floppy. for each one make sure you put the correct path (IE: /mnt/cdrom, /mnt/cdrom1, /mnt/floppy, etc.)->apply->ok. you should then be able to insert a cd or floppy, right click the corresponding icon, & choose mount/unmount from the drop down menus. if it doesn't work, make sure you have the /mnt paths correct for each.

otis
 
Old 10-12-2004, 04:36 PM   #10
Dooley
Member
 
Registered: Jun 2004
Location: Lighting Capitol Of The World
Distribution: Debian
Posts: 56

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by opjose
Trash the default icon and create a new one.

You can then add the mount and unmount commands to it.
Thanks opjose for the help of you and otis.

I have tried to do as you instructed but I still have to go
to root to unmount. I also followed the instructions from
otis with the same results, only unmount from root,
eventhough permissions are set to user, myself.

I am one of those people in a position of having to put work
before play, therefore I say it must be something I am
missing.

I will keep trying and sooner or later I will figure this thing
they call LInux out.

Dooley
 
Old 10-12-2004, 04:45 PM   #11
otish1000c
Member
 
Registered: May 2004
Location: Pennsylvania, USA
Distribution: dual boot.... Mandrake 10.0OE/10.xcooker
Posts: 611

Rep: Reputation: 30
could you please post the contents of your /etc/fstab file? it's a plain text file, so you'll be able to open it with any text editor. copy & paste the contents here, please.

otis
 
Old 10-13-2004, 07:55 AM   #12
Dooley
Member
 
Registered: Jun 2004
Location: Lighting Capitol Of The World
Distribution: Debian
Posts: 56

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by otish1000c
could you please post the contents of your /etc/fstab file? it's a plain text file, so you'll be able to open it with any text editor. copy & paste the contents here, please.

otis
First, let me thank everyone for taking up their time to assist me.

I have tried everything you suggested and have unchecked mount/unmount in Configure Desktop and created a new device on the desktop with no success. I must not be getting the full path to the floppy in this configuration as I still only have mount with no unmout in the menu.

The following is my fstab as it is at this time:

/dev/hda1 / ext3 defaults 1 1
none /dev/pts devpts mode=0620 0 0
/dev/hda6 /home ext3 defaults 1 2
/dev/hdb /mnt/cdrom auto umask=0,user,iocharset=iso8859-1,
codepage=850,noauto,ro,exec 0 0
none /mnt/floppy supermount dev=/dev/fd0,fs=ext2:vfat,--,umask=0,
codepage=852,sync,iocharset=iso8859-2 0 0
none /proc proc defaults 0 0
none /proc proc defaults 0 0
none /proc proc defaults 0 0
/dev/hda5 swap swap defaults 0 0

Should the line referencing the floppy be there with having unchecked both mount/unmount in the configuration.

Thanks again!
Dooley
 
Old 10-13-2004, 08:11 AM   #13
otish1000c
Member
 
Registered: May 2004
Location: Pennsylvania, USA
Distribution: dual boot.... Mandrake 10.0OE/10.xcooker
Posts: 611

Rep: Reputation: 30
change the floppy line to read like this...............

Code:
/dev/fd0 /mnt/floppy auto noauto,user
to edit the file you will need to be root. open a terminal, su to root, then type...........

that will open kwrite in root mode & let you edit & save the file. try the floppy after the edit/save, if it still doesn't work, then reboot & try.

if the above entry change doesn't fix it, then use this one........

Code:
/dev/fd0 /mnt/floppy auto
the first one should work, though.

otis
 
Old 10-13-2004, 09:43 AM   #14
Dooley
Member
 
Registered: Jun 2004
Location: Lighting Capitol Of The World
Distribution: Debian
Posts: 56

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by otish1000c
change the floppy line to read like this...............

Code:
/dev/fd0 /mnt/floppy auto noauto,user
to edit the file you will need to be root. open a terminal, su to root, then type...........

that will open kwrite in root mode & let you edit & save the file. try the floppy after the edit/save, if it still doesn't work, then reboot & try.

if the above entry change doesn't fix it, then use this one........

Code:
/dev/fd0 /mnt/floppy auto
the first one should work, though.

otis
Otis, I guess I don't need a floppy.

The first code will work on the first try but when I mount
the floppy again and try to unmount I get this popup box.

umount: /mnt/floppy: device is busy
umount: /mnt/floppy: device is busy
Please check that the disk is entered correctly.

The second code want work at all.

I don't understand why this happens, as I
don't take the disk out of the drive until I try to unmount.
I have read where the disk is not written to until one unmounts it.
It want try to unmount in order to be written to until I restart
the machine and only then will it show unmounted.
Another thing which bugs me is why I get the above warning,
how can one enter a floppy incorrectly.

Here are the fstab settings if it helps:

/dev/hda1 / ext3 defaults 1 1
none /dev/pts devpts mode=0620 0 0
/dev/hda6 /home ext3 defaults 1 2
/dev/hdb /mnt/cdrom auto umask=0,user,iocharset=iso8859-1,
codepage=850,noauto,ro,exec 0 0
/dev/fd0 /mnt/floppy auto noauto,user
none /proc proc defaults 0 0
none /proc proc defaults 0 0
none /proc proc defaults 0 0
/dev/hda5 swap swap defaults 0 0

Is it possible I have a corrupted set of MDK disk, I bought the four disk set.

Dooley
 
Old 10-13-2004, 09:50 AM   #15
otish1000c
Member
 
Registered: May 2004
Location: Pennsylvania, USA
Distribution: dual boot.... Mandrake 10.0OE/10.xcooker
Posts: 611

Rep: Reputation: 30
ok, don't give up the ship quite yet..........

do this for me..........

mount the floppy, then try unmounting. when you get the "device is busy........" message, in terminal as root type lsof -V /dev/fd0 (hit enter). that will tell you what's using the device. if you get a "command not found....." error after typing that, then install lsof first & try again. it's on the MDK discs, so to install it, in terminal as root type......... urpmi lsof (hit enter), then try the command again.

post the output here, please.

otis
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
mount & unmounting a floppy disk swamprat Linux - Newbie 4 09-27-2005 09:25 PM
trouble unmounting floppy dr_zayus69 Linux - Software 6 10-20-2004 07:11 PM
Mandrake 7.2, unmounting floppy during shutdown Secret Agent X2 Linux - Laptop and Netbook 2 09-04-2004 09:34 PM
Trouble unmounting and ejecting during diablo 2 install lasalsademuerte Red Hat 4 02-07-2004 03:01 PM
Trouble unmounting 70k51k Linux - Networking 4 08-09-2003 01:32 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 02:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration