LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 10-13-2004, 10:23 AM   #16
Dooley
Member
 
Registered: Jun 2004
Location: Lighting Capitol Of The World
Distribution: Debian
Posts: 56

Original Poster
Rep: Reputation: 15

Otis, I did what you suggested and got the busy error again
with the floppy. I then went to console and as root entered
lsof -V /dev/fd with the error bash command not found.
I then installed lsof -V /dev/fd with urpmi from disk 1. I again
ran the command with the following:

COMMAND PID USER FD TYPE DEVICE SIZE NODE NAME
fam 2236 ed 187r DIR 2,0 7168 1 /mnt/floppy

Hope that tells you something, it sure is greek to me.

Dooley
 
Old 10-13-2004, 10:34 AM   #17
otish1000c
Member
 
Registered: May 2004
Location: Pennsylvania, USA
Distribution: dual boot.... Mandrake 10.0OE/10.xcooker
Posts: 611

Rep: Reputation: 30
okie dokie. now we're getting somewhere..........

Quote:
COMMAND PID USER FD TYPE DEVICE SIZE NODE NAME
fam 2236 ed 187r DIR 2,0 7168 1 /mnt/floppy
fam is the evil cultprit. it stands for File Alteration Monitor. kill that beast! ok, here's what ya do.........

in terminal as root type............. killall fam (hit enter) that will kill it.......or........you could type......... service fam stop (hit enter) to stop it. then, once it's dead, try the floppy. to be rid of FAM permanently, open Mandrake Control Center (IE: MCC)->system->services & look for FAM. uncheck the "startup at boot" box so it doesn't restart. you don't need FAM, you don't need a service to keep track if your files are being altered, unless you are running some type of high security system & want to keep track of those things.

please post back & let me know the results.

otis

Last edited by otish1000c; 10-13-2004 at 11:14 AM.
 
Old 10-13-2004, 11:06 AM   #18
Dooley
Member
 
Registered: Jun 2004
Location: Lighting Capitol Of The World
Distribution: Debian
Posts: 56

Original Poster
Rep: Reputation: 15
[QUOTE]Originally posted by otish1000c
okie dokie. now we're getting somewhere..........

Quote:
COMMAND PID USER FD TYPE DEVICE SIZE NODE NAME
fam 2236 ed 187r DIR 2,0 7168 1 /mnt/floppy[/code]

fam is the evil cultprit. it stands for File Alteration Monitor. kill that beast! ok, here's what ya do.........

in terminal as root type............. killall fam (hit enter) that will kill it.......or........you could type......... service fam stop (hit enter) to stop it. then, once it's dead, try the floppy. to be rid of FAM permanently, open Mandrake Control Center (IE: MCC)->system->services & look for FAM. uncheck the "startup at boot" box so it doesn't restart. you don't need FAM, you don't need a service to keep track if your files are being altered, unless you are running some type of high security system & want to keep track of those things.

please post back & let me know the results.

otis
Well, lets see what should your title be, got to be something
special. I will give that some great thought.

Otis, that worked like a charm. I was almost ready to give up
and just resolve to using the command line.

You have restored my faith.

Thank you, Thank you, Thank you
Dooley
 
Old 10-13-2004, 11:16 AM   #19
otish1000c
Member
 
Registered: May 2004
Location: Pennsylvania, USA
Distribution: dual boot.... Mandrake 10.0OE/10.xcooker
Posts: 611

Rep: Reputation: 30
glad we got it worked out. keep the faith........

w00t!

otis
 
Old 10-14-2004, 02:42 AM   #20
johnmart
Member
 
Registered: Jun 2004
Location: Jakarta
Distribution: Kubuntu 7.04
Posts: 35

Rep: Reputation: 15
I also have floppy problem-fam cure didn't work

I also have a floppy problem. I followed Dooleys advice to otish1000, but the fam cure didn't work. My problem may be a bit different. I also cannot mount/unmount, but I can't read any floppy's at all. Konqueror shows a blank panel, then aborts. I get similar results when I try to view /mnt. A spinning icon, then no show. If your patience has run out Dooley, anyone else have a sugg? Tx!!

here's fstab contents.
/dev/hda6 / ext3 defaults 1 1
none /dev/pts devpts mode=0620 0 0
/dev/hda8 /home ext3 defaults 1 2
none /mnt/cdrom supermount fs=udf:iso9660,dev=/dev/hdc,--,codepage=850,iocharset=iso8859-1,nosuid,ro,umask=0,nodev,exec 0 0
none /mnt/cdrom2 supermount fs=udf:iso9660,dev=/dev/hdd,--,codepage=850,iocharset=iso8859-1,nosuid,ro,umask=0,nodev,exec 0 0
none /mnt/floppy supermount fs=ext2:vfat,dev=/dev/fd0,--,codepage=850,iocharset=iso8859-1,nosuid,umask=0,unhide,nodev 0 0
/dev/hda1 /mnt/win_c ntfs umask=0,nls=iso8859-1,ro 0 0
/dev/hda5 /mnt/win_d vfat umask=0,iocharset=iso8859-1,codepage=850 0 0
none /proc proc defaults 0 0
/dev/hda7 swap swap defaults 0 0
 
Old 10-14-2004, 04:08 AM   #21
otish1000c
Member
 
Registered: May 2004
Location: Pennsylvania, USA
Distribution: dual boot.... Mandrake 10.0OE/10.xcooker
Posts: 611

Rep: Reputation: 30
look to the part in this thread where i gave dooley info on how to edit the floppy line in his fstab. but, before you do that, i'd suggest doing away with supermount. that was also mentioned early in this thread, so look for info on that. supermount can be very problematic........... not for all, but for many, including my experiences with it.

otis
 
Old 10-14-2004, 07:36 AM   #22
Dooley
Member
 
Registered: Jun 2004
Location: Lighting Capitol Of The World
Distribution: Debian
Posts: 56

Original Poster
Rep: Reputation: 15
Re: I also have floppy problem-fam cure didn't work

Quote:
Originally posted by johnmart
I also have a floppy problem. I followed Dooleys advice to otish1000, but the fam cure didn't work. My problem may be a bit different. I also cannot mount/unmount, but I can't read any floppy's at all. Konqueror shows a blank panel, then aborts. I get similar results when I try to view /mnt. A spinning icon, then no show. If your patience has run out Dooley, anyone else have a sugg? Tx!!

here's fstab contents.
/dev/hda6 / ext3 defaults 1 1
none /dev/pts devpts mode=0620 0 0
/dev/hda8 /home ext3 defaults 1 2
none /mnt/cdrom supermount fs=udf:iso9660,dev=/dev/hdc,--,codepage=850,iocharset=iso8859-1,nosuid,ro,umask=0,nodev,exec 0 0
none /mnt/cdrom2 supermount fs=udf:iso9660,dev=/dev/hdd,--,codepage=850,iocharset=iso8859-1,nosuid,ro,umask=0,nodev,exec 0 0
none /mnt/floppy supermount fs=ext2:vfat,dev=/dev/fd0,--,codepage=850,iocharset=iso8859-1,nosuid,umask=0,unhide,nodev 0 0
/dev/hda1 /mnt/win_c ntfs umask=0,nls=iso8859-1,ro 0 0
/dev/hda5 /mnt/win_d vfat umask=0,iocharset=iso8859-1,codepage=850 0 0
none /proc proc defaults 0 0
/dev/hda7 swap swap defaults 0 0
I feel honored, but it was Otis which was giving me advise.

Maybe you missed something in the instructions which Otis gave me.

The only way I could get the floppy to work was to go to MCC as root
and uncheck the box where fam was to run at start up. Then go to
Configure- Desktop-Behavior-Device Icons and uncheck the box at
mount floppy and unmount floppy. Right click Desktop and choose
New Device and choose Floppy, set the correct path from the
dropdown menu. I just let MDK set the path by just choosing /dev/fdo
as the path. This should give you a floppy icon on the desktop.

The floppy want mount and will give you an error if you don't insert
a floppy in the drive before you try to mount it. It also might not
write to the floppy until you unmount it.

This is my fstab after Otis gave me the code to enter in the floppy
line:

/dev/hda1 / ext3 defaults 1 1
none /dev/pts devpts mode=0620 0 0
/dev/hda6 /home ext3 defaults 1 2
/dev/hdb /mnt/cdrom auto umask=0,user,iocharset=iso8859-1,
codepage=850,noauto,ro,exec 0 0
/dev/fd0 /mnt/floppy auto noauto,user
none /proc proc defaults 0 0
none /proc proc defaults 0 0
none /proc proc defaults 0 0
/dev/hda5 swap swap defaults 0 0

See the line at /dev/fdo that is the only mod. made to fstab.

Cheers:
Dooley
 
Old 10-14-2004, 11:11 AM   #23
ernie
Senior Member
 
Registered: Nov 2001
Location: Toledo, Ohio - USA
Distribution: Mageia 1
Posts: 1,079
Blog Entries: 4

Rep: Reputation: 70
Actually, Mandrakelinux 10.0 and newer uses magicdev. Check that the magicdev package is installed. I just checked my floppy drive, and it works perfectly for me. I put a floppy in the drive, then opened the floppy icon, and was greeted with a konqueror window displaying the contents of the disk (after reading the floppy etc.). I then popped out the floppy and inserted another, then clicked the reload button near the top of the konqueror window. The right Payne blanked, the floppy LED lit, then the contents of the new floppy were displayed.

Sorry if this is not much help,
 
Old 10-14-2004, 11:47 PM   #24
johnmart
Member
 
Registered: Jun 2004
Location: Jakarta
Distribution: Kubuntu 7.04
Posts: 35

Rep: Reputation: 15
Hello all,
Sorry Otis for mistaken ID. Thanks for response.

I went back & disabled supermount - that is, I changed the fstab line for the floppy entry to the one you suggd. Is that all I have to do to disable supermount? Is there any need to disable it in the cd's--they work fine.
I removed the floppy icon from the desktop via rt click desktop>configure desktop>devices.

I rt clicked desktop & created a new device>floppy, when I double click the floppy icon I get the spinning drive, & empty konqueror pane; Rt click on the icon doesn't gives me any mount/unmount options,

mcc reports fam starts when requested - should that be deselected?

I'm confused about the difference between creating a new device via rt click desktop>create new device, and configure desktop>behavior>device icons. Is this 2 ways of doing the same process?


btw- ernie, magicdev is installed, this is the first it's been mentioned

Sorry if this is confusing--I'm a bit muddled at this point
Thanks for your attention all!
 
Old 10-15-2004, 04:12 AM   #25
otish1000c
Member
 
Registered: May 2004
Location: Pennsylvania, USA
Distribution: dual boot.... Mandrake 10.0OE/10.xcooker
Posts: 611

Rep: Reputation: 30
fstab.......... edit fstab as suggested in my prior post.

supermount.......... you have supermount listed in your fstab for all devices. to disable it, in terminal as root type......... supermount -i disable (enter). should you want to enable it again at some point, it's........ supermount -i enable.

fam............... go to Mandrake Control Center->system->services. look for FAM listed among the services. stop it from running & stop it from starting at boot. if it currently isn't running, just stop it from starting at boot, then reboot. since it's an "as needed" service, it might not be running when you check, but will start as needed if it was set to start at boot. if it's not listed in MCC, then type service fam stop in terminal as root.

device icons........... when you create the icon via the right click desktop method, you are creating a direct link to that device. the configure desktop->behaviour->devices options is a KDE specific thing. by checking or unchecking those various devices in that tab, that will show or not show those various devices on your desktop in the states listed (mounted or unmounted). by disabling supermount & creating your own icon, you will be able to mount & unmount the drives via that method. so......... you could then uncheck the "mounted/unmounted" devices stuff because the "right click" icon you created yourself is not part of those KDE specific desktop icons.

magic dev............ don't worry about magic dev. if it's installed on your system, leave it be & it will do no harm.

follow the above steps & you're floppy should become accessable.
 
Old 10-15-2004, 11:53 AM   #26
johnmart
Member
 
Registered: Jun 2004
Location: Jakarta
Distribution: Kubuntu 7.04
Posts: 35

Rep: Reputation: 15
Otis I followed all your advice & after an initial reboot it worked like a charm. But after another reboot, the floppy again spins forever trying to mount, till I cancel it. I checked fam status in mcc, & it was still deselected to start as needed, theres no start at boot option. edited fstab with your floppy path. It read floppy fine for one session but after restart same issue. Thanks for your patience.
 
Old 10-15-2004, 12:48 PM   #27
otish1000c
Member
 
Registered: May 2004
Location: Pennsylvania, USA
Distribution: dual boot.... Mandrake 10.0OE/10.xcooker
Posts: 611

Rep: Reputation: 30
please repost your fstab, in it's current state. and, are you sure you disabled uspermount? supermount -i disable? yes, that will disable it for all cd drives, too, but no biggie. you just mount/unmount them manually, via right click icon or CLI. let's see the fstab again, though.

oh, next time it happens (the spinning icon/no response), humour me & do lsof -V /dev/fd0 and lsof -V /mnt/floppy before you edit or reboot. i just want to be sure nothing is locking up that floppy drive. post the output of lsof here if relevant, too.

otis
 
Old 10-16-2004, 11:42 AM   #28
johnmart
Member
 
Registered: Jun 2004
Location: Jakarta
Distribution: Kubuntu 7.04
Posts: 35

Rep: Reputation: 15
Well, I restarted & floppy works like it should! Good news, but would like to find why it flopped & healed. If I disable supermount it's disabled until I enable, rt? My cd icons don't have mount/unmount options & if I double click'm they open. The floppy icon has mount, tho. Seems inconsistent. I will note the lsof commands in case it recurs. Til then, thanks--appreciate ur time & thoughts!
Here's my fstab contents.
/dev/hda6 / ext3 defaults 1 1
none /dev/pts devpts mode=0620 0 0
/dev/hda8 /home ext3 defaults 1 2
none /mnt/cdrom supermount fs=udf:iso9660,dev=/dev/hdc,--,codepage=850,iocharset=iso8859-1,nosuid,ro,umask=0,nodev,exec 0 0
none /mnt/cdrom2 supermount fs=udf:iso9660,dev=/dev/hdd,--,codepage=850,iocharset=iso8859-1,nosuid,ro,umask=0,nodev,exec 0 0
/dev/fd0 /mnt/floppy auto noauto,user
/dev/hda1 /mnt/win_c ntfs umask=0,nls=iso8859-1,ro 0 0
/dev/hda5 /mnt/win_d vfat umask=0,iocharset=iso8859-1,codepage=850 0 0
none /proc proc defaults 0 0
/dev/hda7 swap swap defaults 0 0
 
Old 10-17-2004, 02:44 AM   #29
johnmart
Member
 
Registered: Jun 2004
Location: Jakarta
Distribution: Kubuntu 7.04
Posts: 35

Rep: Reputation: 15
Sunday Morning I restarted my pc and unable to mount floppy again.
I ran lsof queries, here's the feedback.
[root@Main_PC john]# lsof -V /mnt/floppy
lsof: no file use located: /mnt/floppy
[root@Main_PC john]# lsof -V /dev/fd0
lsof: no file use located: /dev/fd0

I just looked at the help notes with supermount & noticed the -i switch (which you included in your comments) (that writes the change to fstab, rt?) & I'm not so sure I included the switch when I disabled supermount. Will give that a try & reboot. Sorry for thinking out loud here.
 
Old 10-17-2004, 04:51 AM   #30
otish1000c
Member
 
Registered: May 2004
Location: Pennsylvania, USA
Distribution: dual boot.... Mandrake 10.0OE/10.xcooker
Posts: 611

Rep: Reputation: 30
yes, the -i switch is needed for the supermount command. the -i enables write to fstab. without the -i switch, supermount will only turn off (or on) until the next reboot, where it will again be enabled because the fstab entries haven't changed.

otis
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
mount & unmounting a floppy disk swamprat Linux - Newbie 4 09-27-2005 09:25 PM
trouble unmounting floppy dr_zayus69 Linux - Software 6 10-20-2004 07:11 PM
Mandrake 7.2, unmounting floppy during shutdown Secret Agent X2 Linux - Laptop and Netbook 2 09-04-2004 09:34 PM
Trouble unmounting and ejecting during diablo 2 install lasalsademuerte Red Hat 4 02-07-2004 03:01 PM
Trouble unmounting 70k51k Linux - Networking 4 08-09-2003 01:32 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 02:19 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration