LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices


Reply
  Search this Thread
Old 01-26-2008, 09:59 AM   #1
sblantipodi
Member
 
Registered: May 2006
Distribution: Latest CentOS
Posts: 151

Rep: Reputation: 15
2.6.24 we need to switch from ipw3945 to iwl3945


Hi,
I have successfully configured my wlan under Fedora 8 using an intel pro wireless 3945 adapter with 2.6.23 vanilla kernel using ipw3945...

Now with 2.6.24 I need to switch from ipw3945 to iwl3945...
Sincerely I don't like iwl as ipw... but I need to switch

iwl seems to works ok but I've got some error when starting wpa_supplicant

Code:
service wpa_supplicant start Avvio di wpa_supplicant: /etc/wpa_supplicant/wpa_supplicant.conf, -iwlan0, -Dwextioctl[SIOCSIWAUTH]: Operation not supported WEXT auth param 4 value 0x0 - ioctl[SIOCSIWAUTH]: Operation not supported WEXT auth param 5 value 0x1 - [ OK ]

and then when I ifup wlan0
Code:
ifup wlan0 Error for wireless request "Set Mode" (8B06) : SET failed on device wlan0 ; Invalid argument.

network works well but I've got this two error and my intel wireless card led doesn't work anymore...
Is there someone who can help me please?
 
Old 01-26-2008, 10:41 AM   #2
Brian1
LQ Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 64
Post contents of your wpa_supplicant.conf file.

Brian
 
Old 01-26-2008, 12:35 PM   #3
sblantipodi
Member
 
Registered: May 2006
Distribution: Latest CentOS
Posts: 151

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Brian1 View Post
Post contents of your wpa_supplicant.conf file.

Brian
here my /etc/wpa_supplicant/wpa_supplicant.conf:
Code:
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=wheel

network={
    ssid="WhiteStar"
        scan_ssid=1
    key_mgmt=WPA-PSK
        group=TKIP
        psk=MYPASSWD
        mode=0
}
please help.
 
Old 01-27-2008, 06:35 AM   #4
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 420Reputation: 420Reputation: 420Reputation: 420Reputation: 420
Quote:
-Dwextioctl
That looks weird, but I can't tell if that is the command being run or if the error message is just concatenated with the command. At any rate, you probably want to take a good look at how wpa_supplicant is started.

Also, you did change your firmware, right? I've been using wpa_supplicant with iwl3945 without a problem, although it is on a patched 2.6.23 kernel.
 
Old 01-27-2008, 10:33 AM   #5
sblantipodi
Member
 
Registered: May 2006
Distribution: Latest CentOS
Posts: 151

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Hangdog42 View Post
That looks weird, but I can't tell if that is the command being run or if the error message is just concatenated with the command. At any rate, you probably want to take a good look at how wpa_supplicant is started.

Also, you did change your firmware, right? I've been using wpa_supplicant with iwl3945 without a problem, although it is on a patched 2.6.23 kernel.
no, with 2.6.23 wpa_supplicant works like a charm also on my pc...
this error message has appeared with 2.6.24 using built-in iwl driver...
 
Old 01-27-2008, 10:43 AM   #6
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 420Reputation: 420Reputation: 420Reputation: 420Reputation: 420
Quote:
Originally Posted by sblantipodi View Post
no, with 2.6.23 wpa_supplicant works like a charm also on my pc...
this error message has appeared with 2.6.24 using built-in iwl driver...
Sorry, I probably wasn't real clear on what I was suggesting you look at.....

the iwl3945 driver requires a new firmware install that you can get from the Intel site. My understanding is that if you didn't install the new firmware, it won't really work. The firmware for the ipw3945 (which you had suggested was being used prior) won't work with the iwl3945 driver. At least that is my understanding. And if you haven't upgraded your firmware, it might be part of the problem with wpa_supplicant.

The second issue was with the line you posted in your original post

-Dwextioctl

I don't believe that to be a legitimate flag for wpa_supplicant. It should be -Dwext. However, it is possible that in your wpa_supplicant startup, it is -Dwext and the error you posted is just having some formatting issues. At any rate, you should look at how wpa_supplicant is being started and make sure that hasn't gotten borked somewhere along the way.
 
Old 01-27-2008, 12:55 PM   #7
sblantipodi
Member
 
Registered: May 2006
Distribution: Latest CentOS
Posts: 151

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Hangdog42 View Post
Sorry, I probably wasn't real clear on what I was suggesting you look at.....

the iwl3945 driver requires a new firmware install that you can get from the Intel site. My understanding is that if you didn't install the new firmware, it won't really work. The firmware for the ipw3945 (which you had suggested was being used prior) won't work with the iwl3945 driver. At least that is my understanding. And if you haven't upgraded your firmware, it might be part of the problem with wpa_supplicant.
Ah ok, yes I have installed the firmware in /lib/firmware as mentioned in the readme file...

Quote:
The second issue was with the line you posted in your original post

-Dwextioctl

I don't believe that to be a legitimate flag for wpa_supplicant. It should be -Dwext. However, it is possible that in your wpa_supplicant startup, it is -Dwext and the error you posted is just having some formatting issues. At any rate, you should look at how wpa_supplicant is being started and make sure that hasn't gotten borked somewhere along the way.
This is my /etc/sysconfig/wpa_supplicant
Code:
INTERFACES="-iwlan0"
DRIVERS="-Dwext"
so as you can see there is no -Dwextioctl in my configuration file...
Have you tryed installing 2.6.24?
 
Old 01-27-2008, 05:47 PM   #8
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 420Reputation: 420Reputation: 420Reputation: 420Reputation: 420
You might try disabling the automated setup and try configuring and running everything from the command line. Maybe a better error message will show up.
Quote:
Have you tryed installing 2.6.24?
I've downloaded it, but I haven't given it a go yet. I might have time this week, and if I do, I'll certainly post the results.
 
Old 01-27-2008, 07:28 PM   #9
sblantipodi
Member
 
Registered: May 2006
Distribution: Latest CentOS
Posts: 151

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Hangdog42 View Post
You might try disabling the automated setup and try configuring and running everything from the command line. Maybe a better error message will show up.


I've downloaded it, but I haven't given it a go yet. I might have time this week, and if I do, I'll certainly post the results.
never used automated setup
 
Old 01-31-2008, 11:45 AM   #10
sblantipodi
Member
 
Registered: May 2006
Distribution: Latest CentOS
Posts: 151

Original Poster
Rep: Reputation: 15
no one solved the led problem using iwl3945???
It seems that all intel pro wireless has the same problem?
Have you found any workaround? I want my led on again
 
Old 01-31-2008, 11:59 AM   #11
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 420Reputation: 420Reputation: 420Reputation: 420Reputation: 420
Quote:
Originally Posted by sblantipodi View Post
no one solved the led
Have you found any workaround? I want my led on again
I prefer to think of the lack of the LED as a "green" approach to wireless. If I can get more LED's turned off, I can probably save a whole on my electric bill.
 
Old 01-31-2008, 01:22 PM   #12
sblantipodi
Member
 
Registered: May 2006
Distribution: Latest CentOS
Posts: 151

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Hangdog42 View Post
I prefer to think of the lack of the LED as a "green" approach to wireless. If I can get more LED's turned off, I can probably save a whole on my electric bill.
I will save energy turning off my tv led but I want my led on my wireless card
 
Old 05-11-2008, 06:04 AM   #13
Yako
LQ Newbie
 
Registered: May 2008
Posts: 4

Rep: Reputation: 0
I got ipw3945 to work on 2.6.24.

1. Download ipw3945 microcode (http://ipw3945.sourceforge.net) and copy it into /lib/firmware/(`uname -r`)/
2. Download ipw3945 regulatory daemon (http://ipw3945.sourceforge.net) and copy it into /sbin/
3. Download ipw3945 source (http://ipw3945.sourceforge.net)
4. Apply patch from http://james.colannino.org/downloads.html
5. Make & make install
6. Add these lines to /etc/modprobe.d/ipw3945 (Creating the file if it doesn’t exist)

install ipw3945 /sbin/modprobe –ignore-install ipw3945 ; sleep 0.5 ; /sbin/ipw3945d –quiet
remove ipw3945 /sbin/ipw3945d –kill ; /sbin/modprobe -r –ignore-remove ipw3945

7. modprobe ipw3945
8. blacklist iwl3945 (put ipw3945 into /etc/modprobe.d/blacklist)

And voila! ipw3945 on linux 2.6.24!
 
Old 05-11-2008, 06:23 AM   #14
sblantipodi
Member
 
Registered: May 2006
Distribution: Latest CentOS
Posts: 151

Original Poster
Rep: Reputation: 15
I think that IWL drivers in 2.6.25 should support the led...
Have you tryed it?
 
Old 05-11-2008, 07:15 AM   #15
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 420Reputation: 420Reputation: 420Reputation: 420Reputation: 420
Quote:
Originally Posted by Yako View Post
I got ipw3945 to work on 2.6.24.

1. Download ipw3945 microcode (http://ipw3945.sourceforge.net) and copy it into /lib/firmware/(`uname -r`)/
2. Download ipw3945 regulatory daemon (http://ipw3945.sourceforge.net) and copy it into /sbin/
3. Download ipw3945 source (http://ipw3945.sourceforge.net)
4. Apply patch from http://james.colannino.org/downloads.html
5. Make & make install
6. Add these lines to /etc/modprobe.d/ipw3945 (Creating the file if it doesn’t exist)

install ipw3945 /sbin/modprobe –ignore-install ipw3945 ; sleep 0.5 ; /sbin/ipw3945d –quiet
remove ipw3945 /sbin/ipw3945d –kill ; /sbin/modprobe -r –ignore-remove ipw3945

7. modprobe ipw3945
8. blacklist iwl3945 (put ipw3945 into /etc/modprobe.d/blacklist)

And voila! ipw3945 on linux 2.6.24!
OK, I'm confused. Why would you install ipw3945 (which is no longer supported by Intel) on a 2.6.24 kernel when you have a perfectly good iwl3945 driver (which is what will be supported by Intel going forward) built into the kernel?

Sorry, but replacing good software with obsolete software just doesn't make sense in my book.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
airodum-ng and iwl3945 Malachai.77 Linux - Laptop and Netbook 1 01-06-2008 01:58 AM
wpa_supplicant and iwl3945 alkos333 Slackware 1 12-17-2007 03:20 AM
iwl3945.ko paul_one Fedora 1 09-04-2007 09:25 AM
iwl3945 detects no wireless networks BogusTrumper Fedora 0 06-06-2007 11:29 AM
thread switch results in kernel stack switch superstition Linux - General 1 05-17-2005 11:48 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking

All times are GMT -5. The time now is 09:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration