Share your knowledge at the LQ Wiki.
Go Back > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Fedora This forum is for the discussion of the Fedora Project.


  Search this Thread
Old 08-21-2007, 09:35 PM   #1
LQ Newbie
Registered: Aug 2007
Posts: 14

Rep: Reputation: 0


I'm trying to compile my own kernel for Fedora 7 - which is going very well. Speed increases etc, but whenever I do I loose my wireless.

I've traced it back to both the stock kernel and also the src.rpm kernel from Fedora (!) is missing this module, so I'm having to go get it and build it.

My main question is this: do I need to grab it from anywhere special?
The main site ( requires a daemon - which I don't like the idea of - not to mention a quick browse of google says the iwl module is using the new wireless stack in the kernel, making the daemon unnecessary.

Sorry if this seems trivial, but I'm just starting to play around with the kernel, and would like any tips in that area too.. Is there a collected fedora module set about?
Do I need to make any special settings for Fedora?
Is it wise for me to jump ahead and use the - rather then sticking to the older 2.6.21 (I think I remember hearing Redhat back-port improvements, not sure if that's done in Fedora too)?

Thanks for your time.

Last edited by paul_one; 08-22-2007 at 09:40 AM.
Old 09-04-2007, 09:25 AM   #2
Registered: Jan 2006
Distribution: Debian Testing
Posts: 675

Rep: Reputation: 58
when you do a make menu config there is the 3945 driver under
network -> wireless on the new kernels if I remember correctly. I may not but I think that is where it is. It may require another driver in the kernel as well before it will show up. Make sure you put a 'm' next to it to get it to compile as a module if that is what you want. A 'y' will make it be compiled directly into the kernel.

Also, from what I've read and my own experiences the driver in the kernels (atleast the ones that are out atm) have problems with the 3945 card and are very hit or miss. Plus I don't know if you can enable monitor mode within the kernel driver. My recomendation would be to stay with compiling the driver yourself and moving the .ko file into the modules section after your kernel is compiled. This way you will have full control. I hope this helps in someway and I just moved back to fedora 7 so i haven't checked the kernels yet.



Also, a good starting point would be to take the lastest kernel in the repos and move the .config file over to your new kernel. Then do a make oldconfig (i think is the command) which should set just about everything up for you like it is in the old kernel, including the 3945 driver. After that you can do a make menuconfig and go in and tweak it like you'd like and remove all the crap you don't want.

If the make oldconfig doesn't enable the 3945 driver you might be looking for a kernel patch for it.

Let me know if you need any help.

Last edited by nomb; 09-04-2007 at 09:28 AM. Reason: after thought


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
iwl3945 detects no wireless networks BogusTrumper Fedora 0 06-06-2007 11:29 AM > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 07:36 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration