LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Wireless Networking (https://www.linuxquestions.org/questions/linux-wireless-networking-41/)
-   -   2.6.24 we need to switch from ipw3945 to iwl3945 (https://www.linuxquestions.org/questions/linux-wireless-networking-41/2-6-24-we-need-to-switch-from-ipw3945-to-iwl3945-616433/)

sblantipodi 01-26-2008 09:59 AM

2.6.24 we need to switch from ipw3945 to iwl3945
 
Hi,
I have successfully configured my wlan under Fedora 8 using an intel pro wireless 3945 adapter with 2.6.23 vanilla kernel using ipw3945...

Now with 2.6.24 I need to switch from ipw3945 to iwl3945...
Sincerely I don't like iwl as ipw... but I need to switch

iwl seems to works ok but I've got some error when starting wpa_supplicant

Code:

service wpa_supplicant start Avvio di wpa_supplicant: /etc/wpa_supplicant/wpa_supplicant.conf, -iwlan0, -Dwextioctl[SIOCSIWAUTH]: Operation not supported WEXT auth param 4 value 0x0 - ioctl[SIOCSIWAUTH]: Operation not supported WEXT auth param 5 value 0x1 - [ OK ]

and then when I ifup wlan0
Code:

ifup wlan0 Error for wireless request "Set Mode" (8B06) : SET failed on device wlan0 ; Invalid argument.

network works well but I've got this two error and my intel wireless card led doesn't work anymore...
Is there someone who can help me please?

Brian1 01-26-2008 10:41 AM

Post contents of your wpa_supplicant.conf file.

Brian

sblantipodi 01-26-2008 12:35 PM

Quote:

Originally Posted by Brian1 (Post 3035800)
Post contents of your wpa_supplicant.conf file.

Brian

here my /etc/wpa_supplicant/wpa_supplicant.conf:
Code:

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=wheel

network={
    ssid="WhiteStar"
        scan_ssid=1
    key_mgmt=WPA-PSK
        group=TKIP
        psk=MYPASSWD
        mode=0
}

please help.

Hangdog42 01-27-2008 06:35 AM

Quote:

-Dwextioctl
That looks weird, but I can't tell if that is the command being run or if the error message is just concatenated with the command. At any rate, you probably want to take a good look at how wpa_supplicant is started.

Also, you did change your firmware, right? I've been using wpa_supplicant with iwl3945 without a problem, although it is on a patched 2.6.23 kernel.

sblantipodi 01-27-2008 10:33 AM

Quote:

Originally Posted by Hangdog42 (Post 3036520)
That looks weird, but I can't tell if that is the command being run or if the error message is just concatenated with the command. At any rate, you probably want to take a good look at how wpa_supplicant is started.

Also, you did change your firmware, right? I've been using wpa_supplicant with iwl3945 without a problem, although it is on a patched 2.6.23 kernel.

no, with 2.6.23 wpa_supplicant works like a charm also on my pc...
this error message has appeared with 2.6.24 using built-in iwl driver...

Hangdog42 01-27-2008 10:43 AM

Quote:

Originally Posted by sblantipodi (Post 3036633)
no, with 2.6.23 wpa_supplicant works like a charm also on my pc...
this error message has appeared with 2.6.24 using built-in iwl driver...

Sorry, I probably wasn't real clear on what I was suggesting you look at.....

the iwl3945 driver requires a new firmware install that you can get from the Intel site. My understanding is that if you didn't install the new firmware, it won't really work. The firmware for the ipw3945 (which you had suggested was being used prior) won't work with the iwl3945 driver. At least that is my understanding. And if you haven't upgraded your firmware, it might be part of the problem with wpa_supplicant.

The second issue was with the line you posted in your original post

-Dwextioctl

I don't believe that to be a legitimate flag for wpa_supplicant. It should be -Dwext. However, it is possible that in your wpa_supplicant startup, it is -Dwext and the error you posted is just having some formatting issues. At any rate, you should look at how wpa_supplicant is being started and make sure that hasn't gotten borked somewhere along the way.

sblantipodi 01-27-2008 12:55 PM

Quote:

Originally Posted by Hangdog42 (Post 3036638)
Sorry, I probably wasn't real clear on what I was suggesting you look at.....

the iwl3945 driver requires a new firmware install that you can get from the Intel site. My understanding is that if you didn't install the new firmware, it won't really work. The firmware for the ipw3945 (which you had suggested was being used prior) won't work with the iwl3945 driver. At least that is my understanding. And if you haven't upgraded your firmware, it might be part of the problem with wpa_supplicant.

Ah ok, yes I have installed the firmware in /lib/firmware as mentioned in the readme file...

Quote:

The second issue was with the line you posted in your original post

-Dwextioctl

I don't believe that to be a legitimate flag for wpa_supplicant. It should be -Dwext. However, it is possible that in your wpa_supplicant startup, it is -Dwext and the error you posted is just having some formatting issues. At any rate, you should look at how wpa_supplicant is being started and make sure that hasn't gotten borked somewhere along the way.
This is my /etc/sysconfig/wpa_supplicant
Code:

INTERFACES="-iwlan0"
DRIVERS="-Dwext"

so as you can see there is no -Dwextioctl in my configuration file...
Have you tryed installing 2.6.24?

Hangdog42 01-27-2008 05:47 PM

You might try disabling the automated setup and try configuring and running everything from the command line. Maybe a better error message will show up.
Quote:

Have you tryed installing 2.6.24?
I've downloaded it, but I haven't given it a go yet. I might have time this week, and if I do, I'll certainly post the results.

sblantipodi 01-27-2008 07:28 PM

Quote:

Originally Posted by Hangdog42 (Post 3036968)
You might try disabling the automated setup and try configuring and running everything from the command line. Maybe a better error message will show up.


I've downloaded it, but I haven't given it a go yet. I might have time this week, and if I do, I'll certainly post the results.

never used automated setup :)

sblantipodi 01-31-2008 11:45 AM

no one solved the led problem using iwl3945???
It seems that all intel pro wireless has the same problem?
Have you found any workaround? I want my led on again :D

Hangdog42 01-31-2008 11:59 AM

Quote:

Originally Posted by sblantipodi (Post 3041277)
no one solved the led
Have you found any workaround? I want my led on again :D

I prefer to think of the lack of the LED as a "green" approach to wireless. If I can get more LED's turned off, I can probably save a whole :twocents: on my electric bill.:D

sblantipodi 01-31-2008 01:22 PM

Quote:

Originally Posted by Hangdog42 (Post 3041292)
I prefer to think of the lack of the LED as a "green" approach to wireless. If I can get more LED's turned off, I can probably save a whole :twocents: on my electric bill.:D

I will save energy turning off my tv led but I want my led on my wireless card :D

Yako 05-11-2008 06:04 AM

I got ipw3945 to work on 2.6.24.

1. Download ipw3945 microcode (http://ipw3945.sourceforge.net) and copy it into /lib/firmware/(`uname -r`)/
2. Download ipw3945 regulatory daemon (http://ipw3945.sourceforge.net) and copy it into /sbin/
3. Download ipw3945 source (http://ipw3945.sourceforge.net)
4. Apply patch from http://james.colannino.org/downloads.html
5. Make & make install
6. Add these lines to /etc/modprobe.d/ipw3945 (Creating the file if it doesn’t exist)

install ipw3945 /sbin/modprobe –ignore-install ipw3945 ; sleep 0.5 ; /sbin/ipw3945d –quiet
remove ipw3945 /sbin/ipw3945d –kill ; /sbin/modprobe -r –ignore-remove ipw3945

7. modprobe ipw3945
8. blacklist iwl3945 (put ipw3945 into /etc/modprobe.d/blacklist)

And voila! ipw3945 on linux 2.6.24!

sblantipodi 05-11-2008 06:23 AM

I think that IWL drivers in 2.6.25 should support the led...
Have you tryed it?

Hangdog42 05-11-2008 07:15 AM

Quote:

Originally Posted by Yako (Post 3149789)
I got ipw3945 to work on 2.6.24.

1. Download ipw3945 microcode (http://ipw3945.sourceforge.net) and copy it into /lib/firmware/(`uname -r`)/
2. Download ipw3945 regulatory daemon (http://ipw3945.sourceforge.net) and copy it into /sbin/
3. Download ipw3945 source (http://ipw3945.sourceforge.net)
4. Apply patch from http://james.colannino.org/downloads.html
5. Make & make install
6. Add these lines to /etc/modprobe.d/ipw3945 (Creating the file if it doesn’t exist)

install ipw3945 /sbin/modprobe –ignore-install ipw3945 ; sleep 0.5 ; /sbin/ipw3945d –quiet
remove ipw3945 /sbin/ipw3945d –kill ; /sbin/modprobe -r –ignore-remove ipw3945

7. modprobe ipw3945
8. blacklist iwl3945 (put ipw3945 into /etc/modprobe.d/blacklist)

And voila! ipw3945 on linux 2.6.24!

OK, I'm confused. Why would you install ipw3945 (which is no longer supported by Intel) on a 2.6.24 kernel when you have a perfectly good iwl3945 driver (which is what will be supported by Intel going forward) built into the kernel?

Sorry, but replacing good software with obsolete software just doesn't make sense in my book.


All times are GMT -5. The time now is 11:10 PM.