LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-18-2005, 03:52 AM   #1
mduser63
LQ Newbie
 
Registered: Mar 2005
Distribution: Xandros
Posts: 4

Rep: Reputation: 0
Problem installing KDE 3.4 with Konstruct


I'm trying to install KDE 3.4 using Konstruct. Everything goes fine until it trys to build KDEPIM. It gets through most of the build process, then exits with a series of errors that go something like this:

icalsslexer.l: In function 'sslex':
icalsslexer.l:94: error: request for member 'v_string in something not a structure or union
icalsslexer.l:101: error: request for member 'v_string in something not a structure or union
icalsslexer.c: At top level:
icalsslexer.c:1686: warning: no previous prototype for 'ssget_lineno'
icalsslexer.c:1695: warning: no previous prototype for 'ssget_in'
icalsslexer.c:1703: warning: no previous prototype for 'ssget_out'
icalsslexer.c:1711: warning: no previous prototype for 'ssget_leng'
icalsslexer.c:1720: warning: no previous prototype for 'ssget_text'
icalsslexer.c:1729: warning: no previous prototype for 'ssset_lineno'
icalsslexer.c:1741: warning: no previous prototype for 'ssset_in'
icalsslexer.c:1746: warning: no previous prototype for 'ssset_out'
icalsslexer.c:1751: warning: no previous prototype for 'ssget_debug'
icalsslexer.c:1756: warning: no previous prototype for 'ssset_debug'
icalsslexer.c:1762: warning: no previous prototype for 'sslex_destroy'
make[7]: *** [icalsslexer.lo] Error 1


Any insight as to what's going on, and how I can fix it? Alternatively, is there a way to tell Konstruct to skip installation of KDEPIM? I don't really care about it, as I won't use it, and don't mind not having it unless it's required for KDE to work.

Thanks!

Last edited by mduser63; 03-18-2005 at 03:56 AM.
 
Old 03-18-2005, 07:31 PM   #2
mduser63
LQ Newbie
 
Registered: Mar 2005
Distribution: Xandros
Posts: 4

Original Poster
Rep: Reputation: 0
I re-ran construct using make -k install to get it to keep going even if it was unable to make some packages. Assuming there are no other errors in the make process, is there any reason why this won't work? Like I said I don't care if KDEPIM works or not, as I won't be using it.
 
Old 03-19-2005, 02:15 AM   #3
inescapeableus
Member
 
Registered: Feb 2004
Location: Canada
Distribution: GNU/Linux Debian (Etch)
Posts: 319

Rep: Reputation: 30
I really do not have a solution for your issue but have you attempted to install KDE by source?
 
Old 03-19-2005, 01:22 PM   #4
mduser63
LQ Newbie
 
Registered: Mar 2005
Distribution: Xandros
Posts: 4

Original Poster
Rep: Reputation: 0
Well, I was trying to install from source, and that's when I got the error above. Anyway, I did make -k install to get the build process to keep going even if there were errors, and it finished last night (after about 2 days compiling on my 800 MHz machine). I was able to successfully run KDE 3.4, so it seems that everything's OK. I doubt the KDEPIM applications work correctly, but I'd just as soon not have them installed anyway, as I have no use for them. I would still like to know what was causing that problem however, just so I can learn.
 
Old 03-28-2005, 04:29 AM   #5
polrus
Member
 
Registered: Oct 2004
Location: Poland
Distribution: yoper
Posts: 53

Rep: Reputation: 15
i havce exactly the same proble - yoper linux 2.2 pre
 
Old 03-28-2005, 08:11 AM   #6
polrus
Member
 
Registered: Oct 2004
Location: Poland
Distribution: yoper
Posts: 53

Rep: Reputation: 15
ok i solved the problem and posted a bug report http://bugs.kde.org/show_bug.cgi?id=102670

let me know if it worked for U 2
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
problem installing KDE 3.4.1 using konstruct--urgent nagswarup Linux - General 2 06-15-2005 07:27 AM
Installing KDE with Konstruct electrobank Linux - Software 3 11-30-2004 08:18 AM
installing KDE 3.3.1 with konstruct NeoAndersn007 Linux - Software 5 11-09-2004 06:42 PM
Installing KDE with Konstruct floyd Linux - Software 1 10-27-2004 11:47 PM
Trouble installing KDE through Konstruct svanspal Linux - Newbie 0 10-01-2003 08:04 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 12:27 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration