LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Problem installing KDE 3.4 with Konstruct (https://www.linuxquestions.org/questions/linux-software-2/problem-installing-kde-3-4-with-konstruct-303071/)

mduser63 03-18-2005 03:52 AM

Problem installing KDE 3.4 with Konstruct
 
I'm trying to install KDE 3.4 using Konstruct. Everything goes fine until it trys to build KDEPIM. It gets through most of the build process, then exits with a series of errors that go something like this:

icalsslexer.l: In function 'sslex':
icalsslexer.l:94: error: request for member 'v_string in something not a structure or union
icalsslexer.l:101: error: request for member 'v_string in something not a structure or union
icalsslexer.c: At top level:
icalsslexer.c:1686: warning: no previous prototype for 'ssget_lineno'
icalsslexer.c:1695: warning: no previous prototype for 'ssget_in'
icalsslexer.c:1703: warning: no previous prototype for 'ssget_out'
icalsslexer.c:1711: warning: no previous prototype for 'ssget_leng'
icalsslexer.c:1720: warning: no previous prototype for 'ssget_text'
icalsslexer.c:1729: warning: no previous prototype for 'ssset_lineno'
icalsslexer.c:1741: warning: no previous prototype for 'ssset_in'
icalsslexer.c:1746: warning: no previous prototype for 'ssset_out'
icalsslexer.c:1751: warning: no previous prototype for 'ssget_debug'
icalsslexer.c:1756: warning: no previous prototype for 'ssset_debug'
icalsslexer.c:1762: warning: no previous prototype for 'sslex_destroy'
make[7]: *** [icalsslexer.lo] Error 1


Any insight as to what's going on, and how I can fix it? Alternatively, is there a way to tell Konstruct to skip installation of KDEPIM? I don't really care about it, as I won't use it, and don't mind not having it unless it's required for KDE to work.

Thanks!

mduser63 03-18-2005 07:31 PM

I re-ran construct using make -k install to get it to keep going even if it was unable to make some packages. Assuming there are no other errors in the make process, is there any reason why this won't work? Like I said I don't care if KDEPIM works or not, as I won't be using it.

inescapeableus 03-19-2005 02:15 AM

I really do not have a solution for your issue but have you attempted to install KDE by source?

mduser63 03-19-2005 01:22 PM

Well, I was trying to install from source, and that's when I got the error above. Anyway, I did make -k install to get the build process to keep going even if there were errors, and it finished last night (after about 2 days compiling on my 800 MHz machine). I was able to successfully run KDE 3.4, so it seems that everything's OK. I doubt the KDEPIM applications work correctly, but I'd just as soon not have them installed anyway, as I have no use for them. I would still like to know what was causing that problem however, just so I can learn.

polrus 03-28-2005 04:29 AM

i havce exactly the same proble - yoper linux 2.2 pre

polrus 03-28-2005 08:11 AM

ok i solved the problem and posted a bug report http://bugs.kde.org/show_bug.cgi?id=102670

let me know if it worked for U 2


All times are GMT -5. The time now is 10:00 AM.