LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-07-2005, 03:03 PM   #1
webwolf70
Member
 
Registered: Feb 2004
Distribution: Windows XP. I gave up with Linux & I left LQ.
Posts: 502

Rep: Reputation: 30
LimeWire error


I installed LimeWire with urpmi on Mandrake 10.0 official. When I try and click on the icon it doesn't do anything. When run it from the command line I get this error.


java.lang.ClassNotFoundException: error:
at kaffe.lang.AppClassLoader.findClass (AppClassLoader.java:296)
at java.lang.ClassLoader.loadClass (ClassLoader.java:142)


Java is installed in /usr/java/ Well jre 1.5 is..... What is missing?


Thanks

Webwolf
 
Old 03-07-2005, 03:28 PM   #2
kevinatkins
Member
 
Registered: Jan 2004
Location: cheshire, uk
Distribution: Ubuntu Hoary
Posts: 605

Rep: Reputation: 33
hi,

i seem to remember something similar when attempting to install from rpm..

i'd recommend going to the LimeWire website and grabbing a copy of the latest version and installing that instead (if nothing else, the rpm version for mandrake 10 will be quite old now)...

the only downside is that you'll have to set up a menu entry manually...
 
Old 03-07-2005, 03:58 PM   #3
webwolf70
Member
 
Registered: Feb 2004
Distribution: Windows XP. I gave up with Linux & I left LQ.
Posts: 502

Original Poster
Rep: Reputation: 30
Ok. I will give that a try. I tried it with Conectiva and it worked great so it might be because it is an older version of LimeWire. Thanks.


Webwolf
 
Old 03-07-2005, 07:41 PM   #4
webwolf70
Member
 
Registered: Feb 2004
Distribution: Windows XP. I gave up with Linux & I left LQ.
Posts: 502

Original Poster
Rep: Reputation: 30
Tried it. This is what I get at the command line.



java.lang.NoSuchMethodError: java/awt/Toolkit.createImage(Ljava/net/URLLjava/awt/Image;
at com.limegroup.gnutella.gui.Main.showInitialSplash (Main.java:52)
at com.limegroup.gnutella.gui.Main.main (Main.java:26)
at java.lang.reflect.Method.invoke0 (Method.java)
at java.lang.reflect.Method.invoke (Method.java:255)
at kaffe.jar.ExecJarName.main (ExecJarName.java:67)
at kaffe.jar.ExecJar.main (ExecJar.java:75)
runLime.sh: line 26: unexpected EOF while looking for matching `"'
runLime.sh: line 30: syntax error: unexpected end of file



Webwolf
 
Old 03-08-2005, 07:49 PM   #5
webwolf70
Member
 
Registered: Feb 2004
Distribution: Windows XP. I gave up with Linux & I left LQ.
Posts: 502

Original Poster
Rep: Reputation: 30
This is getting annoying. No matter what I do I cannot get LimeWire to work. Bittorrent works fine, and LimeWire works great with Conectiva but I cannot get it to work, any version, with Mandrake 10.0 Official. I keep getting errors like above. Anyone have any idea how I can fix this, even if you have to just give me guess or something. I am willing to try anything including dancing in a circle and holding my computer while chanting to the linux gods, lol.


Webwolf
 
Old 03-08-2005, 08:54 PM   #6
mrcheeks
Senior Member
 
Registered: Mar 2004
Location: far enough
Distribution: OS X 10.6.7
Posts: 1,690

Rep: Reputation: 52
you are using kaffe as java virtual machine.
Uninstall those below if you got them
- kaffe virtual machine(it seems it is what you have)
- gcj/gij

install the binary from(java.sun.com), the jre as you are not a java programmer. Select the rpm for a rpm based distro. You could also install the jre from IBM or Blackdown.
 
Old 03-08-2005, 10:26 PM   #7
webwolf70
Member
 
Registered: Feb 2004
Distribution: Windows XP. I gave up with Linux & I left LQ.
Posts: 502

Original Poster
Rep: Reputation: 30
I am getting somewhere now. I had java and kaffe both installed so I guess there was a conflict. I unistalled kaffe and it is still not working but I am getting a different error message now, so this is getting better...... That sounds wrong, lol. Well here is the message.


/usr/bin/limewire: error: failed to set JAVACMD
/usr/bin/limewire: line 135: -mx32m: command not found



I re-installed java and then limewire and got the above error. Also thanks for posting this. I am really a bad dancer, and after re-reading this post apparently I am not good with humor either, lol.


Webwolf

Last edited by webwolf70; 03-08-2005 at 10:27 PM.
 
Old 03-09-2005, 08:11 PM   #8
zab
LQ Newbie
 
Registered: Mar 2005
Location: Big Apple
Distribution: FC
Posts: 12

Rep: Reputation: 0
We recently released a new RPM (4.8.1) which supposedly contains menu entries for Mandrake (hasn't been tested since we don't have a mdk box available). Please give that a try and see if helps
 
Old 03-09-2005, 08:42 PM   #9
webwolf70
Member
 
Registered: Feb 2004
Distribution: Windows XP. I gave up with Linux & I left LQ.
Posts: 502

Original Poster
Rep: Reputation: 30
Is that the RPM at the LimeWire website?

Webwolf
 
Old 03-09-2005, 10:37 PM   #10
zab
LQ Newbie
 
Registered: Mar 2005
Location: Big Apple
Distribution: FC
Posts: 12

Rep: Reputation: 0
Yes. That rpm will always be the most up-to-date; I have no idea what the various repositories might carry.
 
Old 03-09-2005, 10:42 PM   #11
webwolf70
Member
 
Registered: Feb 2004
Distribution: Windows XP. I gave up with Linux & I left LQ.
Posts: 502

Original Poster
Rep: Reputation: 30
I installed it and it works. But I don't see an entry in the menu and the only way it works is if I run it from the command line. But it DOES work, finally, lol. Thanks.


Webwolf
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
limewire error liljhand Linux - Software 12 02-02-2005 03:27 PM
More Limewire... install error ewto Linux - Software 14 12-07-2004 01:31 AM
limewire / javavm error jasonmcneil0 Linux - Software 4 08-11-2004 04:33 PM
Getting error when trying to install LimeWire.bin mcaldwell Linux - Newbie 3 11-10-2003 01:11 AM
anyone heard of this error while starting LimeWire? therion12 Linux - Networking 4 01-08-2002 07:06 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:02 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration