LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   LimeWire error (https://www.linuxquestions.org/questions/linux-software-2/limewire-error-298809/)

webwolf70 03-07-2005 03:03 PM

LimeWire error
 
I installed LimeWire with urpmi on Mandrake 10.0 official. When I try and click on the icon it doesn't do anything. When run it from the command line I get this error.


java.lang.ClassNotFoundException: error:
at kaffe.lang.AppClassLoader.findClass (AppClassLoader.java:296)
at java.lang.ClassLoader.loadClass (ClassLoader.java:142)


Java is installed in /usr/java/ Well jre 1.5 is..... What is missing?


Thanks

Webwolf

kevinatkins 03-07-2005 03:28 PM

hi,

i seem to remember something similar when attempting to install from rpm..

i'd recommend going to the LimeWire website and grabbing a copy of the latest version and installing that instead (if nothing else, the rpm version for mandrake 10 will be quite old now)...

the only downside is that you'll have to set up a menu entry manually...

webwolf70 03-07-2005 03:58 PM

Ok. I will give that a try. I tried it with Conectiva and it worked great so it might be because it is an older version of LimeWire. Thanks.


Webwolf

webwolf70 03-07-2005 07:41 PM

Tried it. This is what I get at the command line.



java.lang.NoSuchMethodError: java/awt/Toolkit.createImage(Ljava/net/URL;)Ljava/awt/Image;
at com.limegroup.gnutella.gui.Main.showInitialSplash (Main.java:52)
at com.limegroup.gnutella.gui.Main.main (Main.java:26)
at java.lang.reflect.Method.invoke0 (Method.java)
at java.lang.reflect.Method.invoke (Method.java:255)
at kaffe.jar.ExecJarName.main (ExecJarName.java:67)
at kaffe.jar.ExecJar.main (ExecJar.java:75)
runLime.sh: line 26: unexpected EOF while looking for matching `"'
runLime.sh: line 30: syntax error: unexpected end of file



Webwolf

webwolf70 03-08-2005 07:49 PM

This is getting annoying. No matter what I do I cannot get LimeWire to work. Bittorrent works fine, and LimeWire works great with Conectiva but I cannot get it to work, any version, with Mandrake 10.0 Official. I keep getting errors like above. Anyone have any idea how I can fix this, even if you have to just give me guess or something. I am willing to try anything including dancing in a circle and holding my computer while chanting to the linux gods, lol.


Webwolf

mrcheeks 03-08-2005 08:54 PM

you are using kaffe as java virtual machine.
Uninstall those below if you got them
- kaffe virtual machine(it seems it is what you have)
- gcj/gij

install the binary from(java.sun.com), the jre as you are not a java programmer. Select the rpm for a rpm based distro. You could also install the jre from IBM or Blackdown.

webwolf70 03-08-2005 10:26 PM

I am getting somewhere now. I had java and kaffe both installed so I guess there was a conflict. I unistalled kaffe and it is still not working but I am getting a different error message now, so this is getting better...... That sounds wrong, lol. Well here is the message.


/usr/bin/limewire: error: failed to set JAVACMD
/usr/bin/limewire: line 135: -mx32m: command not found



I re-installed java and then limewire and got the above error. Also thanks for posting this. I am really a bad dancer, ;) and after re-reading this post apparently I am not good with humor either, lol.


Webwolf

zab 03-09-2005 08:11 PM

We recently released a new RPM (4.8.1) which supposedly contains menu entries for Mandrake (hasn't been tested since we don't have a mdk box available). Please give that a try and see if helps

webwolf70 03-09-2005 08:42 PM

Is that the RPM at the LimeWire website?

Webwolf

zab 03-09-2005 10:37 PM

Yes. That rpm will always be the most up-to-date; I have no idea what the various repositories might carry.

webwolf70 03-09-2005 10:42 PM

I installed it and it works. But I don't see an entry in the menu and the only way it works is if I run it from the command line. But it DOES work, finally, lol. Thanks.


Webwolf


All times are GMT -5. The time now is 01:23 AM.