LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 12-08-2004, 04:26 PM   #1
alexmihai
LQ Newbie
 
Registered: May 2004
Distribution: Suse 9.2
Posts: 12

Rep: Reputation: 0
kde starts only as root


I've been googling for some time and didn't find any solution.... Here goes my problem:
At the login dialog in KDE when I choose a regular user, the dialog disappears, but nothing happens. As root everything goes just fine.
This is the .xsession-errors from the regular user's home, after trying to start kde (alex is the normal user):

xset: unable to open display ":0.0"
xsetroot: unable to open display ':0.0'
Error: "/tmp/kde-alex" is not a directory.
Error: Can not create directory "".
Error: "/tmp/ksocket-alex" is not a directory.
Error: Can not create directory "".
startkde: Starting up...
startkde: Running kpersonalizer...
SocketUNIXCreateListener: mkdir(/tmp/.ICE-unix) failed, errno = 13
MakeAllCOTSServerListeners: failed to create listener for local
Cannot establish any listening sockets
DCOPServer self-test failed.
kwin: cannot connect to X server :0.0
kpersonalizer: cannot connect to X server :0.0
kpersonalizer: cannot connect to X server :0.0
kpersonalizer: cannot connect to X server :0.0
kpersonalizer: cannot connect to X server :0.0
kpersonalizer: cannot connect to X server :0.0
kpersonalizer: cannot connect to X server :0.0

I've tried xhost +localhost but it didn't work. Any ideas?
Thank you for your help.
PS: I'm running (or trying to run) Gentoo with xorg 6.8.0-r1, kde 3.3.0
 
Old 12-08-2004, 04:29 PM   #2
marghorp
Senior Member
 
Registered: Jan 2004
Location: Slovenia
Distribution: Slackware 10.1, SLAX to the MAX :)
Posts: 1,040

Rep: Reputation: 45
Are you running the Xserver? Refer to gentoos manual on how to install KDE with Xserver. It's on thei rwebpage under post install instructions.
 
Old 12-08-2004, 04:32 PM   #3
kilgoretrout
Senior Member
 
Registered: Oct 2003
Posts: 2,985

Rep: Reputation: 388Reputation: 388Reputation: 388Reputation: 388
Try creating a new user and see if the new user works.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
GUI only starts as root xri Linux - Newbie 3 04-03-2005 11:14 AM
Eclipse 3.0 starts only as root netjack Linux - Software 1 03-16-2004 02:09 PM
modem only starts in root twcinpa Linux - General 2 12-08-2003 12:41 AM
kde starts for root, not for user tjpick Slackware 3 08-14-2003 02:14 AM
x only starts as root kaise Linux - General 4 11-04-2002 06:08 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 02:39 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration