LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-16-2004, 02:27 PM   #1
netjack
Member
 
Registered: Sep 2003
Location: Italy
Distribution: ubuntu 12.04 64 bit
Posts: 93

Rep: Reputation: 15
Eclipse 3.0 starts only as root


Hello,

I had a look at some Eclipse 3.0 topics in this forum, but I am not sure the answers apply to my problem.

I'm running Fedora 1 Core and I downloaded eclipse 3.0. I put it into my /home/user directory. I did this as user, not as root.

However, I can't run ./eclipse other than if I am root. Anything else gives me the following error:

[user@localhost eclipse]$ ./eclipse
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

Error: Couldn't find per display information
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

Error: Can't open display: :0.0
[user@localhost eclipse]$

What do I have to change and where, so that I can run eclipse as user, too?

Thanks in advance
Netjack
 
Old 03-16-2004, 03:09 PM   #2
netjack
Member
 
Registered: Sep 2003
Location: Italy
Distribution: ubuntu 12.04 64 bit
Posts: 93

Original Poster
Rep: Reputation: 15
I found out by myself:

When you install (i.e. copy the folder eclipse), make sure you're logged in as user . If you're logged as root, place the folder in for e.g. /home/user and then try to run it as user, it doesn't work.

Netjack
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Eclipse IDE - can only run as root not as user JonnyW247 Linux - Software 10 05-28-2016 08:17 PM
running tomcat with eclipse as non-root javcerty Linux - Newbie 4 04-16-2009 01:09 PM
i startup eclipse (as root), but it goes down.. it driver me crazy , help me please!! dreams Linux - Software 2 10-20-2005 04:22 AM
running tomcat with eclipse as non-root user javcerty Linux - Software 1 03-05-2005 08:36 PM
x only starts as root kaise Linux - General 4 11-04-2002 07:08 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 12:00 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration