Share your knowledge at the LQ Wiki.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 09-07-2005, 04:45 AM   #1
Registered: Nov 2004
Location: Algeria
Posts: 111

Rep: Reputation: 15
Why my mouse, keyboard,... stopped!!!

Since a few weeks ago, after starting my PC and start to work i got this message below:

"Sep 5 09:04:56 localhost kernel: Badness in interruptible_sleep_on_timeout at kernel/sched.c:2988
Sep 5 09:04:56 localhost kernel: [<c0300047>] interruptible_sleep_on_timeout+0x5d/0x1da
Sep 5 09:04:56 localhost kernel: [<c011b9ea>] default_wake_function+0x0/0xc
Sep 5 09:04:56 localhost kernel: [<c0121219>] reparent_to_init+0x123/0x127
Sep 5 09:04:56 localhost kernel: [<c0121396>] allow_signal+0xfe/0x198
Sep 5 09:04:56 localhost kernel: [<d8889e3e>] rtl8139_thread+0x38/0x13f [8139too]
Sep 5 09:04:56 localhost kernel: [<d8889e06>] rtl8139_thread+0x0/0x13f [8139too]
Sep 5 09:04:56 localhost kernel: [<c01041d9>] kernel_thread_helper+0x5/0xb
Sep 5 09:04:56 localhost kernel: ACPI: PCI interrupt 0000:00:1f.5[B] -> GSI 10 (level, low) -> IRQ 10"

What is my mistake??
Did i changed anything?

Can you help me !!!
Old 09-07-2005, 06:54 AM   #2
Registered: Jul 2005
Distribution: Debian Sarge/Etch, (K)Ubuntu, FC6, AIX5.3, VMWare ESXServer
Posts: 159

Rep: Reputation: 30
8139 refers to the realtek network card that your using. very common card.

the fact that you've got ACPI errors in there as well might suggest that its got something to do with 'wake-on-lan' (backed up by default_wake_function)

this is just purely a guess by the way. i don't know what you've changed. try disabling wake on lan in your bios...

when do you get this error message? during boot or later on once you've actually booted up?

hope that sheds some light on your problem
Old 09-07-2005, 11:14 AM   #3
Registered: Nov 2004
Location: Algeria
Posts: 111

Original Poster
Rep: Reputation: 15
thanks for your reply by the way.

I 've got this problem once i booted up. In fact after working with my PC for a while and sometimes i got this problem when i let my PC "switched on" without touching it for a while.

Thanks pats
I appreciate your help .

I will go to the bios and disable as you said "wake on lan", i don't know what's the meaning of it but i'll search for it and disable it.
appreciate once again.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
keyboard and mouse stopped working completely in kernel 2.6.9-5.ELsmp Antony_wind Linux - Software 3 08-26-2005 01:56 PM
Keyboard stopped working toaster.waffle Linux - Hardware 2 05-27-2005 01:11 PM
extra keyboard keys stopped working kaega2 Linux - Software 3 04-16-2005 10:57 PM
Keyboard stopped working after Xfree86 Update doslucky Linux - Hardware 2 10-24-2004 02:11 PM
Num-pad on keyboard stopped functioning? l0f33t Linux - Newbie 1 05-25-2003 11:17 AM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 10:46 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration