LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 06-09-2005, 01:09 PM   #16
supermyself
LQ Newbie
 
Registered: May 2005
Posts: 17

Rep: Reputation: 0

Quote:
Im not able to login throught telnet as root?
That's because of security consideration.
I suggest you login throught telnet as user and then su to root.

Of course you could allow others to telnet to your linux as root by correct configurations.
But I forgot how...
 
Old 08-26-2005, 03:32 AM   #17
dylan912
LQ Newbie
 
Registered: Dec 2004
Distribution: Redhat
Posts: 18

Rep: Reputation: 0
mv /etc/securetty /opt/

- dylan912

Quote:
Originally posted by devilzgaze
Im not able to login throught telnet as root?

any ideas where to check for it?
 
Old 12-30-2005, 10:53 AM   #18
kadhiravan.r
Member
 
Registered: Nov 2004
Location: india/tamil nadu/chennai
Distribution: Linux 8.0
Posts: 37

Rep: Reputation: 15
good..


Move /etc/securetty file to some other place.



kadhirava.R
 
Old 12-04-2006, 10:27 PM   #19
hodge
LQ Newbie
 
Registered: Dec 2006
Posts: 2

Rep: Reputation: 0
Question hi,I enable the krb5-telnet service,but root user can't login

1.I modify the disable=no
2.mv /etc/securetty /etc/securetty.bak,
3.vi /etc/pam.d/login and mark the first line
'#auth required pam_securetty.so
auth required pam_stack.so service=system-auth'
4./etc/init.d/xinetd restart
OK
5.chkconfig --list
gssftp: off
daytime-udp: off
krb5-telnet: on
time-udp: off
but when I use root user to telnet,report
login: root
Password for root:
Login incorrect
and use other user,can login with telnet.

Can you tell me how to root login?????
thank you
 
Old 04-27-2007, 04:32 AM   #20
keen4linux
LQ Newbie
 
Registered: Feb 2005
Location: Ahmedabad , India
Posts: 13

Rep: Reputation: 0
Quote:
Originally Posted by gurdip
Hi,

I too have a 530 error on my Redhat machine using webmin.

I have included some possibly relevant info below:

rpm -qa | grep -i ftp
lftp-3.0.6-3
ftp-0.17-22
vsftpd-2.0.1-5

Do I need to install a ftp daemon? Not sure if it is installed and if it is not, I have no idea how to install it!

Under Extended Internet Service -> FTP, the service program appears as : /usr/kerberos/sbin/ftpd -l


Contents of gssftp

# default: off
# description: The kerberized FTP server accepts FTP connections \
# that can be authenticated with Kerberos 5.
service ftp
{
flags = REUSE
log_on_failure += USERID
socket_type = stream
user = root
server = /usr/kerberos/sbin/ftpd
server_args = -1
wait = no
}

I restarted xinetd service when I made changes.

After removing the -a as mentioned in the posts above, ftp connection produces this error:

connecting to 202.71.98.48 ...
Connected to 202.71.98.48 port 21
ftpd: invalid option -- 1
ftpd: Unknown flag -1 ignored.
220 www.mydomain.com FTP server (Version 5.60) ready.
! Receive error: Blocking call cancelled

! Connection failed


The "-1" is being ignored for some reason.

Please help!

Thanks in advance.


The value of "server_args" should be set to '-l' not '-1'. I think this is the only problem.

All the best
 
Old 12-04-2007, 10:14 PM   #21
yowalter
LQ Newbie
 
Registered: Dec 2007
Posts: 1

Rep: Reputation: 0
Exclamation FTP problems : 500 'AUTH GSSAPI': command not understood

You must use :
ftp -u <ftp site>
when loggin .. use PASSIVE command

example:

$ ftp -d -t -u ftp.example.gov.ar
Connected to ftp.example.gov.ar.
220 ns1 Microsoft FTP Service (Version 5.0).
---> SYST
530 Please login with USER and PASS.
ftp>
ftp> user
(username) example
---> USER example
331 Password required for example.
Password:
---> PASS XXXX
230 User example logged in.
ftp> passive
Passive mode off.
ftp>

Regards
 
Old 09-22-2008, 07:57 AM   #22
Dunhill
LQ Newbie
 
Registered: Jul 2005
Posts: 22

Rep: Reputation: 15
Try SFTP?

I am not using FTP on redhat 9 at the moment, I am using SFTP on RHEL 5.

I initially also have problem when using FTP on RHEL 5. SELINUX banned FTP access into the home directory and considered it as an intrusion attack.

(I found this thread when I troubleshooting my problem, I just realized it is several years ago... )

In my case, I can disable the SELINUX and force FTP to work. However, after I found out I can use SFTP to log into my Linux, I used it.



If everything else, for example:

1. no firewall,
2. ftp server like vsftpd is on, and
3. ftp clients like gssftp is not automatically active

is correct, do u wanna a try disabling SELINUX, temporarily?

Just for ur info, because I did not think SELINUX caused my FTP fail when I use RH 9 a couple of years ago.
 
Old 09-22-2008, 07:24 PM   #23
chrism01
Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.5, Centos 5.10
Posts: 16,225

Rep: Reputation: 2021Reputation: 2021Reputation: 2021Reputation: 2021Reputation: 2021Reputation: 2021Reputation: 2021Reputation: 2021Reputation: 2021Reputation: 2021Reputation: 2021
SELINUX didn't exist when RH9 came out....
 
Old 09-24-2008, 08:46 AM   #24
Dunhill
LQ Newbie
 
Registered: Jul 2005
Posts: 22

Rep: Reputation: 15
Lol

Quote:
Originally Posted by chrism01 View Post
SELINUX didn't exist when RH9 came out....
I did not reliaze that... Too long did not use RH9 already... LOL

Hope our friend has solved his problem. Just now I double checked seems this problem is really a few years away from now liao..
 
Old 07-22-2009, 06:37 AM   #25
pkrishna2k
LQ Newbie
 
Registered: Jul 2009
Posts: 1

Rep: Reputation: 0
login incorrect in telnet

edit the file /etc/securetty

#vi /etc/securetty

vc/1
vc/2
vc/3
vc/4
vc/5
vc/6
vc/7
vc/8
vc/9
vc/10
vc/11
tty1
tty2
tty3
tty4
tty5
tty6
tty7
tty8
tty9
tty10
tty11
pts/0 ---- add this line
pts/1 ---- add this line

esc:
:wq

Enjoy
 
Old 06-22-2010, 02:40 PM   #26
4L3X
LQ Newbie
 
Registered: Jun 2010
Location: NYC
Distribution: Debian
Posts: 4

Rep: Reputation: 1
I personnaly solved this (under Red Hat Entreprise AS release4 ) by editing this file:

vi /etc/security/pam_winbind.conf

and changing Kerberos identification to "no"
;krb5_auth = no

Then reboot the server
 
Old 06-22-2010, 06:17 PM   #27
John VV
Guru
 
Registered: Aug 2005
Posts: 12,608

Rep: Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677
4L3X ?? you do know that this is a 6 year old thread ????
and for the dead rh9 not RHEL4
 
Old 06-23-2010, 08:57 AM   #28
4L3X
LQ Newbie
 
Registered: Jun 2010
Location: NYC
Distribution: Debian
Posts: 4

Rep: Reputation: 1
Thumbs down

Ouch!

I've seen that, but you also can see answers from less than a year / and I did not find answers elsewhere.

Feel free to delete if you think the post lacks information and is polluting somehow
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Telnet & FTP localhost connects then hangs Derekeigentek Linux - Newbie 3 12-30-2005 10:46 AM
Telnet & FTP dvong3 Solaris / OpenSolaris 2 07-09-2003 05:44 PM
ftp & telnet 127.0.0.1 aren't working rinux Linux - Newbie 5 05-24-2003 06:18 PM
WU-Ftp & Telnet TheVicar Linux - Software 2 07-12-2002 01:10 PM
Slow Telnet & FTP SkYzOpReNiCk Linux - Networking 1 04-17-2001 12:12 PM


All times are GMT -5. The time now is 06:18 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration