LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-04-2009, 01:46 PM   #1
Luxr
Member
 
Registered: Jun 2009
Distribution: Slackware Current
Posts: 30

Rep: Reputation: 15
headphone problem on slackware 12.2


Greetings.

Hello all, i got problem on my PC. i installed slackware 12.2 64 bit.
but i got problem with these. i also to check on terminal with code: alsamixer but headphone seem block or not in use.
i tried for install alsa with high version(v1.0.19) but that no make changes.
any advice for fix it Bro?
thanks before..

-Joy-
 
Old 07-04-2009, 01:51 PM   #2
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 12,892
Blog Entries: 27

Rep: Reputation: 2183Reputation: 2183Reputation: 2183Reputation: 2183Reputation: 2183Reputation: 2183Reputation: 2183Reputation: 2183Reputation: 2183Reputation: 2183Reputation: 2183
Hi,

You did make the changes to the 'alsamixer' as root from the cli? Then 'alsactl store'?
 
Old 07-05-2009, 03:41 AM   #3
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Quote:
Originally Posted by onebuck View Post
Hi,

You did make the changes to the 'alsamixer' as root from the cli? Then 'alsactl store'?
You shouldn't need to run alsamixer as root.
 
Old 07-05-2009, 07:52 AM   #4
Luxr
Member
 
Registered: Jun 2009
Distribution: Slackware Current
Posts: 30

Original Poster
Rep: Reputation: 15
i was tried it. but didn't get change
1st i used, slackware 12.2 32bit but my RAM isn't full detect.
this my PC specification part:
i used Quad core intel processor 9550 and 8GB RAM@DDR2
but i checking it on terminal with this code " cat /proc/meminfo"
there is available only 3GB++
So, i try with 64 bit version that's fix my memory detected. but headphone still problem.
I think after i changed to 64bit i fix overall my problem. my driver sound is "Intel Corporation 82801JI (ICH10 Family)"
i got this result with this code "lspci"
what i must to update kernel version?
please give me another solution, what should i do?

Last edited by Luxr; 07-05-2009 at 09:49 AM.
 
Old 07-05-2009, 09:14 AM   #5
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 12,892
Blog Entries: 27

Rep: Reputation: 2183Reputation: 2183Reputation: 2183Reputation: 2183Reputation: 2183Reputation: 2183Reputation: 2183Reputation: 2183Reputation: 2183Reputation: 2183Reputation: 2183
Hi,
Quote:
Originally Posted by Nylex View Post
You shouldn't need to run alsamixer as root.
Setting up the mixer and saving will insure that all users will have the settings. That is if the users are in the proper groups.
 
Old 07-12-2009, 08:13 AM   #6
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Quote:
Originally Posted by onebuck View Post
Hi,


Setting up the mixer and saving will insure that all users will have the settings. That is if the users are in the proper groups.
Fair enough. I only have one user, so.. .
 
Old 07-12-2009, 11:35 AM   #7
jelezarov
LQ Newbie
 
Registered: Nov 2007
Location: /dev/urandom
Distribution: Slackware
Posts: 26

Rep: Reputation: 17
Quote:
Originally Posted by Luxr View Post
i used Quad core intel processor 9550 and 8GB RAM@DDR2
but i checking it on terminal with this code " cat /proc/meminfo"
there is available only 3GB++
My pc at home has 8 GB too and runs 32 bit Slackware. The thing is that the Slackware default kernel is compiled with support up to 4 GB, and as i see the video memory of the VGA is included in that calculation too - my VGA has 512 VRAM, and "free -m" reports ~3.5GB memory. Therefore just recompile the kernel with higher memory support - this is under "Processor type and features/High Memory support" - just check the next box - 64 GB and all will work fine.
 
Old 07-13-2009, 04:52 AM   #8
Luxr
Member
 
Registered: Jun 2009
Distribution: Slackware Current
Posts: 30

Original Poster
Rep: Reputation: 15
thanks for respond jelezarov,
i also used NVDIA Geforce 9 series 512 Mb
but i was tried it and got errors it's about boot sector. could you give me tutorial for help me to made it jelezarov.
thank you
 
Old 07-14-2009, 05:06 AM   #9
jelezarov
LQ Newbie
 
Registered: Nov 2007
Location: /dev/urandom
Distribution: Slackware
Posts: 26

Rep: Reputation: 17
Quote:
Originally Posted by Luxr View Post
thanks for respond jelezarov,
i also used NVDIA Geforce 9 series 512 Mb
but i was tried it and got errors it's about boot sector. could you give me tutorial for help me to made it jelezarov.
thank you
That's the way i do it, maybe it's not the best, but works always for me:
* First of all, check what is the last kernel supported by your graphics card driver - my VGA is ATI and they are always very phlegmatic with drivers. Nevermind, lets assume the latest kernel, supported by the video driver, is 2.6.30.1
* Go to http://www.kernel.org and download it. I download always full source code (its marked "F", after the date), because i keep track of the previous kernel, and don't like patching
* I have a directory, named /home/jelezarov/sources/KERNEL - just change the following commands with the appropriate paths and kernel version on your machine ($ prompt is regular user, # is root):
Code:
$ cd /home/jelezarov/sources/KERNEL
$ tar -xjvf linux-2.6.30.1.tar.bz2
$ cd linux-2.6.30.1
$ cp /boot/config-generic-smp-2.6.27.7-smp .config
the above extract the kernel sources and copies the default slackware 12.2 generic smp kernel config (it's a text file with configuration of the kernel, as the name assumes) from /boot to use as a base of our new config. After you successfully compile your kernel and all works fine, you can use the new config, when/if you compile newer kernel.

Code:
$ make silentoldconfig
This creates a new .config file, based on the configuration of the old one. You'll be asked for every new option, that is required by the new kernel. What i'm doing is just press and hold "enter" and all goes to defaults. And since "make xconfig" makes the same - sets all unset options to default, this step is optional.

Code:
$ make xconfig
Here we will make our custom kernel adjustments, one by one. That command requires that you are in X session, otherwise use "make menuconfig", but for me that one is nicer . When you face trouble finding something use "Edit/Find" or just Ctrl+F. When you get familiar with more kernel options, and mostly with the architecture of your machine in details, you can try to adjust more things, but for now i thing that's enough - adjust this things and leave all others to defaults. I'm following Eric Hameleers advise in that http://alien.slackbook.org/, with the difference i'm not using the preemption thing - i tried several kernels and never see a gain in responsiveness, or even it was worst. I left that on you to decide - to set a preemption or not.
Processor type and features:
here i check "Tickless system (Dynamic Ticks)", "High resolution timer suport" and "Processor family" to "Core 2/ newer Xeon" - that will be the same for you, as you use a Quad CPU too. Next is below - if that kernel is just for your PC, you can safely uncheck "Generic X86 Support". More below is "Preemption model" - i leave that to "no", cause i like it so, but you can google it and decide for yourself. Let's go more down for one very important section - "High Memory Support" - just check "64GB" and all of your RAM will be used - i don't know exactly how that is done on 32 bit but is fact that works. The last thing we'll adjust in that section is "Timer Frequency" - set it to 300
File systems:
here you have to enable the file system you are using to be compiled in kernel, not as module - that eliminates the need of initrd image in the common case. You still will need to make an initrd if you need some special module to be loaded on boot - for example with full disk encryption (like me ). So let's assume that you use ext3 (like me), then check "Ext3 journalling file system support" - it is checked as module, mark it to be compiled in kernel. The same goes to "JBD (ext3) debugging support"

That's the minimum to be adjusted. In some cases you have to enable more modules to be compiled (i have a bluetooth keyboard for example), or there is for sure lot of things that you don't need on your PC, but i suggest you leave that for now. Now let's do:

Code:
$ make -j8
Cause we have Quad CPUs we can safely set the -j parameter to 8 - that are the number of threads when compiling and that gives a huge speed boost when compiling the new kernel. After some waiting its finished (by me its approx. 7 min). Lets go superuser and install it:

Code:
$ su
# make modules_install
# #That put all modules in /lib/modules/'version of new kernel'/
# make kernelversion
# #That shows you the name of the new kernel
# cp arch/i386/boot/bzImage /boot/linux-generic-smp-2.6.30.1-smp
# cp System.map /boot/System.map-generic-smp-2.6.30.1-smp
# cp .config /boot/config-generic-smp-2.6.30.1-smp
# #Don't forget the "smp" string - that's what we are using
So, the kernel is installed, but lilo don't knows about that. I like vim, but you can use you preferred editor. Just be root when editing.

Code:
# vim /etc/lilo.conf
DON'T remove the current kernel lines in lilo - if something goes wrong with our new kernel we'll need the old one for troubleshoot. Let the end of lilo.conf looks something like this (adjust your names as you like it, partitions and kernel versions). Root is the partition, now mounted under /

Quote:
.....
.....
# End LILO global section
# Linux bootable partition config begins
image = /boot/vmlinuz-generic-smp-2.6.30.1-smp
root = /dev/sda3
label = NEW
read-only
# Linux bootable partition config ends
# Linux bootable partition config begins
image = /boot/vmlinuz-huge-smp-2.6.27.7-smp
root = /dev/sda3
label = OLD
read-only
# Linux bootable partition config ends
Code:
# lilo
That writes the lilo.conf configuration to the MBR (master boot record). If there's no errors 'till now, remains just:

Code:
# reboot
As we adjusted it in lilo.conf the new kernel will be booted by default, so just see if it works. If anything goes wrong reboot and select in lilo boot prompt the old kernel and your PC will be booted with him.

Good Luck!
 
Old 07-15-2009, 12:59 AM   #10
Luxr
Member
 
Registered: Jun 2009
Distribution: Slackware Current
Posts: 30

Original Poster
Rep: Reputation: 15
thanks for this tutorial jelezarov,
i will try it..
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
headphone output has intermittent problem wabbalee Linux - Hardware 2 06-14-2009 06:45 PM
slackware newbie... sylvania g netbook no audio output from headphone jack jmd9qs Slackware 8 04-26-2009 04:22 PM
problem in speakers and headphone purimanu2000 Linux - Hardware 1 09-18-2007 01:11 AM
Laptop Port Replicator Headphone Problem gmisek Fedora 0 01-22-2005 03:35 AM
headphone problem on suse 9.1 pro cheyrek Linux - Laptop and Netbook 2 07-16-2004 05:24 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:14 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration