LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-14-2017, 07:23 AM   #61
JeremyBoden
Senior Member
 
Registered: Nov 2011
Location: London, UK
Distribution: Debian
Posts: 1,756

Rep: Reputation: 387Reputation: 387Reputation: 387Reputation: 387

Please try a successful live boot from DVD or USB!!!
Do not configure anything.

It seems that your present config is seriously broken.
 
Old 01-14-2017, 07:35 AM   #62
Zupe
Member
 
Registered: Aug 2016
Posts: 65

Original Poster
Rep: Reputation: Disabled
Hi Back again now rested and family needs addressed. I thought about this all night long and had reached the same conclusion to retry that ip a command to verify device name.
SO here we are.
Entered ip a and cut and pasted 'eno1' into terminal with this result...
RTNETLINK answers: Operation not permitted

SO to me that means (probably) that something on this machine resists connecting.
Brief history; before I tried this Actiontec modem/router I had purchased a Netgear stand alone Modem and it had prompted me for a password. I had put in the admin password for this laptop because I am used to being thus prompted, when MAYBE i should have put in my Verizon password. OR a neutral one like admin and password1 which their admittedly ancient paper work states, dating from 2003 when I started with verizon. The reason I think this is because I only did that on this linux OS of this laptop. Everything else automatically connected. I assumed a new Modem would be a fresh start. *shrug*

I further tested this by dusting off an old Dell latitude laptop, dual booted with Win XP and LM 18 xfce It jumped online immediately, easypeasy, no problem. SO the problem cinnamon OS install, is the only 1 out of 6 OS that is blocked from going on line.

So now that is what I am going to explore that avenue. Input still welcome

Also REALLY a loud shout out to TheEzekielProject and Jeremy Boden for your perseverance. The friendliness of linux community continues to amaze me,,, full stop.
 
Old 01-14-2017, 08:10 AM   #63
Zupe
Member
 
Registered: Aug 2016
Posts: 65

Original Poster
Rep: Reputation: Disabled
Next step on Cinnamon OS I pulled up settings -> Network -> wired -> tool box square and it showed Hardware address 5C:26:0A:880:F9 * Last use 4 days ago That dates to when I used the first modem I bought Netgear. hmmm

I clicked on toolbox ->security and tried various usernames and passwords. My Laptops, Cinnamon OS and verizon and generic admin/password1 nothing

SO THEN I tried just disconnecting the security function

and NOW I can get online!
Security is now disabled but I can live with that until I can figure out what it should be. In the end it was not the OS problem but the all to familiar Noob Problem of not understanding how to connect with my provider.

*(Sudden paranoia hits... is it imprudent to post this Hardware address on line, realizing now its too late to change?

Last edited by Zupe; 01-14-2017 at 08:13 AM.
 
Old 01-14-2017, 09:01 AM   #64
JeremyBoden
Senior Member
 
Registered: Nov 2011
Location: London, UK
Distribution: Debian
Posts: 1,756

Rep: Reputation: 387Reputation: 387Reputation: 387Reputation: 387
Is security your Mint security or some other kind of security?
Ethernet connections don't use security but wifi definitely connections do.

Hardware address 5C:26:0A:880:F9 is the unique address of your ethernet card (the MAC address).
 
Old 01-14-2017, 10:17 AM   #65
Zupe
Member
 
Registered: Aug 2016
Posts: 65

Original Poster
Rep: Reputation: Disabled
Hey Jeremy
Back again after Saturday family shopping.
I solved the problem by deleting the username/password listed in toolbox next to wired connection under networking AND Discontinuing security function entirely. I was able then to get on line.
On that page is listed
'802.1x Security' and a slider bar on/off
'Authentication' MDS (other options include TLS, FAST, Tunneled TLS and Protected EAP (PEAP))
'Username' now blank
'Password' now blank
checkbox 'Ask for this password every time'
checkbox 'Show password'

Right now I have security on but cinnamon OS not online so still safe. I am open to suggestions on how to set it but since its probably a choice I am pretty sure I can research options. BUT I would welcome input about where to look or what to put in. I did not reset/forget the wired connection page and I have not tested wireless connections.
(still in happy happy bubble of triumph feeling and don't want to lose it.)

Is this valuable enough to post as solved?

My Question about MAC address related to; Does posting on line give information valuable to hackers? It is to late to change but good to know for future.

Last edited by Zupe; 01-14-2017 at 10:21 AM.
 
Old 01-14-2017, 10:51 AM   #66
JeremyBoden
Senior Member
 
Registered: Nov 2011
Location: London, UK
Distribution: Debian
Posts: 1,756

Rep: Reputation: 387Reputation: 387Reputation: 387Reputation: 387
I would certainly (at a minimum) try to set the username + password
This should be required for access to the router via a browser using http://192.168.0.1

otherwise anyone nearby could use wifi to hack into your router and change your router settings.
 
Old 01-14-2017, 11:52 AM   #67
Zupe
Member
 
Registered: Aug 2016
Posts: 65

Original Poster
Rep: Reputation: Disabled
Okay Jeremy
I will set something right now. I have kept that OS off line until I decided what to do. And if it gums up the works again then I'll know where to look.
Cheers!
 
Old 01-14-2017, 01:04 PM   #68
TheEzekielProject
Member
 
Registered: Dec 2016
Distribution: Devuan+lxde
Posts: 658

Rep: Reputation: 190Reputation: 190
What exactly is the command you entered that returned
Quote:
RTNETLINK answers: Operation not permitted
? And did you then try prepending that command with sudo? That should get you online

It is okay to post a MAC (hardware) address, you can't really be tracked down by them.

What exactly do you mean by
Quote:
SO THEN I tried just disconnecting the security function
?

If you mean you removed the username/password for your Actiontec configuration page, I highly recommend resetting those as that leaves your router/modem vulnerable.

It's strange that a username and password on your router would affect ethernet connectivity. But, as stated above, I have definitely seen the
Quote:
RTNETLINK answers: Operation not permitted
error and prepending with sudo will almost definitely get you connected. We definitely are going in the right direction here now

Last edited by TheEzekielProject; 01-14-2017 at 01:29 PM.
 
Old 01-14-2017, 03:42 PM   #69
Zupe
Member
 
Registered: Aug 2016
Posts: 65

Original Poster
Rep: Reputation: Disabled
First the answer to you immediate question:
Here is terminal screen shot from this Studio computer loaded with LM xfce This computer does not have a username/password and can get on line so I can cut and paste. whew!
-Studio-1737 ~ $ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: enp8s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
link/ether 00:22:19:e4:bd:d3 brd ff:ff:ff:ff:ff:ff
inet 192.168.0.2/24 brd 192.168.0.255 scope global dynamic enp8s0
valid_lft 83888sec preferred_lft 83888sec
inet6 fe80::8b34:aa43:60c3:2e57/64 scope link
valid_lft forever preferred_lft forever
3: wlp4s0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
link/ether 00:24:2b:37:39:7d brd ff:ff:ff:ff:ff:ff

If I look at the original problem dell latitude with cinnamon I get the same thing but next to 2. I now get enp9s0 Before I am certain it was eno1.

So to disconnect security I went to
All -> network connections -> either right click on wired connection or click edit -> tab 802.1xSecurity
here is that description:
802.1x Security' and a slider bar on/off in cinnamon
(in xfce there is a box xed Use 802.1x security for this connection)
'Authentication' MDS (other options include TLS, FAST, Tunneld TLS and Protected EAP (PEAP))
'Username'
'Password' (when filled = no internet connection, when empty = internet connection)
checkbox 'Ask for this password every time'
checkbox 'Show password'

All my linux OS show this same pattern. Put in username and password and it will NOT connect, Take out and they go online immediately, Is this what you mean by Actiontec configuration page?

FYI I have about an hour and a half before I have to leave for a concert but I will have two days to work on this before I return to work on Tuesday.
My happy bubble of success is a bit deflated but with my stalwart linux friends I trust we will win the day!
Cheers Zupe
 
Old 01-14-2017, 03:57 PM   #70
TheEzekielProject
Member
 
Registered: Dec 2016
Distribution: Devuan+lxde
Posts: 658

Rep: Reputation: 190Reputation: 190
By Actiontec Configuration page, I was referring to 192.168.0.1.

It is possible you will get different names for devices depending on which OS is running; they are not "hardcoded". I see what you are talking about now in your connection editor. As this is ethernet, it should be perfectly safe to NOT require a username and password here.

As for my question above, what was the command you entered that returned
Code:
RTNETLINK answers: Operation not permitted
 
Old 01-15-2017, 07:02 AM   #71
Zupe
Member
 
Registered: Aug 2016
Posts: 65

Original Poster
Rep: Reputation: Disabled
The ezekial project and Jeremy
I retraced my steps and copy pasted the following (this is with no username password)
e-Studio-1737 ~ $ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: enp8s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
link/ether 00:22:19:e4:bd:d3 brd ff:ff:ff:ff:ff:ff
inet 192.168.0.2/24 brd 192.168.0.255 scope global dynamic enp8s0
valid_lft 65435sec preferred_lft 65435sec
inet6 fe80::8b34:aa43:60c3:2e57/64 scope link
valid_lft forever preferred_lft forever
3: wlp4s0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
link/ether 00:24:2b:37:39:7d brd ff:ff:ff:ff:ff:ff
-Studio-1737 ~ $ dhclient enp8s0
RTNETLINK answers: Operation not permitted
-Studio-1737 ~ $ dhclient

I hope this helps but I had same reached conclusion overnight Take out the username and password and do security if needed by some other route.

Last edited by Zupe; 01-15-2017 at 08:32 AM. Reason: added needed word
 
Old 01-15-2017, 09:03 AM   #72
JeremyBoden
Senior Member
 
Registered: Nov 2011
Location: London, UK
Distribution: Debian
Posts: 1,756

Rep: Reputation: 387Reputation: 387Reputation: 387Reputation: 387
Don't do that.

Chances are your router is broadcasting on Wifi - even if you aren't using it.

Anyone nearby can connect wirelessly to your router and change the configuration.
In particular, they could break it for you.

They are more likely to use it to load malware onto your Windows machines or to access illegal internet and you will get the blame.

Have you tried
Code:
sudo dhclient enp8s0
(where enp8so is the name of your appropriate connection).
 
Old 01-15-2017, 12:06 PM   #73
TheEzekielProject
Member
 
Registered: Dec 2016
Distribution: Devuan+lxde
Posts: 658

Rep: Reputation: 190Reputation: 190
Code:
2: enp8s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
link/ether 00:22:19:e4:bd:d3 brd ff:ff:ff:ff:ff:ff
inet 192.168.0.2/24 brd 192.168.0.255 scope global dynamic enp8s0
valid_lft 65435sec preferred_lft 65435sec
inet6 fe80::8b34:aa43:60c3:2e57/64 scope link 
valid_lft forever preferred_lft forever
Seems to indicate that you are connected to your network.

As I noted in post #70, if this is what you are referring to, you do NOT need a username password here
 
1 members found this post helpful.
Old 01-15-2017, 01:43 PM   #74
Zupe
Member
 
Registered: Aug 2016
Posts: 65

Original Poster
Rep: Reputation: Disabled
Ezekiel Project yes that is a correct screenshot of where problem area was for putting in username and password

Jeremy I have secured my modem/router but I did it through win vista which is not probably the best choice because of its short shelf life but it was the only thing I could get to work at the time. Would the MAC address be different between different laptops on the same modem? or also different between window and linux sections of same laptop??

Edit:Actually I did a quick ifconfig in Terminal window on cinnamon OS and answered my own question. It is the same MAC address. I am getting better at this!

Last edited by Zupe; 01-15-2017 at 01:45 PM.
 
Old 01-15-2017, 01:51 PM   #75
TheEzekielProject
Member
 
Registered: Dec 2016
Distribution: Devuan+lxde
Posts: 658

Rep: Reputation: 190Reputation: 190
Mac addresses are hardcoded into the nic and should be the same across operating sytems.

Again, assuming
Code:
2: enp8s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
link/ether 00:22:19:e4:bd:d3 brd ff:ff:ff:ff:ff:ff
inet 192.168.0.2/24 brd 192.168.0.255 scope global dynamic enp8s0
valid_lft 65435sec preferred_lft 65435sec
inet6 fe80::8b34:aa43:60c3:2e57/64 scope link 
valid_lft forever preferred_lft forever
is accurate and from the problematic system, type
Code:
ping -c 2 www.google.com
You should be connected.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to access WiFi in Linux Mint Cinnamon 17.1 on Dell Inspiron 1501 CrazyGrannie Linux - Newbie 19 04-03-2016 10:42 PM
Laptop wont hibernate/suspend (dell D430 + Linux mint 15.0 Cinnamon) steak1987 Linux - Laptop and Netbook 33 08-10-2013 01:28 PM
Linux Mint 13 Cinnamon wireless not working taythewhiteguy Linux - Networking 0 06-23-2012 10:06 PM
netgear ma311 wireless card will not talk to actiontec wired/wireless router tzonga1 Linux - Wireless Networking 2 02-10-2007 05:52 PM
need to know how to configure Actiontec wireless card (has native linux driver) izquierdista Linux - Wireless Networking 1 12-17-2005 10:57 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 04:02 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration