LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
LinkBack Search this Thread
Old 09-26-2013, 08:56 PM   #16
Sumguy
Member
 
Registered: Jul 2010
Location: Rural Kentucky, USA.
Distribution: Debian 7 & CrunchBang
Posts: 229
Blog Entries: 2

Original Poster
Rep: Reputation: 56

O-K...here we go:

Quote:
aplay -L
default
Playback/recording through the PulseAudio sound server
sysdefault:CARD=Solo1
ESS ES1938 (Solo-1), ESS Solo-1
Default Audio Device
Quote:
cat /proc/asound/card0/codec#0 | grep Codec
cat: /proc/asound/card0/codec#0: No such file or directory





Quote:
alternatively you could tryt OSS for sound instead of ALSA?

debian sid has oss4-gtk which should pull down oss4-base but the first package is a gui or graphical panel that should suit newbies?
Not sure thatI quite understand that.....but the ALSA system did work.... What happened was, my onboard sound went bad one day, when I was still using Ubuntu (The volume, even when turned to max on both the computer and the speakers, was very low....and low frequencies were weak and distorted, like when you have a blown speaker. I checked out my speakers, and the cable, etc. they were fine.

At the time, I still had Windows Vista on my hard-drive, so I booted it up...same thing. And then when I wiped the Vista and installed Debian...same thing, with the onboard sound- so I bought this PCI sound card...and now NO sound at all from Debian or Ubuntu....which leads me to believe the card is bad. What'ya think?

I really appreciate the time and trouble you're taking to help!
 
Old 09-27-2013, 12:20 AM   #17
aus9
Guru
 
Registered: Oct 2003
Posts: 5,055

Rep: Reputation: Disabled
aaahhh why did you not tell us you were using pulseaudio before?
Quote:
Playback/recording through the PulseAudio sound server
did you not know you had it running?

I suggest you now ensure you have all the configs for it
Code:
sudo su
apt-get update
apt-get install pulseaudio paman pavucontrol pavumeter paprefs
come back when you have installed all and we re-look at whatever you have for pulseaudio (=PA)
 
1 members found this post helpful.
Old 09-27-2013, 12:24 AM   #18
aus9
Guru
 
Registered: Oct 2003
Posts: 5,055

Rep: Reputation: Disabled
now the other thing is possible hardware failure

please confirm that sound is working or not in windos pls

If no sound working, boot up a live cd/dvd such as Linux mint and confirm you get sound or not
---you may need to use alsamixer/gui mixer to unmute and raise volumes

If you have blown speakers we are wasting time no?
 
1 members found this post helpful.
Old 09-27-2013, 10:16 AM   #19
Sumguy
Member
 
Registered: Jul 2010
Location: Rural Kentucky, USA.
Distribution: Debian 7 & CrunchBang
Posts: 229
Blog Entries: 2

Original Poster
Rep: Reputation: 56
I have PulseAudio?!
(Did I mention that I'm a clueless noob?)

I no longer have WinD'ohs on the 'puter...just Ubuntu 10.04 and Debian- and now there's no sound in either. (The onboard sound worked fine in Ubuntu until recently, then it started only half-working as described above- and that had to be a hardware issue, because it did the same in Ubuntu and Windows...and then Debian. Then I installed the PCI card to "fix" that problem, and no sound...from any OS.)

No...LOL...speakers are not blown. They sound fine if I hook up my MP3 player through the auxilary input, or even through the jack used for the computer cable.

Do we really have to mess with the Pulseaudio? ALSA worked fine before...I was thinking maybe it would be better to just stick with one system? Could it be that the output of something is set to use PulseAudio, while the output of something else is trying to use ALSA?

Hopefully my new new sound card will arrive soon, and we can eliminate a defective sound card as an issue......

I have an old live CD of some distro (I think it is Mint) lying around here, somewhere...I'll find it and give it a whirl, as you suggest, some time today.

You should be getting paid for this!
 
Old 09-27-2013, 10:20 AM   #20
Sumguy
Member
 
Registered: Jul 2010
Location: Rural Kentucky, USA.
Distribution: Debian 7 & CrunchBang
Posts: 229
Blog Entries: 2

Original Poster
Rep: Reputation: 56
PS: I had already tried that pavucontrol thing on my Ubuntu...no difference.

Since I do have updated Pulse on my Ubuntu, if you prefer to work with that, maybe I can boot into Ubuntu for the pulse stuff...and stay with ALSA on Debian, so we don't start confusing things? (I'll be wiping the Ubuntu in the future, so I don't mind experimenting with it).
 
Old 09-29-2013, 06:49 PM   #21
aus9
Guru
 
Registered: Oct 2003
Posts: 5,055

Rep: Reputation: Disabled
Quote:
and stay with ALSA on Debian
suits me, join the ubuntu forum to ask questions about pulseaudio (LQ or the real forum) as you see fit
I will assume you will now delete all pulseaudio from debian,
Code:
sudo su
apt-get remove --purge pulseaudio paman pavucontrol pavumeter paprefs
rm -rf /etc/pulse 
rm -rf /home/yourname/.pulse # change this
some may not be installed so you may need to do each package by its self YMMV

then do a full reboot

then post the contents of aplay -l and aplay -L----when you have no pulse showing pls
 
1 members found this post helpful.
Old 09-29-2013, 07:53 PM   #22
Sumguy
Member
 
Registered: Jul 2010
Location: Rural Kentucky, USA.
Distribution: Debian 7 & CrunchBang
Posts: 229
Blog Entries: 2

Original Poster
Rep: Reputation: 56
Hello, Again...

Now something weird is happening: I pasted your commands in (after editing-in the name I use on the computer, of course), and without even hitting ENTER, it just starts running. Gets to the prompt at the bottom, where it asks me if I want to continue; I hit "y" and "enter"...and it aborts...

Here's how it looks:

Quote:
apt-get remove --purge pulseaudio paman pavucontrol pavumeter paprefs
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package 'paman' is not installed, so not removed
Package 'paprefs' is not installed, so not removed
Package 'pavucontrol' is not installed, so not removed
Package 'pavumeter' is not installed, so not removed
The following packages were automatically installed and are no longer required:
a2ps hddtemp libexo-common libexo-helpers libgarcon-common libhal-storage1
libhal1 libkeybinder0 libnotify-bin libsensors4 libtagc0 libtumbler-1-0
libunique-1.0-0 lm-sensors
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED:
gnome* gnome-core* libcanberra-pulse* pulseaudio* pulseaudio-module-x11*
task-gnome-desktop*
0 upgraded, 0 newly installed, 6 to remove and 3 not upgraded.
After this operation, 5,070 kB disk space will be freed.
Do you want to continue [Y/n]? y
Abort.
 
Old 09-30-2013, 05:31 PM   #23
Sumguy
Member
 
Registered: Jul 2010
Location: Rural Kentucky, USA.
Distribution: Debian 7 & CrunchBang
Posts: 229
Blog Entries: 2

Original Poster
Rep: Reputation: 56
iy...

My new card came today, and I just installed it- now apparently, the OS isn't recognizing it- it just says "dummy output".

It never ends.....

It can't be the Debian...'cause I get the exact same thing whether I'm using Ubuntu or Debian.
 
Old 09-30-2013, 06:39 PM   #24
aus9
Guru
 
Registered: Oct 2003
Posts: 5,055

Rep: Reputation: Disabled
hmmm not sure what Debian you are on so try this instead
Code:
sudo rm -rf /etc/pulse
ME=`whoami` 
rm -rf /home/$ME/.pulse
we will leave pulse installed as it looks like gnome depends on it.....grrrr

2) Ok now lets use this post to work on your new card
go into your bios pls and disable your onboard sound
look to see if you need to setup your new card

boot up

go into /var/log/messages with a root powered text editor ....as you have gnome
thats likely to be
Code:
sudo gedit /var/log/messages
copy and paste only those bits that relate to any sound hardware

If you can't find any...pls describe your new card
make model pci-card (the kind of slot its in)

Also did you remove your solo card or not?

also with the new card post the contents of
Code:
lsmod | grep snd
cheers
 
1 members found this post helpful.
Old 10-01-2013, 10:00 PM   #25
Sumguy
Member
 
Registered: Jul 2010
Location: Rural Kentucky, USA.
Distribution: Debian 7 & CrunchBang
Posts: 229
Blog Entries: 2

Original Poster
Rep: Reputation: 56
Aus9, I'll pick up on this in a day or two- I'm so tired of fooling with this at the moment- and have spent so much time doing so, that I need a break!

I re-enabled the onboard sound, and that works somewhat- as it did before, with lower than normal volume- which was the orignal problem which prompted me to get the PCI card [Under 3 different OS's..so THAT had to be a hardware problem] (I right clicked on the volume icon on my toolbar, and was able to set the output volume at 153%....so at last with the speakers turned up the way, it's usable).

I'll go back and re-read this thread- I think you (or possibly someone else) mentioned how to re-install PulseAudio? I notice that in Alsamixer, the PCI card is listed a "PulseAudio"....so when I get back to this, I'll take your earlier advice about the pulse..... (I'm so bleary from this crapola, I hardly know what I'm doing, so forgive me if I'm rehashing....)

Or maybe I'll take the sound card to a PC repair shop and see if they can test it....

Thanks again for all the help.

Last edited by Sumguy; 10-01-2013 at 10:01 PM.
 
Old 10-06-2013, 09:33 PM   #26
Sumguy
Member
 
Registered: Jul 2010
Location: Rural Kentucky, USA.
Distribution: Debian 7 & CrunchBang
Posts: 229
Blog Entries: 2

Original Poster
Rep: Reputation: 56
Hello, All,

I replaced my old Ubuntu with Crunchbang today [So I'm now running Debian and Crunchbang].....same deal in Crunchbang.....no sound through the PCI card; but I can get the onboard audio to partially work.... Gotta be hardware, eh?
 
Old 10-07-2013, 08:49 AM   #27
aus9
Guru
 
Registered: Oct 2003
Posts: 5,055

Rep: Reputation: Disabled
umm you did firmly push card into slot eh?

why not try another slot?

You can use masking tape to cover the olde hole if your case has no spare cover pieces.

good luck
 
1 members found this post helpful.
Old 10-07-2013, 09:19 AM   #28
Sumguy
Member
 
Registered: Jul 2010
Location: Rural Kentucky, USA.
Distribution: Debian 7 & CrunchBang
Posts: 229
Blog Entries: 2

Original Poster
Rep: Reputation: 56
Tried that already, Aus.

The card is recognized in either slot...just no sound. It's the first "new" card I'm still working with. The "new" new card that I got to replace it, turned out to have an ES1983 chip, which I've seen from Googling-around, isn't really Linux compatible- which, I guess is why when I had it installed, it wasn't recognized, and just said "dummy output".

So I'm back to the idea of trying ANOTHER card, since the card I bought to replace the potentially defective initial card isn't really compatible.....

In the meantime, I've got sound through the onboard audio- by plugging the speaker's auxilary input into the computer's headphone jack, while keeping the regular computer-to-speaker connection connected also, and boosting the volume in [I think?] the GUI "pavucontrol" to it's max of 153%.

I'll let you know what happens when I do finally get a compatible replacement card..... [The non-compatible replacement card- a generic piece of Chinese junk- didn't sit well in the slot.... I was going to file down the edge of the board below the contacts- as one can see that it is not 100% straight....but no need to bother, since the ES1983 isn't supported....]

Thanks again for sticking with this.
 
Old 10-09-2013, 06:48 PM   #29
selfprogrammed
Member
 
Registered: Jan 2010
Location: Minnesota, USA
Distribution: Slackware 10.2, 13.37
Posts: 215

Rep: Reputation: 45
Alsa mixer can cause problems because Alsa must configure it according to what card that Alsa detects. It took years for Alsa to fix their downloads to configure Alsa mixer for my sound cards. I resorted to randomly trying mixer setups for closely related cards and saving the bits that worked.

When you get a mixer config that works, it can be saved and then setup Alsa to load it instead of detecting. There may be more mixer controls than what you see, and if one is set to default then the volume is low.

Installing a different Alsa version with a new set of Alsa mixer configs can be the cause of all your problems. Suspect everything that Alsa is doing. There are some Alsa config tools, but I do not remember their names, and they probably have changed again.

Try
>> man -k Alsa

To verify the pci install
>>lspci
 
Old 10-09-2013, 08:22 PM   #30
Sumguy
Member
 
Registered: Jul 2010
Location: Rural Kentucky, USA.
Distribution: Debian 7 & CrunchBang
Posts: 229
Blog Entries: 2

Original Poster
Rep: Reputation: 56
Thanks, Selfprogrammed, but it was doing the same thing even when I booted-up Vista, before wiping it off my HDD- so I'd think it's gotta be a hardware issue, no? And it was working fine in Ubuntu...until one day when it just went bad- and I had made no changes to the system.... Now it's the same on Crunchbang, too.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
sound card not being recognized pconsolini Debian 1 03-14-2010 07:36 PM
Sound card recognized but no sound on SoundMAX Integrated Digital Audio xzallion Fedora 46 12-13-2006 10:18 PM
Sound Card not recognized cheesekeeper Red Hat 11 03-08-2005 03:57 AM
Sound card recognized but no sound landfill Linux - Hardware 5 02-13-2005 12:50 PM
sound card not recognized kare13 Linux - Newbie 1 07-26-2004 09:44 AM


All times are GMT -5. The time now is 06:40 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration