LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Linux - Hardware (http://www.linuxquestions.org/questions/forumdisplay.php?f=18)
-   -   Sound Card Recognized....Still No Sound (http://www.linuxquestions.org/questions/showthread.php?t=4175478345)

Sumguy 09-24-2013 09:49 AM

Sound Card Recognized....Still No Sound
 
Hi, Again!

I just installed an old ES1938 Solo-1 soundcard, as my onboard sound was messed up. Debian recognizes the sound card....but there is no sound (At least I had some sound with mt messed-up onboard config!)

I disabled the onboard sound in the bios..

Opened Alsamixer...volume is set at 100.....

What else can I do to try and get the sound working?

Kuranes 09-24-2013 10:41 AM

Make sure output channels are not muted.

Sumguy 09-24-2013 10:58 AM

Quote:

Originally Posted by Kuranes (Post 5033913)
Make sure output channels are not muted.

Hmm...how would i do that, please?

Kuranes 09-24-2013 11:31 AM

In alsamixer, a muted channel shows MM at the bottom (instead of OO). Pressing m toggles it.

Sumguy 09-24-2013 01:38 PM

Ah, O-K...thanks.

The only thing showing as muter is "3D cntrl".....

Any other ideas?

Sumguy 09-25-2013 10:07 AM

I'm beginning to think that this sound card is defective....'cause everything else seems to check-out O-K. I've ordered a nedw one.....

NeXuS_2006 09-25-2013 12:23 PM

If you have pulse audio, you could install and try pavucontrol, its like alsa mixer but on my system, at least, it has options and device settings that alsamixer lacks.

Sumguy 09-25-2013 02:01 PM

Quote:

Originally Posted by NeXuS_2006 (Post 5034712)
If you have pulse audio, you could install and try pavucontrol, its like alsa mixer but on my system, at least, it has options and device settings that alsamixer lacks.

Thanks. I don't believe my Debian has Pulse...but I know that my old Ubuntu does...so maybe I'll boot-up Ubuntu and give that a try!

Sumguy 09-25-2013 02:46 PM

Ah well...that didn't work..... Same deal; It recognizes the card....but still no sound.

I forgot to hook up the wire from the CD/DVD drive when I installed the card...but that would only affect media I was trying to play from the drive, right? (I'll hook it up later, just for the heck of it...)

Sumguy 09-25-2013 11:27 PM

Anyone see anything wrong with this aplay -l output:

Quote:

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Solo1 [ESS ES1938 (Solo-1)], device 0: es-1938-1946 [ESS Solo-1]
Subdevices: 2/2
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Or this lspci -v:

Quote:

02:01.0 Multimedia audio controller: ESS Technology ES1938/ES1946/ES1969 Solo-1 Audiodrive (rev 01)
Subsystem: ESS Technology Solo-1 Audio Adapter
Flags: bus master, medium devsel, latency 64, IRQ 21
I/O ports at bc00 [size=64]
I/O ports at b800 [size=16]
I/O ports at b400 [size=16]
I/O ports at b000 [size=4]
I/O ports at ac00 [size=4]
Capabilities: <access denied>
Kernel driver in use: snd_es1938
It's obviously seeing the sound card ,and loading the driver....

What can the problem be, besides a bad card?

aus9 09-26-2013 01:57 AM

Hi

I like images pls post an image of
Code:

alsamixer -c0 -Vall
if you don't have your own host site consider tinypic.com or http://imagebin.org/index.php?page=add
eg 14 day expiry at link http://imagebin.org/271938

2) Have you read http://www.alsa-project.org/main/ind...:Module-es1938

so post the contents of
Code:

sudo modinfo snd
3) Can you just mention that your syslog has no mention of your onboard---no need for posting log at this stage
---its smart to disable it while testing your pc card snd but it can interfere, pesky things they are.

but we don't know if interference from other IRQs so post this output pls
Code:

cat /proc/interrupts
good luck

Sumguy 09-26-2013 11:11 AM

Hello, Aus9,

Thank you for taking the time to do this- Being a noob, this is really what I need- someone to walk me through this.

Here is the output of alsamixer -c0 -Vall:

http://oi44.tinypic.com/5x3ejn.jpg

(I un-muted the 3Dcntrl...just in case...but it made no difference)

2)- No, I haven't read that particular piece. Hadn't found it yet (Not for lack of Googling, though!)


Here is the output of modinfo snd:
Quote:

modinfo snd
filename: /lib/modules/3.2.0-4-686-pae/kernel/sound/core/snd.ko
alias: char-major-116-*
license: GPL
description: Advanced Linux Sound Architecture driver for soundcards.
author: Jaroslav Kysela <perex@perex.cz>
license: GPL
description: Jack detection support for ALSA
author: Mark Brown <broonie@opensource.wolfsonmicro.com>
depends: soundcore
intree: Y
vermagic: 3.2.0-4-686-pae SMP mod_unload modversions 686
parm: slots:Module names assigned to the slots. (array of charp)
parm: major:Major # for sound driver. (int)
parm: cards_limit:Count of auto-loadable soundcards. (int)
3)I've tried it with the onboard sound disabled and in "auto" through the BIOS...no difference. (Funny thing is: I used to have some sound through the onboard sound...now if i enable it and plug the speakers in to it, I have NO sound, even through that! )

...and finally:

Quote:

cat /proc/interrupts
CPU0 CPU1
0: 61 0 IO-APIC-edge timer
1: 6279 0 IO-APIC-edge i8042
8: 1 0 IO-APIC-edge rtc0
9: 3 0 IO-APIC-fasteoi acpi
12: 120595 0 IO-APIC-edge i8042
14: 35244 0 IO-APIC-edge pata_atiixp
15: 0 0 IO-APIC-edge pata_atiixp
16: 1 0 IO-APIC-fasteoi ohci_hcd:usb2
17: 2 0 IO-APIC-fasteoi ohci_hcd:usb3, ohci_hcd:usb5
18: 2 0 IO-APIC-fasteoi ohci_hcd:usb4, ohci_hcd:usb6
19: 0 0 IO-APIC-fasteoi ehci_hcd:usb1
20: 7546 0 IO-APIC-fasteoi eth0
21: 374 0 IO-APIC-fasteoi snd_es1938
22: 31028 0 IO-APIC-fasteoi ahci
NMI: 20 23 Non-maskable interrupts
LOC: 409319 328106 Local timer interrupts
SPU: 0 0 Spurious interrupts
PMI: 20 23 Performance monitoring interrupts
IWI: 0 0 IRQ work interrupts
RES: 493824 532978 Rescheduling interrupts
CAL: 276 443 Function call interrupts
TLB: 7160 9285 TLB shootdowns
TRM: 0 0 Thermal event interrupts
THR: 0 0 Threshold APIC interrupts
MCE: 0 0 Machine check exceptions
MCP: 22 22 Machine check polls
ERR: 0
MIS: 0
Any ideas?

Thanks again!

aus9 09-26-2013 06:29 PM

Hi

thanks for image

2) Your soundcard has not been shared with other devices so no interrupt interference which eliminates that issue

3) but I can't see any sound inputs in your [all] image pls post the contents of
Code:

aplay -L
and thanks for aplay -l above.

4) I have to go out but maybe this device needs a quirk setting or something,
will research later

aus9 09-26-2013 08:11 PM

ok some quick research on your card shows
https://www.kernel.org/doc/Documenta...figuration.txt

Quote:

Module snd-es1968
-----------------

Module for sound cards based on ESS Maestro-1/2/2E (ES1968/ES1978) chips.

total_bufsize - total buffer size in kB (1-4096kB)
pcm_substreams_p - playback channels (1-8, default=2)
pcm_substreams_c - capture channels (1-8, default=0)
clock - clock (0 = auto-detection)
use_pm - support the power-management (0 = off, 1 = on,
2 = auto (default))
enable_mpu - enable MPU401 (0 = off, 1 = on, 2 = auto (default))
joystick - enable joystick (default off)

This module supports multiple cards and autoprobe.

The power-management is supported.
but to be sure can you post the output of this command pls
Code:

cat /proc/asound/card0/codec#0 | grep Codec

aus9 09-26-2013 08:20 PM

alternatively you could tryt OSS for sound instead of ALSA?

debian sid has oss4-gtk which should pull down oss4-base but the first package is a gui or graphical panel that should suit newbies?


All times are GMT -5. The time now is 05:01 AM.