LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
 
Search this Thread
Old 08-30-2014, 07:19 PM   #1
J_angel2000
Member
 
Registered: Dec 2003
Location: Madrid, España/Spain
Distribution: Ubuntu Linux
Posts: 66

Rep: Reputation: 15
How to disable Touchpad permanently - Ubuntu 14.04


I have an Ubuntu 14.04 and a new Sony Vaio with an annoying huge touchpad. How can I disable it forever?

On system configuration it works but just until next reboot. Then it reenables itself again.

On the Bios I don't find any option to disable it.

Thanks a lot!
 
Old 08-30-2014, 07:48 PM   #2
ferrari
Member
 
Registered: Sep 2003
Location: Auckland, NZ
Distribution: openSUSE 13.1
Posts: 463

Rep: Reputation: 52
Are you using the Gnome DE? If so, you can disable using 'deconf-editor' as described here:

http://xmodulo.com/2013/01/how-to-di...u-desktop.html

In particular...
Quote:
In order to disable touchpad permanently on your laptop, invoke dconf-editor.
$ dconf-editor

Then go to "org"->"gnome"->"settings-daemon"->"peripherals"->"touchpad" on dconf-editor, and uncheck "touchpad-enabled" field
 
Old 08-30-2014, 08:10 PM   #3
J_angel2000
Member
 
Registered: Dec 2003
Location: Madrid, España/Spain
Distribution: Ubuntu Linux
Posts: 66

Original Poster
Rep: Reputation: 15
Hey, I have done it that way too but after rebooting it gets enabled by itself again
 
Old 08-30-2014, 08:37 PM   #4
jefro
Guru
 
Registered: Mar 2008
Posts: 12,643

Rep: Reputation: 1598Reputation: 1598Reputation: 1598Reputation: 1598Reputation: 1598Reputation: 1598Reputation: 1598Reputation: 1598Reputation: 1598Reputation: 1598Reputation: 1598
Find out how it connects and either remove support for it or blacklist the driver. Might be possible to disable in bios too.
 
Old 08-30-2014, 08:42 PM   #5
ferrari
Member
 
Registered: Sep 2003
Location: Auckland, NZ
Distribution: openSUSE 13.1
Posts: 463

Rep: Reputation: 52
Then maybe an executable script in ~/.config/autostart/ directory that executes
Code:
synclient TouchPadOff=1
which will take effect after logging in.
 
Old 08-30-2014, 09:05 PM   #6
J_angel2000
Member
 
Registered: Dec 2003
Location: Madrid, España/Spain
Distribution: Ubuntu Linux
Posts: 66

Original Poster
Rep: Reputation: 15
I'm very newbie, ferrari. How can I do that?
 
Old 08-31-2014, 01:44 AM   #7
ferrari
Member
 
Registered: Sep 2003
Location: Auckland, NZ
Distribution: openSUSE 13.1
Posts: 463

Rep: Reputation: 52
Since you're an Ubuntu user, the easiest way to do this is to use 'Startup Applications'

http://askubuntu.com/questions/48321...cally-on-login

You'll want to use the command given previously.

Another example here:

http://askubuntu.com/questions/29000...k-ubuntu-13-04

Hope that helps.
 
Old 08-31-2014, 11:43 AM   #8
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: Slackware®
Posts: 11,707
Blog Entries: 10

Rep: Reputation: 1600Reputation: 1600Reputation: 1600Reputation: 1600Reputation: 1600Reputation: 1600Reputation: 1600Reputation: 1600Reputation: 1600Reputation: 1600Reputation: 1600
Member Response

Hi,

I use this script;
Code:
~$ cat touchpad.sh

----cut-----
#!/bin/bash

# touchpad.sh Written by Atanas S / Siteground Support Team

# First we need to get the device ID from the xinput
# if it does not work for you, you may need to set the cut -f option to another number
# I would suggest that you test the command in your terminal first to see the result
# It should output an integer usually between 8-15, at least on my lap top :D

getdev=`xinput list |grep pointer |grep PS |cut -f 2`
devid=${getdev/id=/}

#Second we need to get the device status, if it is enabled or not

# if it does not work for you, you may need to set the cut -f option to another number
# I would suggest that you test the command in your terminal first to see the result
# It should output 0 or 1

getstatus=`xinput list-props $devid |grep 'Device Enabled' |cut -f 3`

#once we get the device status depending on the status we set it the other way arround
        if [ "$getstatus" == "1" ]; then
        newstatus="0"
        else
        newstatus="1"
        fi
`xinput set-prop $devid "Device Enabled" $newstatus`
----end cut------
I just run the script locally via Kconsole vt, no issue. You can use the same script to toggle the touchpad back on.
Hope this helps.
Have fun & enjoy!
 
Old 09-01-2014, 10:55 AM   #9
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1; Debian 8
Posts: 7,365
Blog Entries: 55

Rep: Reputation: Disabled
Not a permanent solution, but I've put aliases in ~/.bashrc:
Code:
alias tpoff='synclient TouchpadOff=1'
alias tpon='synclient TouchpadOff=0'
It's more often off than on, but not always.
 
Old 09-04-2014, 05:23 AM   #10
solarisguy
Member
 
Registered: Aug 2010
Location: Seattle
Distribution: CentOS, RHEL, Oracle Enterprise Linux, Solaris, BSD
Posts: 64

Rep: Reputation: 15
Easy permanent solution
1. Find a hammer...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] how to disable ssh server permanently? wang Linux - Newbie 13 03-09-2011 08:04 AM
[SOLVED] How to disable Linux iptables permanently ? gardenair Linux - Security 6 03-07-2011 05:02 AM
Disable touchpad - ASUS UL50 - Ubuntu 10.04 Bartmeister Linux - Laptop and Netbook 5 07-05-2010 03:52 AM
Touchpad disable button permanently disables touchpad until reboot William (Dthdealer) Linux - Hardware 12 08-01-2009 10:51 PM
How to disable X security permanently danishmr Linux - Security 15 04-09-2004 02:16 PM


All times are GMT -5. The time now is 04:21 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration