LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 01-16-2003, 09:00 PM   #1
nakkaya
LQ Guru
 
Registered: Jan 2003
Location: Turkey&USA
Distribution: Emacs and linux is its device driver(Slackware,redhat)
Posts: 1,398

Rep: Reputation: 45
please help x window problem


i got red hat 8.0 and dsl(bellsouth provider) connection on eth0 everything works fine some time linux says welcome to local host when that hapens everything works fine but some time it sayswelcome to host97.null.bellsouth.com something like that when that happen x window waits 20 25 sec before loading a program and eth0 starts transmiting after eth0 stops program loads.
 
Old 01-16-2003, 09:14 PM   #2
nakkaya
LQ Guru
 
Registered: Jan 2003
Location: Turkey&USA
Distribution: Emacs and linux is its device driver(Slackware,redhat)
Posts: 1,398

Original Poster
Rep: Reputation: 45
by the way /etc/host configuration as follows
127.0.0.1 localhost.localdomain localhost
 
Old 01-16-2003, 09:53 PM   #3
bulliver
Senior Member
 
Registered: Nov 2002
Location: Edmonton AB, Canada
Distribution: Gentoo x86_64; Gentoo PPC; FreeBSD; OS X 10.9.4
Posts: 3,760
Blog Entries: 4

Rep: Reputation: 78
host97.null.bellsouth.com is the name given automatically by your isp through dhcp, I am presuming. With some ip sniffers I am listed as 24.xxx.xxx.xxx@shawcable.net (shaw is my isp).

If you want to stop that then give your box a name...use the hostname command ie:

hostname blinky
hostname wallace
hostname slagithor

You get the picture. You can pick whatever you want. It should hopefully fix your problem.
 
Old 01-16-2003, 10:01 PM   #4
KnightAbel
Member
 
Registered: Sep 2002
Location: Kaysville, UT USA
Distribution: Red Hat Linux, Slackware
Posts: 242

Rep: Reputation: 30
and if you want to keep that hostname setting, edit the file /etc/HOSTNAME to hostnameyouwant.domainnameyouwant (I'm not sure if setting the domain name with broadband will cause a problem, I don't have broadband. -.-')
 
Old 01-16-2003, 10:17 PM   #5
nakkaya
LQ Guru
 
Registered: Jan 2003
Location: Turkey&USA
Distribution: Emacs and linux is its device driver(Slackware,redhat)
Posts: 1,398

Original Poster
Rep: Reputation: 45
there is no filer called /etc/HOSTNAME
how can i create it
 
Old 01-16-2003, 10:41 PM   #6
KnightAbel
Member
 
Registered: Sep 2002
Location: Kaysville, UT USA
Distribution: Red Hat Linux, Slackware
Posts: 242

Rep: Reputation: 30
just use a text editor, mine looks like this:

hell.evil

seriously, that's the whole file, it's not a big deal.
 
Old 01-16-2003, 10:57 PM   #7
nakkaya
LQ Guru
 
Registered: Jan 2003
Location: Turkey&USA
Distribution: Emacs and linux is its device driver(Slackware,redhat)
Posts: 1,398

Original Poster
Rep: Reputation: 45
i created the file and reboot the machine but still hostname did not change
 
Old 01-16-2003, 11:06 PM   #8
KnightAbel
Member
 
Registered: Sep 2002
Location: Kaysville, UT USA
Distribution: Red Hat Linux, Slackware
Posts: 242

Rep: Reputation: 30
I'm probably missing something then, I'm still pretty new to this myself, I remember that's what I did, but maybe there's some key point I just forgot about... have you looked to see if there is a configuration utility from Red Hat in the menu? I can't remember, I downgraded to 7.3 cause I had problems with 8.0.
 
Old 01-17-2003, 09:09 PM   #9
bulliver
Senior Member
 
Registered: Nov 2002
Location: Edmonton AB, Canada
Distribution: Gentoo x86_64; Gentoo PPC; FreeBSD; OS X 10.9.4
Posts: 3,760
Blog Entries: 4

Rep: Reputation: 78
The file in question is /etc/hosts, not HOSTNAME
 
Old 01-17-2003, 10:08 PM   #10
KnightAbel
Member
 
Registered: Sep 2002
Location: Kaysville, UT USA
Distribution: Red Hat Linux, Slackware
Posts: 242

Rep: Reputation: 30
/etc/hosts is where you set the IP addresses for hosts on your LAN though. my hostname is specified /etc/HOSTNAME

so where am I going wrong here? Mine is setup that way on both my Slackware and Red Hat boxes, and I've reinstalled and simply let Red Hat configure the files for me. (slackware I had to do myself.)
 
Old 01-17-2003, 11:12 PM   #11
bulliver
Senior Member
 
Registered: Nov 2002
Location: Edmonton AB, Canada
Distribution: Gentoo x86_64; Gentoo PPC; FreeBSD; OS X 10.9.4
Posts: 3,760
Blog Entries: 4

Rep: Reputation: 78
Really? I just put:

127.0.0.1 localhost.localdomain badcomputer

in /etc/hosts and:

HOSTNAME=badcomputer

in /etc/sysconfig/network. It works fine...
 
Old 01-17-2003, 11:28 PM   #12
KnightAbel
Member
 
Registered: Sep 2002
Location: Kaysville, UT USA
Distribution: Red Hat Linux, Slackware
Posts: 242

Rep: Reputation: 30
oh, ok. hmm. well, /etc/hosts is the file that sets aliases for IP addresses.

you know what nakkaya? try setting it in /etc/sysconfig/network... now that I think about it, I believe I set it there as well... not entirely sure.

Last edited by KnightAbel; 01-17-2003 at 11:30 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
X Window Problem estman Linux - Software 2 09-26-2004 08:06 AM
x window problem midnightrider Debian 4 12-29-2003 11:19 PM
X window problem pudhiyavan Linux - General 1 11-24-2003 09:28 AM
X window problem... ahmonra Linux - Newbie 1 07-24-2003 06:30 AM
x window problem webboss Linux - General 1 02-11-2003 06:54 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 01:46 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration