LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (https://www.linuxquestions.org/questions/linux-general-1/)
-   -   please help x window problem (https://www.linuxquestions.org/questions/linux-general-1/please-help-x-window-problem-41753/)

nakkaya 01-16-2003 09:00 PM

please help x window problem
 
i got red hat 8.0 and dsl(bellsouth provider) connection on eth0 everything works fine some time linux says welcome to local host when that hapens everything works fine but some time it sayswelcome to host97.null.bellsouth.com something like that when that happen x window waits 20 25 sec before loading a program and eth0 starts transmiting after eth0 stops program loads.:newbie:

nakkaya 01-16-2003 09:14 PM

by the way /etc/host configuration as follows
127.0.0.1 localhost.localdomain localhost

bulliver 01-16-2003 09:53 PM

host97.null.bellsouth.com is the name given automatically by your isp through dhcp, I am presuming. With some ip sniffers I am listed as 24.xxx.xxx.xxx@shawcable.net (shaw is my isp).

If you want to stop that then give your box a name...use the hostname command ie:

hostname blinky
hostname wallace
hostname slagithor

You get the picture. You can pick whatever you want. It should hopefully fix your problem.

KnightAbel 01-16-2003 10:01 PM

and if you want to keep that hostname setting, edit the file /etc/HOSTNAME to hostnameyouwant.domainnameyouwant (I'm not sure if setting the domain name with broadband will cause a problem, I don't have broadband. -.-')

nakkaya 01-16-2003 10:17 PM

there is no filer called /etc/HOSTNAME
how can i create it

KnightAbel 01-16-2003 10:41 PM

just use a text editor, mine looks like this:

hell.evil

seriously, that's the whole file, it's not a big deal. :p

nakkaya 01-16-2003 10:57 PM

i created the file and reboot the machine but still hostname did not change

KnightAbel 01-16-2003 11:06 PM

I'm probably missing something then, I'm still pretty new to this myself, I remember that's what I did, but maybe there's some key point I just forgot about... have you looked to see if there is a configuration utility from Red Hat in the menu? I can't remember, I downgraded to 7.3 cause I had problems with 8.0.

bulliver 01-17-2003 09:09 PM

The file in question is /etc/hosts, not HOSTNAME ;)

KnightAbel 01-17-2003 10:08 PM

/etc/hosts is where you set the IP addresses for hosts on your LAN though. my hostname is specified /etc/HOSTNAME

so where am I going wrong here? Mine is setup that way on both my Slackware and Red Hat boxes, and I've reinstalled and simply let Red Hat configure the files for me. (slackware I had to do myself.)

bulliver 01-17-2003 11:12 PM

Really? I just put:

127.0.0.1 localhost.localdomain badcomputer

in /etc/hosts and:

HOSTNAME=badcomputer

in /etc/sysconfig/network. It works fine...

KnightAbel 01-17-2003 11:28 PM

oh, ok. hmm. well, /etc/hosts is the file that sets aliases for IP addresses.

you know what nakkaya? try setting it in /etc/sysconfig/network... now that I think about it, I believe I set it there as well... not entirely sure.


All times are GMT -5. The time now is 09:47 PM.