LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices



Reply
 
Search this Thread
Old 08-20-2005, 04:18 AM   #1
xxfunkxx
LQ Newbie
 
Registered: Jul 2004
Location: Vienna
Distribution: Debian Sid
Posts: 26

Rep: Reputation: 15
run x.org without keyboard and mouse


Hello!

I have created a touchscreen GUI to control the xmms player using ubuntu. I want to run the touchscreen as a standalone mp3player.

Having looking around in lots of forum i did not find how to configure x.org so that i can run it without mouse and keyboard?


I have tried the ServerFlag
Option "AllowMouseOpenFail" "true"

but without any success.

The x server does not start when the mouse or keyboard are disconected.
Are there any dummy plugs for keyboard and mouse?

Thanks for any help!

xxfunkxx
 
Old 08-20-2005, 05:25 AM   #2
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
Wow: presumably you want to be able to use the mouse and kbd sometime right? Or do you plan for this to be a dedicated, 100% of the time, player? (How would you edit playlists?) Otherwise it would be a pain to boot without kbd support by default.

Anyhoo - After you have booted, you can disconnect the kbd and mouse can't you?

I wonder what would happen if you edit out the keboard and mouse entries in Xorg.conf? Or, possibly you can remove the mouse/kdb seeking section of the boot script.

I havn't tried to boot ubuntu without kbd or mouse ... I'll try it right now:
... BIOS reports keyboard failure
... GRUB screen starts OK
... booting Ubuntu Hoary
... X starts up - I see the gnome login screen.

of course, I cannot login - presumably you've set things up to login a particular user on startup. however - Xserver would seem to be running.
 
Old 08-24-2005, 05:41 AM   #3
xxfunkxx
LQ Newbie
 
Registered: Jul 2004
Location: Vienna
Distribution: Debian Sid
Posts: 26

Original Poster
Rep: Reputation: 15
Simon Bridge thanks for the answer. The computer will act as a jukebox and will be placed in small shops and bars where the staff can select between readymade playlists. Thats why i dont need keyboard and mouse.

Booting Hoary without mouse and kbd the x server doesnt come up. Ubuntu shows me the tty1. I played around with the parameter of xorg but that didnīt work neither.
mmh. dont know what can i do.
xxfunkxx
 
Old 08-24-2005, 06:33 AM   #4
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
Sorry - I can't think of any reason leaving the kbd and mouse disconnected would mean the x server wouldn't start. Would you show us the boot messages?

(If you have this on a network, you should be able to access the logs too.)

Basically, you need to know why x thinks it needs the input devices.
 
Old 08-24-2005, 06:53 PM   #5
refdoc
Member
 
Registered: Aug 2005
Location: Scotland
Distribution: Ubuntu
Posts: 30

Rep: Reputation: 15
Remove the input devices from xorg.conf would be my first thought. Install an ssh server so that you have sideways access and then you can pull keyboard and mouse for good.
 
Old 08-25-2005, 07:43 AM   #6
xxfunkxx
LQ Newbie
 
Registered: Jul 2004
Location: Vienna
Distribution: Debian Sid
Posts: 26

Original Poster
Rep: Reputation: 15
Simon Bridge: If you can boot without connection of the 2 devices it sounds like a specific hardware constellation?

thanks refdoc. I already tried to run xorg with the comments on the InputDevices

So here are the log files.

part of xorg.conf
Quote:

Section "Module"
Load "bitmap"
Load "dbe"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "record"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "de"
Option "XkbOptions" "nodeadkeys"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection

Section "Device"
Identifier "Intel Corporation 82865G Integrated Graphics Device"
Driver "i810"
BusID "PCI:0:2:0"
EndSection




Section "InputDevice"
Identifier "Touchscreen"
Driver "evtouch"
Option "Device" "/dev/input/event3"
Option "DeviceName" "touchscreen"
Option "MinX" "2778"
Option "MinY" "2386"
Option "MaxX" "14100"#"13910"
Option "MaxY" "13488"
Option "DragTimer" "200"
Option "MoveLimit" "600"
Option "ReportingMode" "Raw"
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
# InputDevice "Generic Keyboard"
# InputDevice "Configured Mouse"
InputDevice "Touchscreen"
EndSection

Section "DRI"
Mode 0666
EndSection


output of Xorg log file:
Quote:
$ less /var/log/Xorg.0.log | grep EE
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(EE) xf86OpenSerial: Cannot open device /dev/input/event3
(EE) PreInit failed for input device ""
output of .xsession-errors

Quote:
/etc/gdm/PreSession/Default: Registering your session with wtmp and utmp
/etc/gdm/PreSession/Default: running: /usr/bin/X11/sessreg -a -w /var/log/wtmp -u /var/run/utmp -x "/var/lib/gdm/:0.Xservers" -h "" -l ":0" "jimi"
/etc/gdm/Xsession: Beginning session setup...
/usr/bin/startxfce4: X server already running on display :0
Agent pid 8522
 
Old 08-25-2005, 08:19 AM   #7
refdoc
Member
 
Registered: Aug 2005
Location: Scotland
Distribution: Ubuntu
Posts: 30

Rep: Reputation: 15
Yes you have commented out the input devices in your layout, but the actual sections are still there. Coment them out too.
 
Old 08-25-2005, 08:23 AM   #8
xxfunkxx
LQ Newbie
 
Registered: Jul 2004
Location: Vienna
Distribution: Debian Sid
Posts: 26

Original Poster
Rep: Reputation: 15
i forget one thing to mention.
X and gdm keep on running, so the autologin from gdm is running i think
xxfunkxx

Last edited by xxfunkxx; 08-25-2005 at 08:28 AM.
 
Old 08-25-2005, 11:21 AM   #9
xxfunkxx
LQ Newbie
 
Registered: Jul 2004
Location: Vienna
Distribution: Debian Sid
Posts: 26

Original Poster
Rep: Reputation: 15
still no luck. I intalled Hoary on another machine and for my surprise the X server comes up without having connected mouse and kbd. So i copied that xorg,conf to the PC where it does not work. But no luck with that neither with the commands on the entire Section "InputDevice".

Very strange. What can that be?
xxfunkxx
 
Old 08-25-2005, 08:20 PM   #10
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
This is hardware rather than software. You need to know more about your bios and your motherboard.

Perhaps the bios thinks it is a safety feature to disable, say, part of the videocard if you do not have kbd or mouse plugged in? In which case there may be a switch in your cmos setup...

Other than that - consult your motherboard manual... there may be a jumper to change somewhere.

And, of course, you can set a script to catch your syslog for the (kbd/mouse-less) session so when you reaccess with the keyboard you can see what happened.
 
Old 09-15-2005, 05:22 PM   #11
xkev
LQ Newbie
 
Registered: Sep 2005
Posts: 1

Rep: Reputation: 0
I have an evtouch screen working for my receptionist panel. You need to alter the 'eventX' device name when you don't have other input devices attached. It has decremented to something like 2 or 1.

Also, if you can't get X to start without keyboard, due to no core keyboard, use the "void" driver (versus kbd or keyboard). I have no problem with my particular ITX board starting without a keyboard, but I did experience exactly your issue when my eventX decremented after mouse was removed.

Section "InputDevice"
Identifier "void"
Driver "void"
Option "CoreKeyboard"
EndSection

Section "ServerLayout"
...
InputDevice "void"
InputDevice "touchscreen"
EndSection
 
Old 09-23-2005, 08:01 AM   #12
xxfunkxx
LQ Newbie
 
Registered: Jul 2004
Location: Vienna
Distribution: Debian Sid
Posts: 26

Original Poster
Rep: Reputation: 15
Hi xkev!
Thanks for your promising tip. I was about to gave up the configuration and just hide the keyboard somewhere.
Going to try this soon as posible.

xxfunkxx

Last edited by xxfunkxx; 09-27-2005 at 09:44 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
X.org keyboard layout problem drigz Linux - Software 4 08-20-2004 08:27 AM
mouse / keyboard not working with X.org curmudgeon42 Linux - Software 2 08-16-2004 01:43 PM
Office.org won't run after update dtee Linux - Software 3 10-19-2003 01:13 PM
USB mouse, keyboard, hid, console mouse problems jqcaducifer Linux - General 1 08-05-2003 10:43 AM
OpenOffice.org run problem (Application ErrorAborted) sooaai Linux - Software 2 04-10-2003 03:12 PM


All times are GMT -5. The time now is 02:06 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration