-   Ubuntu (
-   -   run without keyboard and mouse (

xxfunkxx 08-20-2005 03:18 AM

run without keyboard and mouse

I have created a touchscreen GUI to control the xmms player using ubuntu. I want to run the touchscreen as a standalone mp3player.

Having looking around in lots of forum i did not find how to configure so that i can run it without mouse and keyboard?

I have tried the ServerFlag
Option "AllowMouseOpenFail" "true"

but without any success.

The x server does not start when the mouse or keyboard are disconected.
Are there any dummy plugs for keyboard and mouse?

Thanks for any help!


Simon Bridge 08-20-2005 04:25 AM

Wow: presumably you want to be able to use the mouse and kbd sometime right? Or do you plan for this to be a dedicated, 100% of the time, player? (How would you edit playlists?) Otherwise it would be a pain to boot without kbd support by default.

Anyhoo - After you have booted, you can disconnect the kbd and mouse can't you?

I wonder what would happen if you edit out the keboard and mouse entries in Xorg.conf? Or, possibly you can remove the mouse/kdb seeking section of the boot script.

I havn't tried to boot ubuntu without kbd or mouse ... I'll try it right now:
... BIOS reports keyboard failure
... GRUB screen starts OK
... booting Ubuntu Hoary
... X starts up - I see the gnome login screen.

of course, I cannot login - presumably you've set things up to login a particular user on startup. however - Xserver would seem to be running.

xxfunkxx 08-24-2005 04:41 AM

Simon Bridge thanks for the answer. The computer will act as a jukebox and will be placed in small shops and bars where the staff can select between readymade playlists. Thats why i dont need keyboard and mouse.

Booting Hoary without mouse and kbd the x server doesnt come up. Ubuntu shows me the tty1. I played around with the parameter of xorg but that didnīt work neither.
mmh. dont know what can i do.

Simon Bridge 08-24-2005 05:33 AM

Sorry - I can't think of any reason leaving the kbd and mouse disconnected would mean the x server wouldn't start. Would you show us the boot messages?

(If you have this on a network, you should be able to access the logs too.)

Basically, you need to know why x thinks it needs the input devices.

refdoc 08-24-2005 05:53 PM

Remove the input devices from xorg.conf would be my first thought. Install an ssh server so that you have sideways access and then you can pull keyboard and mouse for good.

xxfunkxx 08-25-2005 06:43 AM

Simon Bridge: If you can boot without connection of the 2 devices it sounds like a specific hardware constellation?

thanks refdoc. I already tried to run xorg with the comments on the InputDevices

So here are the log files.

part of xorg.conf

Section "Module"
Load "bitmap"
Load "dbe"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "record"
Load "type1"
Load "vbe"

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "de"
Option "XkbOptions" "nodeadkeys"

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"

Section "Device"
Identifier "Intel Corporation 82865G Integrated Graphics Device"
Driver "i810"
BusID "PCI:0:2:0"

Section "InputDevice"
Identifier "Touchscreen"
Driver "evtouch"
Option "Device" "/dev/input/event3"
Option "DeviceName" "touchscreen"
Option "MinX" "2778"
Option "MinY" "2386"
Option "MaxX" "14100"#"13910"
Option "MaxY" "13488"
Option "DragTimer" "200"
Option "MoveLimit" "600"
Option "ReportingMode" "Raw"

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
# InputDevice "Generic Keyboard"
# InputDevice "Configured Mouse"
InputDevice "Touchscreen"

Section "DRI"
Mode 0666

output of Xorg log file:

$ less /var/log/Xorg.0.log | grep EE
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(EE) xf86OpenSerial: Cannot open device /dev/input/event3
(EE) PreInit failed for input device ""
output of .xsession-errors


/etc/gdm/PreSession/Default: Registering your session with wtmp and utmp
/etc/gdm/PreSession/Default: running: /usr/bin/X11/sessreg -a -w /var/log/wtmp -u /var/run/utmp -x "/var/lib/gdm/:0.Xservers" -h "" -l ":0" "jimi"
/etc/gdm/Xsession: Beginning session setup...
/usr/bin/startxfce4: X server already running on display :0
Agent pid 8522

refdoc 08-25-2005 07:19 AM

Yes you have commented out the input devices in your layout, but the actual sections are still there. Coment them out too.

xxfunkxx 08-25-2005 07:23 AM

i forget one thing to mention.
X and gdm keep on running, so the autologin from gdm is running i think

xxfunkxx 08-25-2005 10:21 AM

still no luck. I intalled Hoary on another machine and for my surprise the X server comes up without having connected mouse and kbd. So i copied that xorg,conf to the PC where it does not work. But no luck with that neither with the commands on the entire Section "InputDevice".

Very strange. What can that be?

Simon Bridge 08-25-2005 07:20 PM

This is hardware rather than software. You need to know more about your bios and your motherboard.

Perhaps the bios thinks it is a safety feature to disable, say, part of the videocard if you do not have kbd or mouse plugged in? In which case there may be a switch in your cmos setup...

Other than that - consult your motherboard manual... there may be a jumper to change somewhere.

And, of course, you can set a script to catch your syslog for the (kbd/mouse-less) session so when you reaccess with the keyboard you can see what happened.

xkev 09-15-2005 04:22 PM

I have an evtouch screen working for my receptionist panel. You need to alter the 'eventX' device name when you don't have other input devices attached. It has decremented to something like 2 or 1.

Also, if you can't get X to start without keyboard, due to no core keyboard, use the "void" driver (versus kbd or keyboard). I have no problem with my particular ITX board starting without a keyboard, but I did experience exactly your issue when my eventX decremented after mouse was removed.

Section "InputDevice"
Identifier "void"
Driver "void"
Option "CoreKeyboard"

Section "ServerLayout"
InputDevice "void"
InputDevice "touchscreen"

xxfunkxx 09-23-2005 07:01 AM

Hi xkev!
Thanks for your promising tip. I was about to gave up the configuration and just hide the keyboard somewhere.
Going to try this soon as posible.


All times are GMT -5. The time now is 05:55 AM.