LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 08-19-2004, 05:19 PM   #1
drigz
Member
 
Registered: Apr 2004
Distribution: Gentoo ~x86
Posts: 407

Rep: Reputation: 30
X.org keyboard layout problem


I live in Britain, and so want a British keyboard layout. However, although xorg.conf says to use a gb layout (see below), it doesn't. I can fix it by changing the rules xfree from xorg, but then I get an error on opening X. Here are the relevant lines from xorg.conf:

Code:
Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "keyboard"
        Option      "XkbRules" "xorg"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "gb"
EndSection
 
Old 08-19-2004, 05:44 PM   #2
320mb
Senior Member
 
Registered: Nov 2002
Location: pikes peak
Distribution: Slackware, LFS
Posts: 2,577

Rep: Reputation: 47
I guess you need to create a symlink...................
Code:
ln -s path/to/keymap /usr/share/kbd/keymaps/defkeymap.map.gz
where path/to/keymap would be the layout you need, like--
i386/qwerty/nl.map.gz.

look thru those directories and find the layout you want to use......
 
Old 08-20-2004, 05:16 AM   #3
drigz
Member
 
Registered: Apr 2004
Distribution: Gentoo ~x86
Posts: 407

Original Poster
Rep: Reputation: 30
Done - no difference. BTW, in normal console only mode (no X) I have the uk keymap.
 
Old 08-20-2004, 06:47 AM   #4
BinaryLinux
Member
 
Registered: May 2004
Distribution: Slackware 9.1 and 10
Posts: 35

Rep: Reputation: 15
My keyboard section is similar to yours except yours has more lines, heres mine for you to try.

Code:
Section "InputDevice"
    Identifier "Keyboard1"
    Driver "Keyboard"
    Option "XkbLayout" "gb"
EndSection

Last edited by BinaryLinux; 08-20-2004 at 07:38 AM.
 
Old 08-20-2004, 07:27 AM   #5
drigz
Member
 
Registered: Apr 2004
Distribution: Gentoo ~x86
Posts: 407

Original Poster
Rep: Reputation: 30
I fixed it - GNOME was arbitrating the keyboard layout, so I had to change in in Applications -> Desktop Preferences -> Keyboard.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
KDE Keyboard Shortcuts with different Keyboard Layout hellblade Linux - Software 5 04-18-2006 12:40 AM
keyboard layout acidjuice Slackware 10 02-22-2005 08:51 AM
Keyboard Layout AlessPT Linux - Software 1 12-20-2004 01:07 AM
Keyboard layout problem theonebeyond Linux - General 22 12-13-2004 01:38 AM
Keyboard layout Nylex Slackware 2 08-08-2003 10:25 AM


All times are GMT -5. The time now is 01:39 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration