LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 03-30-2008, 12:12 PM   #1
clb
Member
 
Registered: Sep 2004
Location: UK
Distribution: Ubuntu
Posts: 117

Rep: Reputation: 16
No acceleration with Kubuntu 7.10, kernel 2.6.22-14-generic and ATI Radeon 9550


Hi all,
I recently installed Kubuntu 7.10, since installing it I am unable to get the graphics card working. It was running on 7.04 with no problems.

Initially I tried to use the Restricted Drivers feature, which failed, I then used Envy to install the graphics drivers, which failed as fglrxinfo reports that it is still using MESA as the OpenGL renderer. After trying all of the available drivers from Envy I downloaded the ATI drivers from their site and tried to install manually. According to the driver release notes on the ATI site the proprietary driver needs the "agpgart" kernel module to be blacklisted, but this has made no difference.
Running "lsmod | grep "agp" " results in:
Code:
chris@chris-desktop:~/Desktop$ lsmod | grep "agp"
intel_agp              25620  0
agpgart                35016  2 fglrx,intel_agp
Checking "dmesg | grep "fglrx" " shows:
Code:
chris@chris-desktop:~/Desktop$ dmesg | grep "fgl"
[   32.284037] fglrx: module license 'Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY' taints kernel.
[   32.313634] [fglrx] Maximum main memory to use for locked dma buffers: 2896 MBytes.
[   32.313672] [fglrx] ASYNCIO init succeed!
[   32.313831] [fglrx] PAT is enabled successfully!
[   32.314368] [fglrx] module loaded - fglrx 8.47.3 [Feb 25 2008] on minor 0
[   35.289415] [fglrx] Internal AGP is not supported in 2.6 kernel.
From this I presume that I need to enable Internal AGP in the kernel, but I have no idea how to do this.

Any help would be greatly appreciated,
Chris
 
Old 03-31-2008, 07:29 AM   #2
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
Quote:
Code:
[   35.289415] [fglrx] Internal AGP is not supported in 2.6 kernel.
From this I presume that I need to enable Internal AGP in the kernel
No... it means you have to disable agp support. Intuitive huh?

In particular, you need to make sure that the agpgart module is not loaded if you want to use fglrx's internal AGP support. (There is a line in xorg.conf for this).

However, you may not need to. There is no conflict here - fglrx is telling you that it is using agpgart instead of it's internal agp. If performance is not affected, leave it alone.

check: glxinfo | grep render

Make sure you have DRI enabled in xorg.conf

... if you still have problems.

Last edited by Simon Bridge; 03-31-2008 at 07:32 AM.
 
Old 03-31-2008, 08:14 AM   #3
clb
Member
 
Registered: Sep 2004
Location: UK
Distribution: Ubuntu
Posts: 117

Original Poster
Rep: Reputation: 16
Ok, that makes sense.

Code:
chris@chris-desktop:~/Desktop$ glxinfo | grep render
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
OpenGL renderer string: Mesa GLX Indirect
Unfortunately performance is affected, quite significantly, although whether due to the agpgart thing or the driver not being loaded I'm not sure. From fglrxinfo I get:

Code:
chris@chris-desktop:~/Desktop$ fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.4 (2.1 Mesa 7.0.1)
.

I wouldn't mind, or probably wouldn't even notice anything was wrong, but I have no accelerated graphics at all. 2d works perfectly but any games or graphics intensive applications just go so slow. fgl_glxgears segfaults, glxgears reports 305 fps in a small window, but as soon as I enlarge it the rate drops to 42. Only problem is its ridiculously choppy, the gears spinning cant be seen at all. It's like watching a series of still photographs in slow motion.

Apologies for the length of the post, but I have also included my xorg.conf here. I can't see anything wrong with it, but I'm no expert with X.

Code:
chris@chris-desktop:~/Desktop$ cat /etc/X11/xorg.conf
# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
EndSection

Section "InputDevice"
        Identifier      "Generic Keyboard"
        Driver          "kbd"
        Option          "CoreKeyboard"
        Option          "XkbRules"      "xorg"
        Option          "XkbModel"      "pc105"
        Option          "XkbLayout"     "gb"
        Option          "XkbOptions"    "lv3:ralt_switch"
EndSection

Section "Module"
        Load            "bitmap"
        Load            "ddc"
        Load            "dri"
        Load            "extmod"
        Load            "freetype"
        Load            "glx"
        Load            "int10"
        Load            "type1"
        Load            "vbe"
EndSection

Section "InputDevice"
        Identifier      "Configured Mouse"
        Driver          "mouse"
        Option          "CorePointer"
        Option          "Device"        "/dev/input/mice"
        Option          "Protocol"      "ImPS/2"
        Option          "ZAxisMapping"  "4 5"
        Option          "Emulate3Buttons"       "true"
EndSection

Section "InputDevice"
        Driver          "wacom"
        Identifier      "stylus"
        Option          "Device"        "/dev/input/wacom"
        Option          "Type"  "stylus"
        Option          "ForceDevice"   "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
        Driver          "wacom"
        Identifier      "eraser"
        Option          "Device"        "/dev/input/wacom"
        Option          "Type"  "eraser"
        Option          "ForceDevice"   "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
        Driver          "wacom"
        Identifier      "cursor"
        Option          "Device"        "/dev/input/wacom"
        Option          "Type"  "cursor"
        Option          "ForceDevice"   "ISDV4"# Tablet PC ONLY
EndSection

Section "Device"
        Identifier      "ATI Technologies Inc RV350 AS [Radeon 9550]"
        Driver          "fglrx"
        Busid           "PCI:1:0:0"
        Option          "DRI"
        Option          "VideoOverlay"  "on"
        Option          "OpenGLOverlay" "off"
EndSection

Section "Monitor"
        Identifier      "SyncMaster"
        Option          "DPMS"
EndSection

Section "Screen"
        Identifier      "Default Screen"
        Device          "ATI Technologies Inc RV350 AS [Radeon 9550]"
        Monitor         "SyncMaster"
        Defaultdepth    24
        SubSection "Display"
                Modes           "1280x1024"     "1280x960"      "1152x864"     "1024x768"       "832x624"       "800x600"       "720x400"       "640x480"
        EndSubSection
EndSection

Section "ServerLayout"
        Identifier      "Default Layout"
  screen "Default Screen"
        Inputdevice     "Generic Keyboard"
        Inputdevice     "Configured Mouse"

        # Uncomment if you have a wacom tablet
        #       InputDevice     "stylus"        "SendCoreEvents"
        #       InputDevice     "cursor"        "SendCoreEvents"
        #       InputDevice     "eraser"        "SendCoreEvents"
EndSection


Section "DRI"
        Mode    0666
EndSection
Section "Extensions"
        Option          "Composite"     "Enable"
EndSection
Thanks for your time and help so far,
Chris
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
radeon 9550 cant get hardware acceleration to work lysandros Linux - Hardware 1 04-02-2007 06:19 AM
Ubuntu Edgy no 3d acceleration with Radeon 9550 clb Ubuntu 5 03-01-2007 12:31 PM
ATI drivers fakes- Impossible to run 3D on ATI Radeon 9550 ilpadrino Linux - Hardware 29 06-24-2006 01:59 PM
ATI Radeon 9550 / NO acelleration at all... amobius Linux - Hardware 2 09-29-2005 05:35 PM
ATI Redeon 9550 with suse 9.3, no 3D acceleration danke Linux - Hardware 3 08-22-2005 12:52 PM


All times are GMT -5. The time now is 04:06 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration