LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-07-2006, 11:14 PM   #1
MS3FGX
Guru
 
Registered: Jan 2004
Location: NJ, USA
Distribution: Slackware, Debian
Posts: 5,852

Rep: Reputation: 351Reputation: 351Reputation: 351Reputation: 351
udev problems in current


So, I updated my machine to the changes from Aug 7th, only to find that when I restarted, it wouldn't boot. Lovely.

The machine was stopping right at the end of rc.S, and not getting any farther. The last thing it printed was "Using /etc/random-seed to initialize /dev/urandom.". I booted to some LiveCDs, checked everything out, and I couldn't find what the problem was. Eventually I realized that it would boot with a 2.4 kernel, but not a 2.6 kernel, and that udev was the problem. So I booted with the Slackware install CD's kernel, got in there, and chmod -x rc.udev. This got the machine started, but obviously my devices that were using udev before are not working.

I will admit, I know almost nothing of udev. With the previous versions of udev, I managed to get it to load up my optical drives and USB headset, and they worked fine. I also had hotplug running, so I think most of the hardware was running though that. Now that udev isn't running, I had to remake the symlinks to my optical drives, and my USB headset doesn't show up in any of my software.

If I try and start udev after the machine boots, the situation just gets worse. My mouse stops working, sound stops working, and I can't start any more VTs. It seems like udev isn't creating all the device files my system needs. It made ones for my video card and drives, but that seemed like it.

So I guess my question is, what exactly do I need to do to get udev working with this new version, and have all of my devices work?
 
Old 08-07-2006, 11:52 PM   #2
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,529

Rep: Reputation: 407Reputation: 407Reputation: 407Reputation: 407Reputation: 407
have you do exactly as Pat said? (put all .new files in /etc/rc.d/ into place)

I also have upgraded to latest udev and sysvinit and it's working fine here
 
Old 08-08-2006, 12:22 AM   #3
drkstr
Senior Member
 
Registered: Feb 2006
Location: Seattle, WA: USA
Distribution: Slackware 11.0
Posts: 1,191

Rep: Reputation: 45
Worked ok for me on clean install. You problem is probably being caused by changes to some config files that didn't make it to the right place. Copying the .new files over the original should do the the trick, just make sure you don't lose any custom changes you might have put into the originals.

regards,
...drkstr
 
Old 08-08-2006, 12:29 AM   #4
MS3FGX
Guru
 
Registered: Jan 2004
Location: NJ, USA
Distribution: Slackware, Debian
Posts: 5,852

Original Poster
Rep: Reputation: 351Reputation: 351Reputation: 351Reputation: 351
All of the .new files have been moved into place as they should be.

I am running a custom compile of 2.6.12, by the way.

EDIT:

I have removed and reinstalled the udev package, and no change. I tried to start udev again after the machine has started up, and again lost my VTs and sound. Mouse seemed to keep working this time though. When doing "/etc/rc.d/rc.udev start" it takes a very long time for it to complete. Something like 3 or 4 minutes. Not sure if that means anything or not.

Last edited by MS3FGX; 08-08-2006 at 01:54 AM.
 
Old 08-08-2006, 12:37 PM   #5
shilo
Senior Member
 
Registered: Nov 2002
Location: Stockton, CA
Distribution: Slackware 11 - kernel 2.6.19.1 - Dropline Gnome 2.16.2
Posts: 1,132

Rep: Reputation: 49
I believe your kernel is too old.

Install a newer one.

***EDIT***

You can see in the ChangeLog that PV uses Piter Punk's changes, http://piterpunk.info02.com.br/extra/ . There you can see that you need min. kernel version of 2.6.15.

Last edited by shilo; 08-08-2006 at 12:48 PM.
 
Old 08-09-2006, 12:07 AM   #6
MS3FGX
Guru
 
Registered: Jan 2004
Location: NJ, USA
Distribution: Slackware, Debian
Posts: 5,852

Original Poster
Rep: Reputation: 351Reputation: 351Reputation: 351Reputation: 351
Yes, that had occurred to me this morning, so I compiled 2.6.16.

Between that, the newest udev update in current, and some changes to the rules file, things seem to be working properly now.
 
Old 08-09-2006, 12:28 AM   #7
Yalla-One
Member
 
Registered: Oct 2004
Location: Norway
Distribution: Slackware, CentOS
Posts: 635

Rep: Reputation: 35
Quote:
Originally Posted by MS3FGX
Between that, the newest udev update in current, and some changes to the rules file, things seem to be working properly now.
Would you mind sharing with us the changes you made to the rules file to make it work? Might save some others some time when searching the threads

-Y1
 
Old 08-09-2006, 01:18 AM   #8
MS3FGX
Guru
 
Registered: Jan 2004
Location: NJ, USA
Distribution: Slackware, Debian
Posts: 5,852

Original Poster
Rep: Reputation: 351Reputation: 351Reputation: 351Reputation: 351
Just for my own specific hardware, the rules worked well enough stock, but things I wanted added like I had in my previous udev setup, like the kqemu module/node, I had to do manually.
 
Old 08-09-2006, 03:34 AM   #9
cRoW2k
LQ Newbie
 
Registered: Aug 2006
Location: Italy
Distribution: Slackware
Posts: 2

Rep: Reputation: 0
IPW2200 modules stop to work with latest UDEV release. Must rollback to 0.71. wainting for a fix
 
Old 08-09-2006, 04:08 AM   #10
vharishankar
Senior Member
 
Registered: Dec 2003
Posts: 3,142
Blog Entries: 4

Rep: Reputation: 121Reputation: 121
udev is problematic generally. In Debian every now and then udev fails to load on startup. This prevents a lot of device drivers from loading and leaves me to reboot and try again. This is a peculiar issue...

Before using udev, I had none of these problems. discover and hotplug worked fine for me.
 
Old 08-09-2006, 07:19 AM   #11
rkelsen
Senior Member
 
Registered: Sep 2004
Distribution: slackware
Posts: 1,748

Rep: Reputation: 159Reputation: 159
Quote:
Originally Posted by Harishankar
udev is problematic generally. In Debian every now and then udev fails to load on startup. This prevents a lot of device drivers from loading and leaves me to reboot and try again. This is a peculiar issue...
It does sound very strange.
Quote:
Originally Posted by Harishankar
Before using udev, I had none of these problems. discover and hotplug worked fine for me.
Yes. Same here. 2.4 and hotplug were the pinnacle of hardware support for me. Admittedly, that was on older hardware. 2.6 and udev seemed a step backwards at first. Even now there are modules which refuse to auto-load under 2.6 and must be "modprobed" into place. For example: parport_pc and lp. Both of these used to auto-load for me under 2.4 and hotplug...
 
Old 08-09-2006, 05:13 PM   #12
MS3FGX
Guru
 
Registered: Jan 2004
Location: NJ, USA
Distribution: Slackware, Debian
Posts: 5,852

Original Poster
Rep: Reputation: 351Reputation: 351Reputation: 351Reputation: 351
Ah, today Pat decides to actually say in the changelog that 2.6.15+ is now required. Cute.
 
Old 08-12-2006, 05:51 AM   #13
cRoW2k
LQ Newbie
 
Registered: Aug 2006
Location: Italy
Distribution: Slackware
Posts: 2

Rep: Reputation: 0
yeah. The latest udev (-4) solve problem of network and cdrom . For me, to made work ipw2200 , i've delete the network.rules under /etc/udev/rules.d. After reboot the new version of udev re-create the file but with the entry commented.
 
Old 08-12-2006, 04:04 PM   #14
jam222
Member
 
Registered: Feb 2004
Posts: 56

Rep: Reputation: 15
Can some please tell me how do I boot from Installation CD. wheever I start it asks me for new installation and I cannot access my drive where I have already installed Slackware. I have got the same problem
 
Old 08-12-2006, 05:11 PM   #15
regis_n_bits
Member
 
Registered: Mar 2006
Distribution: Slackware64 14.1 (kernel 3.13.5)
Posts: 83

Rep: Reputation: Disabled
jam,

If your root partition is at '/dev/sda1' and you want to use the default kernel 'bare.i' then the command to enter at the first prompt is:

bare.i root=/dev/sda1 noinitrd ro

There is some help available at the prompt using function keys F1 to F5 when you boot with the CD.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to upgrade to -current ? New udev for new kernel !? introuble Slackware 8 04-21-2006 02:47 PM
udev update question (from Current Changelog) dhave Slackware 31 07-22-2005 07:49 PM
problems with udev can3p Slackware 7 06-09-2005 06:33 PM
problems with udev - 2.6.10 kernel akshunj Slackware 8 01-21-2005 10:45 AM
udev/hal, problems... TazG Linux - Hardware 0 09-28-2004 02:38 PM


All times are GMT -5. The time now is 07:16 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration