LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 12-29-2006, 03:31 AM   #1
system_elite
LQ Newbie
 
Registered: Dec 2006
Posts: 6

Rep: Reputation: 0
slackware 10.1 net problem


hi..can who help me?i was install slackware in kernel.
but my network don`t doing.. i was set:

/sbin/ifconfig eth0 inet 192.168.1.132 netmask 255.255.255.0 broadcast 192.168.1.1

/usb/sbin/iptables -t nat -A POSTROUTING -s 192.168.1.1 -j MASQUERADE

/etc/resolv.conf

i have be connected on internet with one friend.and i have computer connected to router...and i have two computers..this computers where i have windows an other where i have linux
and i can connect from tihese computer to other with putty..



sorry for my eanglish:S
i please for yours help
 
Old 12-29-2006, 04:22 AM   #2
dombrowsky
Member
 
Registered: Dec 2005
Location: New York
Distribution: Debian/GNU
Posts: 235

Rep: Reputation: 31
just a suggestion: I know that for me, if I know where you're coming from, I can understand broken english much better. Judging from your english I'm guessing slavic, but I really have no idea.

I don't even see a question in there. The setup looks correct to me.
 
Old 12-29-2006, 07:08 AM   #3
system_elite
LQ Newbie
 
Registered: Dec 2006
Posts: 6

Original Poster
Rep: Reputation: 0
look..i was configure network but it`s don`t working..
i was configure it:

/sbin/ifconfig eth0 inet 192.168.1.132 netmask 255.255.255.0 broadcast 192.168.1.1

/usb/sbin/iptables -t nat -A POSTROUTING -s 192.168.1.1 -j MASQUERADE

/etc/resolv.conf

maybe am i what forget config..
 
Old 12-29-2006, 09:20 AM   #4
dombrowsky
Member
 
Registered: Dec 2005
Location: New York
Distribution: Debian/GNU
Posts: 235

Rep: Reputation: 31
/etc/resolv.conf is a file. Not sure what you mean by listing it. The contents should contain your search domains and nameservers.
Code:
search nycap.rr.com
nameserver 24.92.226.x

your iptables setup looks correct. I have a nat.sh script which does basically the same thing ->
Code:
# Delete and flush. Default table is "filter". Others like "nat" must be explicitly stated.
iptables --flush            # Flush all the rules in filter and nat tables
iptables --table nat --flush
iptables --delete-chain     # Delete all chains that are not in default filter and nat table
iptables --table nat --delete-chain

# FORWARD packets received in eth1, and ACCEPT the packet
# only needed if the default policy is DROP ?
iptables --append FORWARD --in-interface eth1 -j ACCEPT

# for packets set out from eth0, after routing, masq the packet with
# this machine's ip addess
iptables --table nat --append POSTROUTING --out-interface eth0 -j MASQUERADE

echo 1 > /proc/sys/net/ipv4/ip_forward             # Enables packet forwarding by kernel
so looks like you're good to go.
 
Old 12-29-2006, 10:01 AM   #5
system_elite
LQ Newbie
 
Registered: Dec 2006
Posts: 6

Original Poster
Rep: Reputation: 0
yes i was do this but network dont work:s
 
Old 12-30-2006, 02:28 AM   #6
Wim Sturkenboom
Senior Member
 
Registered: Jan 2005
Location: Roodepoort, South Africa
Distribution: Slackware 10.1/10.2/12, Ubuntu 12.04, Crunchbang Statler
Posts: 3,786

Rep: Reputation: 282Reputation: 282Reputation: 282
The command netconfig might help you to configure the network. Not a network expert, but why is your broadcast ending with 1 ?

First test without iptables.
What is output of ifconfig for eth0 ?
 
Old 12-30-2006, 04:14 PM   #7
system_elite
LQ Newbie
 
Registered: Dec 2006
Posts: 6

Original Poster
Rep: Reputation: 0
i must have 1 in broadcast because i have that config on windows.
 
Old 12-31-2006, 05:48 AM   #8
urka58
Member
 
Registered: Nov 2003
Distribution: slackware 14
Posts: 530

Rep: Reputation: 30
I believe there is some confusion....may be what you're calling "broadcast" is actually "gateway" ?
First check how your router is set (basically if it is acting as DHCP server. Most of routers usually do as default).
If this is the case just use
/sbin/dhcpcd -d -t 15
where the -d option stands for daemon and -t 15 is the timeout setting.
If your router is configured not to act as DHCP server use
/sbin/ifconfig eth0 192.168.x.x netmask 255.255.255.0
the broadcast address will be automatically guessed by ifconfig (192.168.x.255)
To add your gateway do
/sbin/route add default gw 192.168.x.y
where 192.168.x.y is the address of your router.
Slackware comes with a very useful tool called "netconfig". This tool will make your life easier.
On /etc/resolv.conf you must add the address of the DNS servers of your IP provider. Instead you could use the addresses you find here
http://www.opendns.com/start/
There are some extra small benefits
Hope this helps
Ciao
 
Old 12-31-2006, 08:58 AM   #9
system_elite
LQ Newbie
 
Registered: Dec 2006
Posts: 6

Original Poster
Rep: Reputation: 0
thx..now network doing thank you very much..
 
Old 01-03-2007, 02:31 PM   #10
system_elite
LQ Newbie
 
Registered: Dec 2006
Posts: 6

Original Poster
Rep: Reputation: 0
i dont know what is wrong..last time was doing network but now it dont working.
 
  


Reply

Tags
correct, firewall, important, iptables, routing, undefined


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
net config for slackware Wes527 Linux - Networking 6 10-01-2008 12:30 PM
Net::SSLeay and Slackware kdepa Slackware 1 03-29-2007 06:14 AM
slackware net configure padmakar Linux - Newbie 1 11-21-2006 02:49 AM
Net Send in slackware... phiberoptik Slackware 1 11-20-2004 12:35 PM
idea: sharing net connection, method: iptables..., problem: broken net connection :( danny2055 Linux - Networking 4 06-09-2003 07:00 AM


All times are GMT -5. The time now is 03:58 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration