LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   slackware 10.1 net problem (http://www.linuxquestions.org/questions/slackware-14/slackware-10-1-net-problem-514546/)

system_elite 12-29-2006 03:31 AM

slackware 10.1 net problem
 
hi..can who help me?i was install slackware in kernel.
but my network don`t doing.. i was set:

/sbin/ifconfig eth0 inet 192.168.1.132 netmask 255.255.255.0 broadcast 192.168.1.1

/usb/sbin/iptables -t nat -A POSTROUTING -s 192.168.1.1 -j MASQUERADE

/etc/resolv.conf

i have be connected on internet with one friend.and i have computer connected to router...and i have two computers..this computers where i have windows an other where i have linux
and i can connect from tihese computer to other with putty..



sorry for my eanglish:S
i please for yours help

dombrowsky 12-29-2006 04:22 AM

just a suggestion: I know that for me, if I know where you're coming from, I can understand broken english much better. Judging from your english I'm guessing slavic, but I really have no idea.

I don't even see a question in there. The setup looks correct to me.

system_elite 12-29-2006 07:08 AM

look..i was configure network but it`s don`t working..
i was configure it:

/sbin/ifconfig eth0 inet 192.168.1.132 netmask 255.255.255.0 broadcast 192.168.1.1

/usb/sbin/iptables -t nat -A POSTROUTING -s 192.168.1.1 -j MASQUERADE

/etc/resolv.conf

maybe am i what forget config..

dombrowsky 12-29-2006 09:20 AM

/etc/resolv.conf is a file. Not sure what you mean by listing it. The contents should contain your search domains and nameservers.
Code:

search nycap.rr.com
nameserver 24.92.226.x


your iptables setup looks correct. I have a nat.sh script which does basically the same thing ->
Code:

# Delete and flush. Default table is "filter". Others like "nat" must be explicitly stated.
iptables --flush            # Flush all the rules in filter and nat tables
iptables --table nat --flush
iptables --delete-chain    # Delete all chains that are not in default filter and nat table
iptables --table nat --delete-chain

# FORWARD packets received in eth1, and ACCEPT the packet
# only needed if the default policy is DROP ?
iptables --append FORWARD --in-interface eth1 -j ACCEPT

# for packets set out from eth0, after routing, masq the packet with
# this machine's ip addess
iptables --table nat --append POSTROUTING --out-interface eth0 -j MASQUERADE

echo 1 > /proc/sys/net/ipv4/ip_forward            # Enables packet forwarding by kernel

so looks like you're good to go.

system_elite 12-29-2006 10:01 AM

yes i was do this but network dont work:s

Wim Sturkenboom 12-30-2006 02:28 AM

The command netconfig might help you to configure the network. Not a network expert, but why is your broadcast ending with 1 ?

First test without iptables.
What is output of ifconfig for eth0 ?

system_elite 12-30-2006 04:14 PM

i must have 1 in broadcast because i have that config on windows.

urka58 12-31-2006 05:48 AM

I believe there is some confusion....may be what you're calling "broadcast" is actually "gateway" ?
First check how your router is set (basically if it is acting as DHCP server. Most of routers usually do as default).
If this is the case just use
/sbin/dhcpcd -d -t 15
where the -d option stands for daemon and -t 15 is the timeout setting.
If your router is configured not to act as DHCP server use
/sbin/ifconfig eth0 192.168.x.x netmask 255.255.255.0
the broadcast address will be automatically guessed by ifconfig (192.168.x.255)
To add your gateway do
/sbin/route add default gw 192.168.x.y
where 192.168.x.y is the address of your router.
Slackware comes with a very useful tool called "netconfig". This tool will make your life easier.
On /etc/resolv.conf you must add the address of the DNS servers of your IP provider. Instead you could use the addresses you find here
http://www.opendns.com/start/
There are some extra small benefits
Hope this helps
Ciao

system_elite 12-31-2006 08:58 AM

thx..now network doing thank you very much..

system_elite 01-03-2007 02:31 PM

i dont know what is wrong..last time was doing network but now it dont working.


All times are GMT -5. The time now is 07:51 PM.