LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-02-2004, 02:52 AM   #1
yenonn
Member
 
Registered: Feb 2003
Location: Malaysia
Distribution: Redhat 8.0, 9, Slackware 9.1
Posts: 511

Rep: Reputation: 30
slack doesnt shutdown automatically??


hi,

i have a ATX power supply.. previously, i had redhat. redhat shutdown my power supply automatically. now, i have slack9.1. but, it never shutdown my power supply automatically... how can i make it so that it will be able to turn off power supply automatically??
 
Old 01-02-2004, 03:30 AM   #2
nephilim
Member
 
Registered: Aug 2003
Location: Belgium
Distribution: Debian (server), Kubuntu (desktop)
Posts: 248

Rep: Reputation: 30
Look in /etc/rc.d to see if the line concerning APM is commented out. It probably is, so just uncomment it, reboot and it should be fine.
 
Old 01-02-2004, 03:31 AM   #3
codec
Member
 
Registered: Sep 2003
Location: mad.es.eu
Distribution: ubuntu 5.04 knoppix Slack91/10 freebsd51 vector4 redhat9
Posts: 304

Rep: Reputation: 30
need:
-recompile kernel with APM/ACPI
-with permission to shutdown (you can chmod 4750 and chown root:users)
 
Old 01-02-2004, 06:10 AM   #4
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
Or try adding :

apm=power-off

to your append line in the Slackware stanza in lilo.conf - ie for example

append="devfs=mount hdc=ide-scsi acpi=off quiet apm=power-off"

then type

/sbin/lilo

to make the changes take effect

Then use halt as Root user to shut the system down........
 
Old 01-02-2004, 06:16 AM   #5
Kovacs
Member
 
Registered: Jul 2003
Distribution: FreeBSD 8.2 RELEASE
Posts: 607

Rep: Reputation: 30
There have been a few threads like this and people start talking about recompiling kernels etc... either you've got a different set up than me or you're doing it the hard way.

Uncomment this line in /etc/rc.d/rc.modules:

# /sbin/modprobe apm

Reboot and then next time you want to shutdown, the pc will turn itself off automagically with shutdown, halt etc.
 
Old 01-02-2004, 06:19 AM   #6
nephilim
Member
 
Registered: Aug 2003
Location: Belgium
Distribution: Debian (server), Kubuntu (desktop)
Posts: 248

Rep: Reputation: 30
Quote:
Originally posted by Kovacs
Uncomment this line in /etc/rc.d/rc.modules:

# /sbin/modprobe apm
I see now that I didn't type the filename correctly in my previous thread, but that's the way I've done it too.
 
Old 01-02-2004, 09:38 AM   #7
Whitehat
Senior Member
 
Registered: Feb 2003
Location: The Cold North
Distribution: SuSE 9.1
Posts: 1,289

Rep: Reputation: 45
Just to be witness to the above working, I've done it too.

I just put in the following in my rc.local file: ( I couldn't fine anything in rc.modules)

modprobe apm

Then when I shutdown I just do:

shutdown -h now
-or-
shutdown -r now

Peace,
Whitehat
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
sound doesnt turn on automatically invinciblegod Linux - General 2 07-27-2005 01:37 PM
Automatically running script at shutdown samac Slackware 2 05-14-2005 10:10 AM
shutdown automatically if linux system is idle for sometime ahalya Linux - Software 1 03-30-2005 12:39 AM
snd_emu10k1 doesnt load automatically in 2.6 yenonn Slackware 3 12-19-2003 05:37 PM
how to automatically power off after shutdown in redhat7.3(kernel 2.4.20) prad Linux - General 8 12-18-2002 02:37 PM


All times are GMT -5. The time now is 06:42 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration