LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 12-17-2002, 11:42 PM   #1
prad
LQ Newbie
 
Registered: Dec 2002
Location: Shanghai,China
Posts: 17

Rep: Reputation: 0
how to automatically power off after shutdown in redhat7.3(kernel 2.4.20)


I have updated my kernel from 2.4.18 to 2.4.20, now my redhat can't automatically poweroff after shutdown, what I should do?
 
Old 12-18-2002, 12:33 AM   #2
nxny
Member
 
Registered: May 2002
Location: AK - The last frontier.
Distribution: Red Hat 8.0, Slackware 8.1, Knoppix 3.7, Lunar 1.3, Sorcerer
Posts: 771

Rep: Reputation: 30
How did you update your kernel? Did you compile it or use an rpm?
 
Old 12-18-2002, 12:39 AM   #3
prad
LQ Newbie
 
Registered: Dec 2002
Location: Shanghai,China
Posts: 17

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by nxny
How did you update your kernel? Did you compile it or use an rpm?
I compile the kernel and select "Power Management support",what I should do next?
 
Old 12-18-2002, 01:42 AM   #4
mcleodnine
Senior Member
 
Registered: May 2001
Location: Left Coast - Canada
Distribution: s l a c k w a r e
Posts: 2,731

Rep: Reputation: 45
Did you choose ACPI or APM for your kernel power support?

Is the APM module(if that's what you had before) loaded and do you have 'apmd' running?

If you're using ACPI is your BIOS capable and configured to support it?
 
Old 12-18-2002, 02:17 AM   #5
prad
LQ Newbie
 
Registered: Dec 2002
Location: Shanghai,China
Posts: 17

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by mcleodnine
Did you choose ACPI or APM for your kernel power support?

Is the APM module(if that's what you had before) loaded and do you have 'apmd' running?

If you're using ACPI is your BIOS capable and configured to support it?
This is part of my kernal config file,could u tell me where is wrong?

CONFIG_APM=y
# CONFIG_APM_IGNORE_USER_SUSPEND is not set
# CONFIG_APM_DO_ENABLE is not set
CONFIG_APM_CPU_IDLE=y
# CONFIG_APM_DISPLAY_BLANK is not set
CONFIG_APM_RTC_IS_GMT=y
# CONFIG_APM_ALLOW_INTS is not set
# CONFIG_APM_REAL_MODE_POWER_OFF is not set
 
Old 12-18-2002, 04:13 AM   #6
mcleodnine
Senior Member
 
Registered: May 2001
Location: Left Coast - Canada
Distribution: s l a c k w a r e
Posts: 2,731

Rep: Reputation: 45
looks ok to me. Try 'ps -e | grep apm' and see what you get.
 
Old 12-18-2002, 05:10 AM   #7
prad
LQ Newbie
 
Registered: Dec 2002
Location: Shanghai,China
Posts: 17

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by mcleodnine
looks ok to me. Try 'ps -e | grep apm' and see what you get.
root 495 1 0 17:04 ? 00:00:00 /usr/sbin/apmd -p 10 -w 5 -W -P
 
Old 12-18-2002, 03:30 PM   #8
nxny
Member
 
Registered: May 2002
Location: AK - The last frontier.
Distribution: Red Hat 8.0, Slackware 8.1, Knoppix 3.7, Lunar 1.3, Sorcerer
Posts: 771

Rep: Reputation: 30
For some buggy bios-es you might have to turn on CONFIG_APM_REAL_MODE_POWER_OFF, I've heard. What are your ACPI config directives?
 
Old 12-18-2002, 03:37 PM   #9
mcleodnine
Senior Member
 
Registered: May 2001
Location: Left Coast - Canada
Distribution: s l a c k w a r e
Posts: 2,731

Rep: Reputation: 45
If you're depending on APM the maybe we should be sure that ACPI hasn't assterted itself instead. 'lsmod | grep ospm'
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Power Wont turn off automatically marigb Linux - Hardware 5 11-16-2005 09:08 PM
How do you automatically power off after a program finishes? cscott Linux - Software 7 03-14-2005 04:36 AM
Power-off during shutdown causes kernel panic CapKrugers Linux - General 6 11-08-2004 07:52 PM
The computer does not power down automatically xcalibra Red Hat 2 10-05-2004 12:07 AM
Controlling desktop power, so that it doesn't go into standby automatically. dmccol Mandriva 6 05-03-2004 08:05 PM


All times are GMT -5. The time now is 05:23 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration