LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-12-2009, 10:12 AM   #1
mattington
LQ Newbie
 
Registered: Sep 2008
Location: Beijing
Distribution: Slackware, Arch
Posts: 10

Rep: Reputation: 0
no response from scim when trying to change languages in slackware 13


All,

I'm running slackware64-current and I've got scim running by following the hints and tips from slack 12.2. It runs in daemon mode when I start X. My $LANG is set to en_US.UTF-8. When I press ctrl+space scim doesn't do anything. I've tried changing the settings, selecting all languages, only selecting Chinese, English and Chinese, but still no response.

Has anyone gotten scim working in Slackware 13? Any tips I'm missing out on?
 
Old 11-12-2009, 02:32 PM   #2
gegechris99
Member
 
Registered: Oct 2005
Location: France
Distribution: Slackware 14.1 32bit
Posts: 719
Blog Entries: 3

Rep: Reputation: 76
Hello,

I'm using SCIM for Korean input on Slackware 13.0 (32-bit edition) and I do not have any issue to write Korean characters in QT-based or in GTK-based applications. OK it may not be helpful to you.

Maybe you could inform about your window manager: KDE or XFCE?

Some other useful information that you may provide:

- In which application was the mouse cursor located when you pressed ctrl+space (ex: was it in the search bar of Firefox, in Kwrite...)
- Have you really a full installation (in case one required package for SCIM is missing)?
 
Old 11-13-2009, 12:40 AM   #3
mattington
LQ Newbie
 
Registered: Sep 2008
Location: Beijing
Distribution: Slackware, Arch
Posts: 10

Original Poster
Rep: Reputation: 0
Hi,

I'm running a stock full installation updated to slackware64-current, using KDE4. I can put the cursor anywhere and I get nothing. How did you edit your scim settings to get hangul? Did you select it from the list within scim? Are you running in a Korean locale?
 
Old 11-13-2009, 02:10 AM   #4
grissiom
Member
 
Registered: Apr 2008
Location: China, Beijing
Distribution: Slackware
Posts: 419

Rep: Reputation: 45
Hmm, try to set your local to zh_CN.UTF-8 then. If you are encouraged, you may want to try ibus (http://slackbuilds.org/result/?search=ibus&sv=13.0 )
 
Old 11-13-2009, 04:00 AM   #5
gegechris99
Member
 
Registered: Oct 2005
Location: France
Distribution: Slackware 14.1 32bit
Posts: 719
Blog Entries: 3

Rep: Reputation: 76
Quote:
Originally Posted by mattington View Post
Hi,

I'm running a stock full installation updated to slackware64-current, using KDE4. I can put the cursor anywhere and I get nothing. How did you edit your scim settings to get hangul? Did you select it from the list within scim? Are you running in a Korean locale?
Hello,

I'm using the French locale!!! So your locale is not an issue as long as you're using a .UTF-8 locale.

SCIM needs to be configured first for available input engines. Right-click on the keyboard icon in the system tray and select "Configuration".

Then you can use this how-to to find your way around the configuration items.
 
Old 11-13-2009, 10:42 PM   #6
mattington
LQ Newbie
 
Registered: Sep 2008
Location: Beijing
Distribution: Slackware, Arch
Posts: 10

Original Poster
Rep: Reputation: 0
I already had my setting set as per that howto, but I did realize how to clarify my question: the scim panel never appears. Is it possible that something else is stealing the shortcut? I'm mystified. Never had problems with scim before on slack.

Thanks for the ibus hint, I'm going to check that out now.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with Zenity and SCIM when tabbing to change focus harryhaller Slackware 0 06-22-2008 05:59 AM
how to change SCIM icon on panel checkchan Fedora 2 11-20-2007 11:09 AM
Howto Switch Languages in SCIM? zoobave Programming 0 08-13-2007 05:44 AM
Can I input other languages use SCIM on an English session? jialin Fedora 2 05-09-2006 09:13 AM
How to use scim to type foreign languages? renshao Linux - Newbie 2 03-30-2006 11:25 AM


All times are GMT -5. The time now is 02:09 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration