LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 03-11-2006, 06:59 AM   #1
renshao
LQ Newbie
 
Registered: Mar 2006
Posts: 14

Rep: Reputation: 0
Question How to use scim to type foreign languages?


I'v installed scim 1.4.4 and a pinyin engine to type chinese. I extracted both package from tarball and follow the instructions in INSTALL file, everything went fine.

But I'm not sure how to use it. I could launch scim command from terminal, and there's an icon in the system tray, but I still can't type chinese in OpenOffice. How do I switch input methods?

Am I supposed to be able to launch scim by 'Ctrl + space'? when I did that, nothing happened.
 
Old 03-11-2006, 07:53 AM   #2
David the H.
Bash Guru
 
Registered: Jun 2004
Location: Osaka, Japan
Distribution: Debian sid + kde 3.5 & 4.4
Posts: 6,823

Rep: Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947
Everything worked easily for me when I installed a Japanese engine. I just had to reset my language environment. You have to make sure it's set to a UTF-8 character set. Run "locale" in a terminal to see what you have set up now. The main entries all need to be something like "en_US.UTF-8", with the first part being whatever language you want your menus and GUI elements to appear in. I'm not going to go into how to reset it if it's wrong, because frankly I don't remember exactly how I did it. :P You'll have to research that on your own. You can start by checking out the "set-language-env" command though.

I think you also need "XMODIFIERS=@im=SCIM" in your environment variables as well. And don't forget that whatever character servers you need have to be running also.

After that it should be easy. SCIM is set to engage by default with crtl+space, but this can be changed in the settings. When you hit it the try icon should change and you should be able to enter Chinese then. A left-click on the tray icon should also give you the choice of switching between your regular keyboard and IME. If you have multiple IME engines set up, then you'll be given a list to choose from. There are shortcut keys you can set up in the settings for these too.

This should work for most applications, but I think that there are some older non-unicode ready apps may not be able to handle the input. There may be a way around it, but I haven't figured it out yet. I'm still learning it myself. At least SCIM is much easier to use than the old set-language-environment-
for-each-app-separately way I had to use before. It's really a godsend for multiple-language users.

Edit: Fixed a mistake.

Last edited by David the H.; 03-11-2006 at 07:56 AM.
 
Old 03-30-2006, 11:25 AM   #3
FireGunz
Member
 
Registered: Mar 2006
Distribution: Fedora Core 5 i386 DVD | Kernel 2.6.16-1.2080_FC5 | YUM v2.6.0 | GNOME v2.14.0 |
Posts: 42

Rep: Reputation: 15
hi renshao,

how did you install scim. does it support for FC5 also I want to install the chinese input and able to view the chinese font at firefox BUT i want my default FC5 OS in english.

can anyone guide me out please ....
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How can I use foreign languages on Gentoo? jroussel Linux - Newbie 14 03-02-2005 02:46 AM
Possible to display foreign languages? vincebs Linux - General 4 01-15-2005 11:33 PM
Foreign languages floppywhopper LQ Suggestions & Feedback 24 01-07-2005 06:48 AM
How to view foreign languages? JunZ Linux - Newbie 1 05-31-2004 07:49 AM
How can I set to type with foreign languages(special characters most) petru_b16 Linux - Software 1 07-27-2003 03:32 PM


All times are GMT -5. The time now is 09:09 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration