LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 11-09-2006, 10:39 AM   #1
Zmyrgel
Senior Member
 
Registered: Dec 2005
Location: Finland
Distribution: Slackware, CentOS, RHEL, OpenBSD
Posts: 1,006

Rep: Reputation: 36
No output device in audacious


Just installed audacious package from linuxpackages.net but when running it I get no playback at all. I checked from preferences and there from audio tab it doesn't give any output devices or let me choose any.
Any idea how to get the audacious to work? I prefer it over xmms
 
Old 11-09-2006, 10:43 AM   #2
raska
Member
 
Registered: Aug 2004
Location: Aguascalientes, AGS. Mexico.
Distribution: Slackware 13.0 kernel 2.6.29.6
Posts: 816

Rep: Reputation: 30
Did you install the plugins as well?
That's a common behaviour of missing audacious's plugins.
I suggest you that compile your own packages from source rather than installing them from linuxpackages.net
 
Old 11-09-2006, 11:03 AM   #3
Zmyrgel
Senior Member
 
Registered: Dec 2005
Location: Finland
Distribution: Slackware, CentOS, RHEL, OpenBSD
Posts: 1,006

Original Poster
Rep: Reputation: 36
Yeah, actually just compiled both the player and the plugins and it's working

btw, how to set compiler options in slackware? Gentoo has the /etc/make.conf file?
 
Old 11-09-2006, 11:10 AM   #4
raska
Member
 
Registered: Aug 2004
Location: Aguascalientes, AGS. Mexico.
Distribution: Slackware 13.0 kernel 2.6.29.6
Posts: 816

Rep: Reputation: 30
Quote:
Originally Posted by Zmyrgel
...how to set compiler options in slackware? Gentoo has the /etc/make.conf file?
mmmm don't know of gentoo's dark corners LOL
I have a couple of gcc's flags in my .profile, they work for me but I'm not sure if that's what you are looking for:
Code:
$ cat ~/.profile
#!/bin/bash
export CFLAGS="-O3 -march=athlon-4"
export CXXFLAGS="-O3 -march=athlon-4"
 
Old 11-09-2006, 11:18 AM   #5
Zmyrgel
Senior Member
 
Registered: Dec 2005
Location: Finland
Distribution: Slackware, CentOS, RHEL, OpenBSD
Posts: 1,006

Original Poster
Rep: Reputation: 36
Ok, thank you. That was what I was looking for. How about make then, how can I specify option "make -j4" on it everytime without typing it? Is alias the best way for it or is there some official way?
 
Old 11-09-2006, 11:53 AM   #6
raska
Member
 
Registered: Aug 2004
Location: Aguascalientes, AGS. Mexico.
Distribution: Slackware 13.0 kernel 2.6.29.6
Posts: 816

Rep: Reputation: 30
Likely an alias would do.
Though I don't know what is the -j4 option for?
What does it do?
 
Old 11-09-2006, 12:10 PM   #7
Zmyrgel
Senior Member
 
Registered: Dec 2005
Location: Finland
Distribution: Slackware, CentOS, RHEL, OpenBSD
Posts: 1,006

Original Poster
Rep: Reputation: 36
Compiles the code using more resources, perfect to use when you have more than one processor. I think the rule of thumb is make -j CPUs + 1 so the dual-core systems use -j3.
 
Old 11-09-2006, 06:39 PM   #8
jong357
Senior Member
 
Registered: May 2003
Location: Columbus, OH
Distribution: DIYSlackware
Posts: 1,914

Rep: Reputation: 52
export MAKEOPTS="-j3"

same place as the CFLAGS.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ifconfig output : unknown device dark* Slackware 15 09-03-2006 11:04 PM
mplayer doesnt have my video output device? Simdude90015 Linux - Software 1 07-12-2006 10:46 PM
redirect output to device christina_rules Linux - General 4 05-23-2006 02:46 AM
Adjusting sound output device DanielTan Linux - Laptop and Netbook 3 10-19-2005 01:35 PM
Let's try Output Device Problem in 10.1 matthewa Slackware 3 08-17-2005 02:37 AM


All times are GMT -5. The time now is 10:45 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration