LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 07-12-2006, 07:36 PM   #1
Simdude90015
Member
 
Registered: Jun 2004
Location: Pittsburgh, PA area
Distribution: Debian 3.1 (or variant... depends on which machine)
Posts: 72

Rep: Reputation: 15
mplayer doesnt have my video output device?


I can't play videos in mplayer... I think it's because my video output device isn't understood by mplayer. Whenever I play a video (mplayer -fs commandN-052-h264.mov) I get the usual terminal output and audio, but no video on my screen. I tried specifying my video output device with -vo, but my options are rather limited:

Code:
media:~# mplayer -vo help
MPlayer dev-SVN-r19053-3.3.5 (C) 2000-2006 MPlayer Team
CPU: AMD Athlon(tm) Processor (Family: 6, Model: 4, Stepping: 2)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 0 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx

Available video output drivers:
        cvidix  console VIDIX
        null    Null video output
        mpegpes Mpeg-PES to DVB card
        yuv4mpeg        yuv4mpeg output for mjpegtools
        tga     Targa output
        pnm     PPM/PGM/PGMYUV file
        md5sum  md5sum of each frame
Any Idea whats wrong?

-Jim
(Somewhat )
 
Old 07-12-2006, 10:46 PM   #2
Simdude90015
Member
 
Registered: Jun 2004
Location: Pittsburgh, PA area
Distribution: Debian 3.1 (or variant... depends on which machine)
Posts: 72

Original Poster
Rep: Reputation: 15
I figured it out. When I compiled mplayer, I didnt look in the docs and check the dependencies. When I went through and installed them (and reconfigured and recompiled mplayer) I had more options and one of them worked.

Also, It helped whenever I issued the command locally, instead of over ssh. :-P

As I said, .

When in doubt: .
 
  


Reply

Tags
mplayer


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mplayer: Could not initialize video filters (-vf) or video output (-vo) miceagol Linux - Software 2 06-04-2006 10:35 AM
Mplayer- no video output!?!?! help!!!!!!! nicdee Linux - Software 2 10-28-2005 10:28 AM
mplayer video output error cd1680 Linux - Software 4 03-20-2005 11:32 AM
mplayer?? video output killi Slackware 11 05-17-2003 07:10 AM
mplayer video output vank Linux - Software 1 01-14-2003 01:08 PM


All times are GMT -5. The time now is 03:52 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration