LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 01-04-2010, 08:42 AM   #151
dugan
Senior Member
 
Registered: Nov 2003
Location: Canada
Distribution: distro hopper
Posts: 4,236

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295

Quote:
Originally Posted by Thursapr View Post
Upgraded to new versions. It is weird that everything works fine, except Firefox (3.5.6), the fonts like the patches never been applied.
Is anyone having the same problem? I had a rebuilt Firefox 3.5.2 from before I upgraded to the new font packages. After I upgraded the font packages, Firefox's font rendering behavior continued as expected.

Last edited by dugan; 01-04-2010 at 09:07 AM.
 
Old 01-04-2010, 03:30 PM   #152
rmjohnso
Member
 
Registered: Mar 2006
Location: Wisconsin
Distribution: Slackware64-Current
Posts: 294

Rep: Reputation: 43
I'm using Slackware64-current, so I think Pat's build of Firefox is dynamically linked against cairo instead of the static linking under 32-bit. Everything looks good to me in firefox-3.5.6 now that I've got cairo-1.8.8 patched.
 
Old 01-04-2010, 06:37 PM   #153
rmjohnso
Member
 
Registered: Mar 2006
Location: Wisconsin
Distribution: Slackware64-Current
Posts: 294

Rep: Reputation: 43
Why is Chrome not showing fonts in a manner similar to Firefox? It defaults to using Arial and Times New Roman, and I've switched it to match what I have in Firefox, but I didn't really see any change.
 
Old 01-05-2010, 12:16 AM   #154
Daedra
Senior Member
 
Registered: Dec 2005
Location: Springfield, MO
Distribution: Slackware64-14.1
Posts: 1,215

Original Poster
Rep: Reputation: 176Reputation: 176
just guessing but like you said above, chrome might be statically linked against cairo. That could be the problem.
 
Old 01-05-2010, 12:42 PM   #155
rmjohnso
Member
 
Registered: Mar 2006
Location: Wisconsin
Distribution: Slackware64-Current
Posts: 294

Rep: Reputation: 43
After doing a little googling, it looks like Chrome uses skia (http://code.google.com/p/skia/) and not cairo.
 
Old 01-25-2010, 03:18 AM   #156
dugan
Senior Member
 
Registered: Nov 2003
Location: Canada
Distribution: distro hopper
Posts: 4,236

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
Thursapr, what rmjohnso wrote is correct. You need to rebuild Firefox from source. Use the Slackware64 SlackBuild.

Last edited by dugan; 01-25-2010 at 03:21 AM.
 
Old 01-26-2010, 10:08 AM   #157
Thursapr
Member
 
Registered: Apr 2009
Distribution: Slackware
Posts: 44

Rep: Reputation: 18
Quote:
Originally Posted by dugan View Post
Thursapr, what rmjohnso wrote is correct. You need to rebuild Firefox from source. Use the Slackware64 SlackBuild.
I did these exactly. But after upgrading the 4 packages, not before.

Anyone rebuild FF after upgrading 4 package not encountered my problem?
 
Old 01-26-2010, 12:32 PM   #158
dugan
Senior Member
 
Registered: Nov 2003
Location: Canada
Distribution: distro hopper
Posts: 4,236

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
Quote:
Originally Posted by Thursapr View Post
Anyone rebuild FF after upgrading 4 package not encountered my problem?
Yes. In the "Optimizing" page I have screenshots to prove it.
 
Old 01-26-2010, 12:47 PM   #159
GrapefruiTgirl
Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 542Reputation: 542Reputation: 542Reputation: 542Reputation: 542Reputation: 542
@ dugan,

I just wanted to write that I had never before visited your web page about these fonts and things, so I went and had a look just now. It's nice! Really well written and covers a lot of angles dealing with fonts and monitors and X. Cool, nice work.

I have long ago got my subpixel rendering sorted out, but never yet bothered going into great depth regarding my Slackware fonts (AFAICT they are pretty good anyhow); but it's on my list though of things to do eventually, and I'll be using this thread, and your web page, as a guide/template when I get to it.

Thanks,
Sasha
 
Old 05-24-2010, 05:59 PM   #160
dugan
Senior Member
 
Registered: Nov 2003
Location: Canada
Distribution: distro hopper
Posts: 4,236

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
The four patched SlackBuilds have been updated for 13.1.

You can find them in the "Optimizing Slackware Linux's Fonts" page in my sig.

Last edited by dugan; 05-24-2010 at 06:00 PM.
 
1 members found this post helpful.
Old 05-25-2010, 07:10 AM   #161
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,769
Blog Entries: 1

Rep: Reputation: 410Reputation: 410Reputation: 410Reputation: 410Reputation: 410
Thanks dugan, your page has been a real help in making my desktop MUCH getter.
 
Old 06-01-2010, 02:13 AM   #162
tomtomjkw
Member
 
Registered: Jan 2008
Distribution: Slackware64-current
Posts: 125

Rep: Reputation: 31
Calibri problem

Hi

I have a problem with Calibri font:

http://yfrog.com/jycalibrip

When font size ranges from 8 to 14, rendering of language specific fonts seems to be broken. 15 and over - font is ok.
Webcore-fonts installed from Dugan's slackbuild, fontconfig and others compiled Cleartype-style.
Any ideas?
 
Old 06-12-2010, 11:34 PM   #163
dugan
Senior Member
 
Registered: Nov 2003
Location: Canada
Distribution: distro hopper
Posts: 4,236

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
I just noticed that the current Fontconfig patch no longer enables the "lcddefault" filter, which is the whole point of the Ubuntu patches in the first place.

You need to add the following lines to your local.conf:
Code:
        
<match target="font">
    <edit name="lcdfilter" mode="assign">
        <const>lcddefault</const>
    </edit>
</match>
Also, after upgrading from 13.1 from 13.0, you need to rebuild all 4 packages in order. I know this wasn't obvious because I'd neglected to change the build numbers, but I've taken care of that now.
 
3 members found this post helpful.
Old 06-13-2010, 10:08 AM   #164
SpelledJ
Member
 
Registered: Jun 2006
Location: Birmingham, AL
Distribution: Slackware64-13.1, 12.1
Posts: 119

Rep: Reputation: 20
I rebuilt your packages for 13.1 on a fresh installation a couple of weeks ago, Dugan, and my fonts didn't seem as clear as they did a couple of months ago on -current. Thanks for the tweak - that made a big difference. One thing you might want to mention is that your addition needs to go between the <fontconfig> . . . </fontconfig> tags, not at the end of the file.

Something else I noticed is that I'm missing some entries in /etc/fonts/conf.avail now. Compared to your post #125, I don't have any 10-hinting-*.conf entries, and I don't have 11-lcd-filter-lcddefault.conf. Your conf.d from post #125 was last edited in 08/09 for Slackware 13.0. Is it still consistent with 13.1?

My /etc/fonts/conf.avail:
Code:
-rw-r--r-- 1 root root  220 2010-06-01 17:54 10-autohint.conf
-rw-r--r-- 1 root root  226 2010-06-01 17:54 10-no-sub-pixel.conf
-rw-r--r-- 1 root root  225 2010-06-01 17:54 10-sub-pixel-bgr.conf
-rw-r--r-- 1 root root  225 2010-06-01 17:54 10-sub-pixel-rgb.conf
-rw-r--r-- 1 root root  226 2010-06-01 17:54 10-sub-pixel-vbgr.conf
-rw-r--r-- 1 root root  226 2010-06-01 17:54 10-sub-pixel-vrgb.conf
-rw-r--r-- 1 root root  217 2010-06-01 17:54 10-unhinted.conf
-rw-r--r-- 1 root root  912 2010-06-01 17:54 20-fix-globaladvance.conf
-rw-r--r-- 1 root root 1157 2010-06-01 17:54 20-unhint-small-vera.conf
-rw-r--r-- 1 root root 2941 2010-06-01 17:54 25-unhint-nonlatin.conf
-rw-r--r-- 1 root root 3939 2010-06-01 17:54 30-metric-aliases.conf
-rw-r--r-- 1 root root 1164 2010-06-01 17:54 30-urw-aliases.conf
-rw-r--r-- 1 root root 2103 2010-06-01 17:54 40-nonlatin.conf
-rw-r--r-- 1 root root 1837 2010-06-01 17:54 45-latin.conf
-rw-r--r-- 1 root root  545 2010-06-01 17:54 49-sansserif.conf
-rw-r--r-- 1 root root  245 2010-06-01 17:54 50-user.conf
-rw-r--r-- 1 root root  318 2010-06-13 09:33 51-local.conf
-rw-r--r-- 1 root root 1701 2010-06-01 17:54 60-latin.conf
-rw-r--r-- 1 root root 9880 2010-06-01 17:54 65-fonts-persian.conf
-rw-r--r-- 1 root root  289 2010-06-01 17:54 65-khmer.conf
-rw-r--r-- 1 root root 7706 2010-06-01 17:54 65-nonlatin.conf
-rw-r--r-- 1 root root  672 2010-06-01 17:54 69-unifont.conf
-rw-r--r-- 1 root root  263 2010-06-01 17:54 70-no-bitmaps.conf
-rw-r--r-- 1 root root  263 2010-06-01 17:54 70-yes-bitmaps.conf
-rw-r--r-- 1 root root  388 2010-06-01 17:54 80-delicious.conf
-rw-r--r-- 1 root root 1691 2010-06-01 17:54 90-synthetic.conf
My *dc packages in /var/log/packages, note timestamps for build order:

Code:
-rw-r--r-- 1 root root 3861 2010-06-01 17:57 freetype-2.3.12-x86_64-1_dc
-rw-r--r-- 1 root root 8827 2010-06-01 17:58 fontconfig-2.8.0-x86_64-1_dc
-rw-r--r-- 1 root root 1068 2010-06-01 18:01 libXft-2.1.14-x86_64-1_dc
-rw-r--r-- 1 root root 4197 2010-06-01 18:02 cairo-1.8.8-x86_64-3_dc
Thanks as usual for keeping up with all the nice font upgrades!
 
Old 06-13-2010, 01:12 PM   #165
dugan
Senior Member
 
Registered: Nov 2003
Location: Canada
Distribution: distro hopper
Posts: 4,236

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
SpelledJ: Those files are no longer there. I've edited post #125 accordingly.

To tweak further, try putting <edit name="antialias" mode="assign"><bool>true</bool></edit> or <edit name="antialias" mode="assign"><bool>false</bool></edit> between the <match> tags.

Also, I tried Chrome, and I noticed that the fonts in the rendering area look different than the fonts in its menus, with the menu fonts being fuzzier and the website fonts being sharper. This leads me to believe that the settings in Chrome's rendering area are actually hardcoded, and cannot be changed. I do know that this is the case with another program: the Gargoyle Interactive Fiction Interpreter.

Last edited by dugan; 06-13-2010 at 01:16 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
If I were to recompile & arch-optimize Slackware, where to begin? GrapefruiTgirl Slackware 124 06-22-2007 09:46 PM
How to Optimize Slackware 10.2? zeroz52 Slackware 23 10-04-2005 06:42 PM
How to fully optimize Slackware? Introx Slackware 4 05-30-2004 04:23 AM


All times are GMT -5. The time now is 11:48 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration