LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-11-2009, 07:35 AM   #136
pokipoki08
Member
 
Registered: Mar 2009
Posts: 76

Rep: Reputation: 16

Quote:
Originally Posted by dugan View Post
I've written up most of this thread's findings:
http://www.vcn.bc.ca/~dugan/slackware-fonts/
The results are lovely, especially the droid fonts.
Thank you.
 
Old 09-02-2009, 07:23 AM   #137
pokipoki08
Member
 
Registered: Mar 2009
Posts: 76

Rep: Reputation: 16
@dugan

What are the changes required for Slackware 13.0?

.XDefaults doesn't seem to work.

Do I need to rebuild Freetype, Fontconfig, libXft and Cairo for subpixel rendering to work?

Thanks
 
Old 09-02-2009, 01:25 PM   #138
dugan
Senior Member
 
Registered: Nov 2003
Location: Canada
Distribution: distro hopper
Posts: 4,562

Rep: Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394
Quote:
Originally Posted by pokipoki08 View Post
What are the changes required for Slackware 13.0?

.XDefaults doesn't seem to work.

Do I need to rebuild Freetype, Fontconfig, libXft and Cairo for subpixel rendering to work?
???

The process for Slackware 13 is exactly as described. And, exactly the same as for 12.1 and 12.2.

~/.Xdefaults (note capitalization and location) works after you run xrdb -merge ~/.Xdefaults. This is usually run automatically, as soon as you log into X.

If you want the type of font rendering advocated in this thread, then yes you have to rebuild those packages. I would then blacklist them in slackpkg to prevent slackpkg from overwriting them.

Last edited by dugan; 09-02-2009 at 01:43 PM.
 
Old 09-05-2009, 03:51 AM   #139
Su-Shee
Member
 
Registered: Sep 2007
Location: Berlin
Distribution: Slackware
Posts: 509

Rep: Reputation: 41
Hm, I have a unpleasant bug with all our perfect font patches (with both the old school version of just three patches _and_ with the new school version of all the 9458604 available patches applied ) - it excludes Japanese from being rendered perfectly.

This looks like this:

Bad rendering

in comparison to my perfect rendering with Slackware 12.2:

Nice rendering

This concerns not just showing the font in gvim (like in the screenshots, but also with less or plain vim in "terminal" (Xfce's terminal which I always use).

As I don't install a new home dir, all my old configs are completely untouched, my fonts.conf and the fonts itselves the same as ever - only the Slackware installation is new.

Any ideas? Maybe something totally easy to configure I have to do with Slack 13?
 
Old 09-05-2009, 03:53 AM   #140
Su-Shee
Member
 
Registered: Sep 2007
Location: Berlin
Distribution: Slackware
Posts: 509

Rep: Reputation: 41
And we should really open the "once and for all perfect fonts under slackware" thread
 
Old 09-05-2009, 03:54 AM   #141
Daedra
Senior Member
 
Registered: Dec 2005
Location: Springfield, MO
Distribution: Slackware64-14.1
Posts: 1,216

Original Poster
Rep: Reputation: 177Reputation: 177
Did you enable bytecode interprter in the slackbuild? I think Dugan's by default doesn't enable it? Not sure if that would help but maybe.
 
Old 09-05-2009, 05:53 AM   #142
Su-Shee
Member
 
Registered: Sep 2007
Location: Berlin
Distribution: Slackware
Posts: 509

Rep: Reputation: 41
Yes, I tried 3 variations:


* Only our old patches (Cleartype variation) enabled
* all patches straight as Dugan supplied them as Cleartype variation
* all patches as Ubuntu variation

I also re-build vim just to be on the safe side and tried with Dugan's fontconfig build and with Slack's out-of-the-box fontconfig package.

All with the same font.

Funnily, it's really _only_ japanese.
 
Old 09-05-2009, 10:20 AM   #143
dugan
Senior Member
 
Registered: Nov 2003
Location: Canada
Distribution: distro hopper
Posts: 4,562

Rep: Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394
Quote:
Originally Posted by Daedra View Post
Did you enable bytecode interprter in the slackbuild? I think Dugan's by default doesn't enable it?
Yes it does.
 
Old 09-30-2009, 12:21 PM   #144
jcardoza
LQ Newbie
 
Registered: Jun 2009
Posts: 23

Rep: Reputation: 0
Talking

Nice Job, cool!!!
 
Old 10-31-2009, 09:25 AM   #145
tdos20
Member
 
Registered: Aug 2006
Location: London
Distribution: Slackware
Posts: 103

Rep: Reputation: 29
These make such a difference to my slackware, thanks for putting up the easy instructions at http://www.vcn.bc.ca/~dugan/slackware-fonts/
 
Old 12-27-2009, 06:13 PM   #146
rmjohnso
Member
 
Registered: Mar 2006
Location: Wisconsin
Distribution: Slackware64-Current
Posts: 294

Rep: Reputation: 43
Dugan, have you tested out the Ubuntu patches on the new version of Cairo (cairo-1.8.8) that is needed for Firefox 3.5.6? I tried going through your slackbuild and the patches you have posted on your site for 1.8.6, but I'm not having much luck.
 
Old 12-29-2009, 12:44 AM   #147
dugan
Senior Member
 
Registered: Nov 2003
Location: Canada
Distribution: distro hopper
Posts: 4,562

Rep: Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394
I'll try to get to it by tomorrow.
 
Old 01-03-2010, 03:51 PM   #148
dugan
Senior Member
 
Registered: Nov 2003
Location: Canada
Distribution: distro hopper
Posts: 4,562

Rep: Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394
Okay, the new SlackBuilds are up (Freetype 2.3.11, Fontconfig 2.8.0, LibXft 2.3.14, Cairo 1.8.8).
 
Old 01-03-2010, 08:47 PM   #149
rmjohnso
Member
 
Registered: Mar 2006
Location: Wisconsin
Distribution: Slackware64-Current
Posts: 294

Rep: Reputation: 43
Thanks! They look great, as always.
 
Old 01-04-2010, 06:21 AM   #150
Thursapr
Member
 
Registered: Apr 2009
Distribution: Slackware
Posts: 44

Rep: Reputation: 18
Upgraded to new versions. It is weird that everything works fine, except Firefox (3.5.6), the fonts like the patches never been applied.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
If I were to recompile & arch-optimize Slackware, where to begin? GrapefruiTgirl Slackware 124 06-22-2007 09:46 PM
How to Optimize Slackware 10.2? zeroz52 Slackware 23 10-04-2005 06:42 PM
How to fully optimize Slackware? Introx Slackware 4 05-30-2004 04:23 AM


All times are GMT -5. The time now is 04:11 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration