LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-02-2011, 11:38 AM   #1
Widgeteye
Member
 
Registered: Mar 2005
Posts: 100

Rep: Reputation: 17
HAL in Slackware


I know this isn't really the place for HAL questions but we got some smart people in the Slackware community. So ima ask here anyway.

I check "ps aux" and see that HAL is running. But when I build some apps they complain that KDE D-Bus can't be found. What's up with that? Why do some apps complain about KDE D-Bus when I do a configure --without-kde? I have run into several apps that complain about this. Why wouldn't HAl D-Bus running on my system satisfy the Hal/D-bus dep?

Then when I start KDE and try and build the app it builds fine?? SOme of these apps aren't even specifically made for KDE. And then some apps complain about D-Bus, not particularly KDE, and won't build. The more that app builders are depending on HAL/D-Bus the more confusing it gets.

Does anyone have any insight into this?

Thanks
 
Old 01-02-2011, 01:24 PM   #2
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,289

Rep: Reputation: 1062Reputation: 1062Reputation: 1062Reputation: 1062Reputation: 1062Reputation: 1062Reputation: 1062Reputation: 1062
Could you please more specific?

What are your distribution and version?
Which app(s) are you trying to build and how ?
What are the exact error message(s) you get ?

Other than that, HAL and D-Bus are two different apps.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware 12, HAL automount arubin Slackware 38 01-27-2009 11:48 AM
Hal and XFCE in Slackware 12.1 budman85 Slackware 2 07-24-2008 11:22 PM
Preparing for Slackware 12 and Hal arubin Slackware 4 07-05-2007 10:44 AM
HAL on Slackware 11.0 cdale77 Slackware 4 05-13-2007 05:55 PM
Has anyone got hal working on Slackware 10.2? Steve50 Slackware 12 02-26-2006 08:39 AM


All times are GMT -5. The time now is 11:11 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration