LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-23-2008, 12:38 AM   #1
budman85
LQ Newbie
 
Registered: Sep 2005
Location: Montreal Canada
Distribution: Slackware
Posts: 15

Rep: Reputation: 0
Hal and XFCE in Slackware 12.1


Hi

I've noticed this odd issue since updating to 12.1. It ran fine in 12.0. I've been through all the FAQs and topics I could find, but none of them mention this issue.

My id is plugdev, and the other related groups. The entries in /etc/fstab have user option, tried users as well.

The rules I created for the two card readers work fine, I added GROUP=users to each line.

Here is the issue.

If a memory card is installed in the reader when XFCE starts up - the icon of the card reader will appear and I can mount and unmount fine.

However, if the card reader is empty when XFCE starts up, unplugging the device, or adding a memory card does not add the icon to the desktop.

I've tried toggling the "allow xfce to manage desktop" option, the icons refresh but the new drive icon never appears.

I checked to see if hald is working, I see it polling every 2 secs. When the card is added, the mounts are created and symlinks are created. It seems they are all working fine. I can mount the card reader under root and then access as the user.

The only thing I've found that works are these steps:
rc.messagebus reload
rc.hald restart
toggle the "allow xfce to manage desktop"
bingo - the icon appears and I can mount the card.

BTW, restarting X has no effect. Message bus must be reloaded and hald restarted so the icon will appear on the desktop.

Does anyone know how XFCE checks to see if anything was changed? I saw mention of the famd daemon, but its no longer on my system. Is this related to the xfdesktop?

I also try renaming the .config under my home dir, same results. I also tried as root, same results.

I then renamed the my custom rules file, and commented the lines in fstab. Restarted everything, same results.

In 12.0, when I unplugged the device, the icon disappeared. When I plugged it in, it reappeared. This no longer happens. The icons remain whether the device is plugged in or not.

Any ideas I can check or try?


Thanks
Rich
 
Old 07-24-2008, 09:56 AM   #2
granth
Member
 
Registered: Jul 2004
Location: USA
Distribution: Slackware64
Posts: 210

Rep: Reputation: 39
Quote:
My id is plugdev, and the other related groups
I'm guessing you are a member of the plugdev group?

Code:
cat /etc/group | grep username

Quote:
The entries in /etc/fstab have user option, tried users as well.
Please post your fstab.

Did you try removing the entries from your fstab?
Does your cdrom auto-mount?
 
Old 07-24-2008, 11:22 PM   #3
budman85
LQ Newbie
 
Registered: Sep 2005
Location: Montreal Canada
Distribution: Slackware
Posts: 15

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by granth View Post
I'm guessing you are a member of the plugdev group?

Code:
cat /etc/group | grep username



Please post your fstab.

Did you try removing the entries from your fstab?
Does your cdrom auto-mount?

Thanks for replying.
I started tracing what was loaded. XFCE uses libgamin now, and dropped the famd support. I was comparing files in /lib, /usr/bin, and /usr/lib. Decided to rename the usr dir and try a reload of software.

It worked. Whatever was in /usr/bin or /usr/lib caused hald/messagebus gamin to break in Xfce. I've been comparing directories, file by file - so far I cannot see anything that may have caused it.

Since I have the dirs, I'll keep on checking. Maybe something will stick out. The only thing I saw on libgamin was a slight lib address change.

ldd /usr1/lib/libgamin-1.so.0.1.9
linux-gate.so.1 => (0xffffe000)
libpthread.so.0 => /lib/libpthread.so.0 (0xb7ee4000)
libc.so.6 => /lib/libc.so.6 (0xb7d98000)
/lib/ld-linux.so.2 (0x80000000)

ldd /usr/lib/libgamin-1.so.0.1.9
linux-gate.so.1 => (0xffffe000)
libpthread.so.0 => /lib/libpthread.so.0 (0xb7fa2000)
libc.so.6 => /lib/libc.so.6 (0xb7e56000)
/lib/ld-linux.so.2 (0x80000000)

Really strange. Maybe libc or libpthread caused it. Works like a charm now.

oh well.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Automount - HAL - udev - Xfce - Konqueror - Slackware - help requested Linux.tar.gz Linux - Hardware 5 06-19-2008 09:49 AM
HAL on Slackware 11.0 cdale77 Slackware 4 05-13-2007 05:55 PM
KDE base to work with dropline's HAL & rworkman's buildscripts for xfce 4.4 ? Doable? Old_Fogie Slackware 13 04-16-2007 10:57 PM
Has anyone got hal working on Slackware 10.2? Steve50 Slackware 12 02-26-2006 08:39 AM


All times are GMT -5. The time now is 04:54 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration