LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-23-2006, 06:05 AM   #1
Steve50
Member
 
Registered: Nov 2004
Location: Coventry, UK
Distribution: Debian Lenny, Ubuntu Feisty
Posts: 121

Rep: Reputation: 15
Has anyone got hal working on Slackware 10.2?


Apologies if I've missed the answer to this question but I've trawled through the forum and can't seem to find an solution.

I've recently done a clean install of 10.2, and added FR Gnome as well as a custom 2.6 kernel. FR Gnome installed hal and d-bus but automounting still doesn't work. This seems to be a common theme, and although I have no problem with manually mounting devices it would be nice to get this working properly. Has anyone had any success?
 
Old 02-23-2006, 06:11 AM   #2
satinet
Senior Member
 
Registered: Feb 2004
Location: England
Distribution: Slackware 11, Sabayon 3.1
Posts: 1,464

Rep: Reputation: 46
hi,

i didn't get it working with GWARE, but it works fine with FRG on a 10.2 system...

are the deamons actually running?

on mine i had to go into /etc/rc.d and do chmod +x on the rc scripts enable them at boot. or that's how i remember it. also there is 'howl' that you should start too.

do "ps -ef|grep -i hald"
 
Old 02-23-2006, 10:32 AM   #3
Steve50
Member
 
Registered: Nov 2004
Location: Coventry, UK
Distribution: Debian Lenny, Ubuntu Feisty
Posts: 121

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by satinet
hi,

i didn't get it working with GWARE, but it works fine with FRG on a 10.2 system...

are the deamons actually running?

on mine i had to go into /etc/rc.d and do chmod +x on the rc scripts enable them at boot. or that's how i remember it. also there is 'howl' that you should start too.

do "ps -ef|grep -i hald"

Not sure if the deamons are running. I ran the command and got this output:

4179 4177 0 16:29 pts/1 00:00:00 grep -i hald

which I'm guessing means no.

In /etc/rc.d the following scripts are not executable:

rc.hal
rc.messagebus
rc.howl
rc.udev

Do I need all of these to run? Thanks for any advice. I'm only a few weeks into using Slackware and so far I'm really impressed.
 
Old 02-23-2006, 11:11 AM   #4
satinet
Senior Member
 
Registered: Feb 2004
Location: England
Distribution: Slackware 11, Sabayon 3.1
Posts: 1,464

Rep: Reputation: 46
the udev one is depricated. dont need to chmod it.

but yes, you need to do this:

cd /etc/rc.d/

chmod +x rc.hal

chmod +x rc.messagebus

chmod +x rc.howl


then after you reboot, you should be fine. i believe the FRG install script modifies one of the other scripts to point to these.

hope that helps - it should work after that..... let me know how you get on.


if you want to disable service do 'chmod -x rc.servicename'

there's lots of stuff you can turn off. not that it really makes that much difference...
 
Old 02-23-2006, 11:11 AM   #5
titopoquito
Senior Member
 
Registered: Jul 2004
Location: Ruhr Area, Germany
Distribution: Slackware64 14.0
Posts: 1,517

Rep: Reputation: 90
They have to be executable (and referenced in one of the other files, for example in rc.local which should be already done by the Freerock Gnome installation routine).
Do a "chmod 755 rc.hal rc.messagebus rc.howl rc.udev" or just the ones you need. I don't know if rc.hal alone is enough.
 
Old 02-23-2006, 11:13 AM   #6
satinet
Senior Member
 
Registered: Feb 2004
Location: England
Distribution: Slackware 11, Sabayon 3.1
Posts: 1,464

Rep: Reputation: 46
just to clarify, you dont need to chmod +x the udev one.

do "ps -ef|grep -i udev" and realise that i am as right as ever.... ;-)
 
Old 02-23-2006, 11:32 AM   #7
Steve50
Member
 
Registered: Nov 2004
Location: Coventry, UK
Distribution: Debian Lenny, Ubuntu Feisty
Posts: 121

Original Poster
Rep: Reputation: 15
OK, I did the following:

chmod +x rc.hal

chmod +x rc.messagebus

chmod +x rc.howl

and rebooted. Automounting still isn't working but the gnome volume manager now opens and lets me change settings.

The out put from ps -ef|grep -i hald is now:

steve@dadpc:~$ ps -ef|grep -i hald
root 3883 1 0 17:23 ? 00:00:00 /usr/sbin/hald --daemon=yes --retain-privileges
root 3889 3883 0 17:23 ? 00:00:00 hald-addon-acpi
root 3893 3883 0 17:23 ? 00:00:00 hald-addon-storage
root 3914 3883 0 17:23 ? 00:00:00 hald-addon-storage
steve 4555 4542 0 17:29 pts/1 00:00:00 grep -i hald

And I looked in the rc.local file and it contains:

#!/bin/sh
#
# /etc/rc.d/rc.local: Local system initialization script.
#
# Put any local setup commands in here:

# To disable howl, chmod rc.howl to 644
if [ -x /etc/rc.d/rc.howl ]; then
echo "Starting Howl mDNS daemons"
. /etc/rc.d/rc.howl start
fi

# To disable dbus, chmod rc.messagebus to 644
if [ -x /etc/rc.d/rc.messagebus ]; then
echo "Starting D-BUS Messaging Subsystem"
. /etc/rc.d/rc.messagebus start
fi

# To disable hal, chmod rc.hal to 644
if [ -x /etc/rc.d/rc.hal ]; then
echo "Starting HAL"
# wait a few seconds to let udev complete its
# initialization. Otherwise hald will not recognize CD/DVD
# drives and will not start polling them
( sleep 5; /etc/rc.d/rc.hal start ) &
fi


Any ideas about what to do next? Thanks for the advice so far.

Edit: do I need to add the halddeamon to the users group or make other group modifications?

Last edited by Steve50; 02-23-2006 at 12:10 PM.
 
Old 02-23-2006, 01:17 PM   #8
satinet
Senior Member
 
Registered: Feb 2004
Location: England
Distribution: Slackware 11, Sabayon 3.1
Posts: 1,464

Rep: Reputation: 46
i'm not sure. just doing that worked for me.

are you sure you've got your settings right in gnome. i.e to displayed mounted devices...
 
Old 02-23-2006, 01:37 PM   #9
Steve50
Member
 
Registered: Nov 2004
Location: Coventry, UK
Distribution: Debian Lenny, Ubuntu Feisty
Posts: 121

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by satinet
i'm not sure. just doing that worked for me.

are you sure you've got your settings right in gnome. i.e to displayed mounted devices...

Yes, settings are fine, but when I tried inserting my usbstick nothing happened at all. So I put a blank cd in the drive, and after a few seconds that did mount and appear on the desktop - so progress at least. I then switched to kde and even the cd doesn't automount. Oh well, not a huge problem, but if anyone has any other ideas please let me know. And thanks for the help so far.
 
Old 02-25-2006, 03:05 PM   #10
satinet
Senior Member
 
Registered: Feb 2004
Location: England
Distribution: Slackware 11, Sabayon 3.1
Posts: 1,464

Rep: Reputation: 46
i might have been wrong about the "rc.udev" thing. lol. oops

well try enabling it and see what happens....
 
Old 02-26-2006, 06:41 AM   #11
Steve50
Member
 
Registered: Nov 2004
Location: Coventry, UK
Distribution: Debian Lenny, Ubuntu Feisty
Posts: 121

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by satinet
i might have been wrong about the "rc.udev" thing. lol. oops

well try enabling it and see what happens....
Tries this, but doesn't seem to make any difference. Thanks anyway.
 
Old 02-26-2006, 07:21 AM   #12
satinet
Senior Member
 
Registered: Feb 2004
Location: England
Distribution: Slackware 11, Sabayon 3.1
Posts: 1,464

Rep: Reputation: 46
hmmm that's a bit dissapointing.

mine is mounting my iPod name automagically and opening GTKpod....




when you plug something in does it get mounted in /etc/mtab at all?
 
Old 02-26-2006, 08:39 AM   #13
Steve50
Member
 
Registered: Nov 2004
Location: Coventry, UK
Distribution: Debian Lenny, Ubuntu Feisty
Posts: 121

Original Poster
Rep: Reputation: 15
In Gnome only the cd gets automounted and shows up in mtab. When I plug in my usbstick or my iaudio they don't show up at all, although I can manually mount them once I find out which node they're mapped to with dmesg | tail. One of the issues I have is that the /dev node changes each time. I have 3 sata disks, and a usb card reader with four slots, which are sometimes picked up at boot, and sometimes not. So sometimes my usbsick is sdd1 and sometimes sdh1, and occasionally something inbetween. In KDE nothing automounts.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
HAL/UDEV ! I need help to get them working ! kevkim55 Suse/Novell 1 01-15-2006 05:57 AM
hal krusty_lab Fedora 3 10-10-2005 10:23 AM
HAL deamon johnnydangerous Fedora 2 02-08-2005 02:41 AM
Hal gamehack Programming 7 12-16-2004 02:03 AM
wine and winesetuptk working well with slackware 9.0 and slackware 9.1 oobe Linux - Software 0 10-19-2003 12:29 PM


All times are GMT -5. The time now is 03:26 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration