LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-26-2010, 06:41 PM   #16
andrew.46
Member
 
Registered: Oct 2007
Distribution: Slackware
Posts: 646

Rep: Reputation: 90

I have been bitten by the same irritating bug:

Code:
Console: switching to colour frame buffer device 100x37
and the various attempts I have made to get around it have failed. Adding append = "nomodeset" to lilo.conf certainly stopped the microscopic frame buffer output but X would not start. Selecting a better size frame buffer option in lilo.conf worked for the first few screens and then back to microfont. Repeatedly crashing my head into the keyboard also did not work...

My graphics are:

Code:
root@skamandros/home/andrew# lspci | grep Graphics
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
and I would love a bit of advice on how to get around this problem. Running Slackware 13.1 and 2.6.33.4-smp.

Andrew
 
Old 05-26-2010, 07:00 PM   #17
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
How did you set "a better frame buffer option" ? Simply using 'video=1024x768' (or whatever resolution you want) appended to the kernel boot line should force the framebuffer to use that resolution always.

Adam
 
Old 05-26-2010, 07:15 PM   #18
andrew.46
Member
 
Registered: Oct 2007
Distribution: Slackware
Posts: 646

Rep: Reputation: 90
Hi Adam,

Quote:
Originally Posted by adamk75 View Post
How did you set "a better frame buffer option" ? Simply using 'video=1024x768' (or whatever resolution you want) appended to the kernel boot line should force the framebuffer to use that resolution always.
Hmmm... perhaps I have done this incorrectly? I simply added:

Code:
vga=771
and this is what I received for a few screens before being resized. Should this be added as append video=1024x768 in the top section? ??

Andrew
 
Old 05-26-2010, 07:38 PM   #19
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
I'm not in front of a slackware box at the moment, but as I recall there's already an append line, right? Just add video=1024x768 to it (make sure it's in the quotes already in that line).

vga=771 only works with the vesa/vga framebuffer, iirc. KMS uses the video option.

Adam
 
Old 05-27-2010, 05:51 AM   #20
matters
Member
 
Registered: May 2007
Distribution: Slackware
Posts: 281

Original Poster
Rep: Reputation: Disabled
I also have the problem although im using intel 865g
in lilo.conf i have added line exactly like this:
Code:
append = "video=1024x768"
and then executed :
Code:
/sbin/lilo
and rebooted but it dosent work for me either. Is there anything we missed?
 
Old 05-27-2010, 06:07 AM   #21
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
What happens when you booted up with that append line? Can you show us the output of 'dmesg | grep drm'?

Adam
 
Old 05-27-2010, 06:30 AM   #22
matters
Member
 
Registered: May 2007
Distribution: Slackware
Posts: 281

Original Poster
Rep: Reputation: Disabled
Code:
dmesg |grep drm
shows nothing, and with that append line i still have microcospic fonts
 
Old 05-27-2010, 06:36 AM   #23
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
Can you show the full output of 'dmesg' then? Is KMS even enabled in your kernel?

Adam
 
Old 05-27-2010, 06:52 AM   #24
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,251

Rep: Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045
To double-check that vesa be not involved, at boot hit <tab> and type:
Code:
Linux vga=normal
If you still see the hight of characters changing on the console during startup, then another frame-buffer driver is involved. To know which one type:
Code:
lspci -k | grep -A3 VGA
and post the output here.

Now if you see a module name including "fb" in the output, then blacklist this module, reboot (still with vga=normal) and please tell us the outcome.

Last edited by Didier Spaier; 05-27-2010 at 06:58 AM.
 
Old 05-27-2010, 06:58 AM   #25
matters
Member
 
Registered: May 2007
Distribution: Slackware
Posts: 281

Original Poster
Rep: Reputation: Disabled
guys you are fast either with append = "video=1024x768" and vga=normal same problem as with when i disable vga=normal and leave append = "video=1024x768"

drm in dmesg shows this :
Code:
drm] Initialized drm 1.1.0 20060810
[drm] set up 7M of stolen space
[drm] initialized overlay support
fb0: inteldrmfb frame buffer device
[drm] Initialized i915 1.6.0 20080730 for 0000:00:02.0 on minor 0
and heres
Code:
lspci -k | grep -A3 VGA
00:02.0 VGA compatible controller: Intel Corporation 82865G Integrated Graphics Controller (rev 02)
        Subsystem: ASRock Incorporation Device 2572
        Kernel driver in use: i915
        Kernel modules: i915

Last edited by matters; 05-27-2010 at 07:03 AM.
 
Old 05-27-2010, 07:00 AM   #26
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,251

Rep: Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045
Then append following line at the end of /etc/modprobe.d/blacklist.conf:
Code:
blacklist inteldrmfb
reboot and see what happens.
 
Old 05-27-2010, 07:37 AM   #27
matters
Member
 
Registered: May 2007
Distribution: Slackware
Posts: 281

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Didier Spaier View Post
Then append following line at the end of /etc/modprobe.d/blacklist.conf:
Code:
blacklist inteldrmfb
reboot and see what happens.
blacklisting didnt help
although vga=normal i disabled in lilo.conf, and enabled append = "video=1024x768"

im wondering what adam will respond since my conclusion its something about kms related issue
 
Old 05-27-2010, 07:48 AM   #28
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
Well, first, inteldrmfb is not a module. It's part of the intel drm. Simply using "nomodeset" on the kernel boot line will disable KMS (including inteldrmfb). But, as I believe we've already confirmed earlier in the thread, X will then not work with the intel driver.

I'm sorry, but if adding video="1024x768" doesn't force the framebuffer resolution to 1024x768, I'm not sure what to try next. Can you boot up with that option, run 'fbset' in the console, and show us the output?

Adam
 
Old 05-27-2010, 08:06 AM   #29
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,251

Rep: Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045
I suppose i915 is compiled as a module and KMS is enabled by default for it. At least this is the case for kernels shipped with 13.1

If you want to make sure that kernel modesetting be not used (though may be then X won't start as Adamk75 stated) you could try this as root

echo 'options i915 modeset=0' > /etc/modprobe.d/i915

and reboot.

Last edited by Didier Spaier; 05-27-2010 at 08:23 AM.
 
Old 05-27-2010, 08:11 AM   #30
matters
Member
 
Registered: May 2007
Distribution: Slackware
Posts: 281

Original Poster
Rep: Reputation: Disabled
it gives :
Code:
mode "1024x768"
    geometry 1024 768 1024 768 32
    timings 0 0 0 0 0 0 0
    rgba 8/16,8/8,8/0,0/0
endmode
one quick question what is relation between append = "video=1024x768" and vga=normal?
does both have to be enabled in lilo.conf?
im asking just to clarify
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Linux frame buffer console help needed ssenuta Linux - Hardware 0 09-20-2007 10:55 AM
console frame buffer @ 640x480 only edM Slackware 6 08-23-2004 09:29 AM
Unable to Find a Valid Frame Buffer Device newinlinux Linux - Newbie 0 01-15-2004 12:17 AM
Problems with changing the frame buffer setting in console. adz Linux - Software 1 10-23-2003 02:25 AM
How to enable frame buffer device? suriyamohan Programming 2 04-03-2003 10:45 PM


All times are GMT -5. The time now is 05:58 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration