LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   console:switching to colour frame buffer device 128x48 while kernel boot 2.6.33-smp (http://www.linuxquestions.org/questions/slackware-14/console-switching-to-colour-frame-buffer-device-128x48-while-kernel-boot-2-6-33-smp-794283/)

matters 03-09-2010 02:10 PM

console:switching to colour frame buffer device 128x48 while kernel boot 2.6.33-smp
 
hi!

in lilo.conf i do have specified vga normal

but while booting the system screen resolution changes and it says
Code:

Console:Switching to colour frame buffer device 128x48
what is causing this? how can i prevent this from happening again?

this only happens when i do have 2.6.33 predefined kernels installed.

Thanks alot!

eddyvp 03-10-2010 02:33 AM

hi,
Are you running slackware-current?
Blacklisting the nouveau driver (and using the nvidia driver) solved the problem for me.

JZL240I-U 03-10-2010 04:01 AM

As I understand it, something was changed in the KBM (kernel based mode setting), that thingy which prevents flickering of the display during boot and changes of resolution. Maybe it is just a side effect...

matters 03-10-2010 05:39 AM

yes slackware-current.im using intel 865g onboard chipset i tried blacklisting by specifying blacklist nouveau anyway to see no matter because its nvidia and no joy for me.

adamk75 03-10-2010 09:01 AM

If it is related to KMS (not KBM), you can disable it at boot by passing the 'nomodeset' option to the kernel. Mind you, I doubt X will start on intel GPUs without KMS enabled :-)

EDIT: Alright, so X will still work if you disable KMS on Slackware 13.0. What I've heard, though, is that it will not work on -current. I can't confirm this personally, though:

http://www.linuxquestions.org/questi...normal-792873/

JZL240I-U 03-10-2010 09:09 AM

Quote:

Originally Posted by adamk75 (Post 3892859)
...KMS (not KBM)...

Darned acronyms ;) :p

Thanks for the correction.

matters 03-10-2010 06:21 PM

@JZL240I-U and adam yes that fixes the problem.

jzl where did you get the info from that its about kms ?

when i disable kms while in X windows i can change console with ctrl+alt+f1-f6 no problem but if kms is enabled then when i try to switch back to consoles with ctrl+alt+f1-f6 it gives black screen and i cant use ctrl+alt+backspace no more.

also xorgsetup when trying to detect hardware gives black screen no matter if kms is enabled or disabled. im wondering what cause that it gives black screen?, im wondering how xorgsetup operate? does it operate in a way that its trying to start a xorg server when detecting hardware?

i saved xorg.conf from previous xorg server from slack13

and tried to start x to see what happens.
i get this:

/usr/lib/xorg/modules/intel_drv.so: undefined symbol: resVgaShared

because at the moment im unable to get proper resolution in X windows. i see that many ppls say that driver that i have installed is conflict with x-org server or does not support xorg server that im running, so i will see about it.

thats why i would like to know how xorgsetup operate when detecting hardware through hal?

thanks guys

JZL240I-U 03-11-2010 07:24 AM

Quote:

Originally Posted by matters (Post 3893491)
...jzl where did you get the info from that its about kms ? ...

That was a guess founded on your description of the problem.

Quote:

Originally Posted by matters (Post 3893491)
...if kms is enabled then when i try to switch back to consoles with ctrl+alt+f1-f6 it gives black screen and i cant use ctrl+alt+backspace no more....

For a controlled reboot use <Alt> + <SysReq> + REISUB (typing the (small) characters in this sequence)

http://kember.net/articles/231/reisu...-linux-restart
http://www.definition-of.com/REISUB

For this the SysRq feature must be turned on, i.e. "cat /proc/sys/kernel/sysrq" issues "1".

Quote:

Originally Posted by matters (Post 3893491)
...thats why i would like to know how xorgsetup operate when detecting hardware through hal...

I have no answer for this, sorry.

Didier Spaier 03-11-2010 08:00 AM

If I wouldn't want frame buffer I'd just blacklist the relevant module; lsmod|grep fb would tell me which one.

matters 03-11-2010 09:44 AM

@jzl sysrq codes works perfecly. thanks for info!

lets wait and see that someone reply whys that happening when kms is enabled and while in X windows when switching to consoles ctrl+alt+f1-f6 gives black screen? what causes that?

and no matter if kms is enabled or disabled in lilo xorgsetup gives black screen while trying to detect hardware ? what causes this?


wondering how xorgsetup operate when trying to detect hardware?

another thing about inteldrmfb would like to know how its related to kms?

Intel_ 03-11-2010 01:08 PM

And I have that problem, but I am not using any drivers for the video card. So, before slackware start on the lilo prompt to type nomodeset, and I should turn off kms from lilo.conf? But after that X may not work?

matters 03-11-2010 01:55 PM

im speaking in the name of intel chipset 865g, if you have slackware-current installed libdrm and xf86-video-intel-2.10 installed you can start X windows no matter if kms is enabled or disabled, but resolution wont be properly displayed, as i described earlier. however im still waiting for peoples to answer on my questions that i posted,

thanks guys

Intel_ 03-11-2010 03:22 PM

I have installed only libdrm, but as I said I don't use any drivers, but if I remove libdrm? This will break anything...

adamk75 03-11-2010 03:42 PM

What do you mean by "I am not using any drivers for the video card." ? Are you saying that you're not using Xorg? Because if you are using Xorg, then you're using drivers for your video card.

Adam

matters 03-11-2010 04:27 PM

to turn off kms in /etc/lilo.conf add the line
Code:

append = "nomodeset"
save /etc/lilo.conf,

then do :
Code:

/sbin/lilo
and reboot.thats how resolution came back to normal for me on 865g chipset.

if u want to turn on kms back just comment the line to be like this:
Code:

#append = "nomodeset"
save lilo.conf and start lilo with
Code:

/sbin/lilo
and reboot.


im wondering when i will get the answer on my questions :)


All times are GMT -5. The time now is 04:38 PM.