LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-09-2010, 01:10 PM   #1
matters
Member
 
Registered: May 2007
Distribution: Slackware
Posts: 281

Rep: Reputation: Disabled
console:switching to colour frame buffer device 128x48 while kernel boot 2.6.33-smp


hi!

in lilo.conf i do have specified vga normal

but while booting the system screen resolution changes and it says
Code:
Console:Switching to colour frame buffer device 128x48
what is causing this? how can i prevent this from happening again?

this only happens when i do have 2.6.33 predefined kernels installed.

Thanks alot!
 
Old 03-10-2010, 01:33 AM   #2
eddyvp
Member
 
Registered: Feb 2007
Location: Belgium
Distribution: Slackware
Posts: 37

Rep: Reputation: 17
hi,
Are you running slackware-current?
Blacklisting the nouveau driver (and using the nvidia driver) solved the problem for me.
 
Old 03-10-2010, 03:01 AM   #3
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 13.1 / 12.3_64-KDE, Ubuntu 14.04, Fedora 20, Mint 17, Chakra
Posts: 3,642

Rep: Reputation: Disabled
As I understand it, something was changed in the KBM (kernel based mode setting), that thingy which prevents flickering of the display during boot and changes of resolution. Maybe it is just a side effect...
 
Old 03-10-2010, 04:39 AM   #4
matters
Member
 
Registered: May 2007
Distribution: Slackware
Posts: 281

Original Poster
Rep: Reputation: Disabled
yes slackware-current.im using intel 865g onboard chipset i tried blacklisting by specifying blacklist nouveau anyway to see no matter because its nvidia and no joy for me.
 
Old 03-10-2010, 08:01 AM   #5
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
If it is related to KMS (not KBM), you can disable it at boot by passing the 'nomodeset' option to the kernel. Mind you, I doubt X will start on intel GPUs without KMS enabled :-)

EDIT: Alright, so X will still work if you disable KMS on Slackware 13.0. What I've heard, though, is that it will not work on -current. I can't confirm this personally, though:

http://www.linuxquestions.org/questi...normal-792873/

Last edited by adamk75; 03-10-2010 at 08:19 AM.
 
Old 03-10-2010, 08:09 AM   #6
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 13.1 / 12.3_64-KDE, Ubuntu 14.04, Fedora 20, Mint 17, Chakra
Posts: 3,642

Rep: Reputation: Disabled
Quote:
Originally Posted by adamk75 View Post
...KMS (not KBM)...
Darned acronyms

Thanks for the correction.
 
Old 03-10-2010, 05:21 PM   #7
matters
Member
 
Registered: May 2007
Distribution: Slackware
Posts: 281

Original Poster
Rep: Reputation: Disabled
@JZL240I-U and adam yes that fixes the problem.

jzl where did you get the info from that its about kms ?

when i disable kms while in X windows i can change console with ctrl+alt+f1-f6 no problem but if kms is enabled then when i try to switch back to consoles with ctrl+alt+f1-f6 it gives black screen and i cant use ctrl+alt+backspace no more.

also xorgsetup when trying to detect hardware gives black screen no matter if kms is enabled or disabled. im wondering what cause that it gives black screen?, im wondering how xorgsetup operate? does it operate in a way that its trying to start a xorg server when detecting hardware?

i saved xorg.conf from previous xorg server from slack13

and tried to start x to see what happens.
i get this:

/usr/lib/xorg/modules/intel_drv.so: undefined symbol: resVgaShared

because at the moment im unable to get proper resolution in X windows. i see that many ppls say that driver that i have installed is conflict with x-org server or does not support xorg server that im running, so i will see about it.

thats why i would like to know how xorgsetup operate when detecting hardware through hal?

thanks guys
 
Old 03-11-2010, 06:24 AM   #8
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 13.1 / 12.3_64-KDE, Ubuntu 14.04, Fedora 20, Mint 17, Chakra
Posts: 3,642

Rep: Reputation: Disabled
Quote:
Originally Posted by matters View Post
...jzl where did you get the info from that its about kms ? ...
That was a guess founded on your description of the problem.

Quote:
Originally Posted by matters View Post
...if kms is enabled then when i try to switch back to consoles with ctrl+alt+f1-f6 it gives black screen and i cant use ctrl+alt+backspace no more....
For a controlled reboot use <Alt> + <SysReq> + REISUB (typing the (small) characters in this sequence)

http://kember.net/articles/231/reisu...-linux-restart
http://www.definition-of.com/REISUB

For this the SysRq feature must be turned on, i.e. "cat /proc/sys/kernel/sysrq" issues "1".

Quote:
Originally Posted by matters View Post
...thats why i would like to know how xorgsetup operate when detecting hardware through hal...
I have no answer for this, sorry.

Last edited by JZL240I-U; 03-11-2010 at 06:30 AM.
 
Old 03-11-2010, 07:00 AM   #9
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-14.1 on a Lenovo T61 6457-4XG
Posts: 3,955

Rep: Reputation: 936Reputation: 936Reputation: 936Reputation: 936Reputation: 936Reputation: 936Reputation: 936Reputation: 936
If I wouldn't want frame buffer I'd just blacklist the relevant module; lsmod|grep fb would tell me which one.
 
Old 03-11-2010, 08:44 AM   #10
matters
Member
 
Registered: May 2007
Distribution: Slackware
Posts: 281

Original Poster
Rep: Reputation: Disabled
@jzl sysrq codes works perfecly. thanks for info!

lets wait and see that someone reply whys that happening when kms is enabled and while in X windows when switching to consoles ctrl+alt+f1-f6 gives black screen? what causes that?

and no matter if kms is enabled or disabled in lilo xorgsetup gives black screen while trying to detect hardware ? what causes this?


wondering how xorgsetup operate when trying to detect hardware?

another thing about inteldrmfb would like to know how its related to kms?
 
Old 03-11-2010, 12:08 PM   #11
Intel_
Member
 
Registered: Mar 2009
Location: Bulgaria
Distribution: Slackware
Posts: 103
Blog Entries: 5

Rep: Reputation: 20
And I have that problem, but I am not using any drivers for the video card. So, before slackware start on the lilo prompt to type nomodeset, and I should turn off kms from lilo.conf? But after that X may not work?
 
Old 03-11-2010, 12:55 PM   #12
matters
Member
 
Registered: May 2007
Distribution: Slackware
Posts: 281

Original Poster
Rep: Reputation: Disabled
im speaking in the name of intel chipset 865g, if you have slackware-current installed libdrm and xf86-video-intel-2.10 installed you can start X windows no matter if kms is enabled or disabled, but resolution wont be properly displayed, as i described earlier. however im still waiting for peoples to answer on my questions that i posted,

thanks guys
 
Old 03-11-2010, 02:22 PM   #13
Intel_
Member
 
Registered: Mar 2009
Location: Bulgaria
Distribution: Slackware
Posts: 103
Blog Entries: 5

Rep: Reputation: 20
I have installed only libdrm, but as I said I don't use any drivers, but if I remove libdrm? This will break anything...
 
Old 03-11-2010, 02:42 PM   #14
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
What do you mean by "I am not using any drivers for the video card." ? Are you saying that you're not using Xorg? Because if you are using Xorg, then you're using drivers for your video card.

Adam
 
Old 03-11-2010, 03:27 PM   #15
matters
Member
 
Registered: May 2007
Distribution: Slackware
Posts: 281

Original Poster
Rep: Reputation: Disabled
to turn off kms in /etc/lilo.conf add the line
Code:
append = "nomodeset"
save /etc/lilo.conf,

then do :
Code:
/sbin/lilo
and reboot.thats how resolution came back to normal for me on 865g chipset.

if u want to turn on kms back just comment the line to be like this:
Code:
#append = "nomodeset"
save lilo.conf and start lilo with
Code:
/sbin/lilo
and reboot.


im wondering when i will get the answer on my questions

Last edited by matters; 03-11-2010 at 03:35 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Linux frame buffer console help needed ssenuta Linux - Hardware 0 09-20-2007 10:55 AM
console frame buffer @ 640x480 only edM Slackware 6 08-23-2004 09:29 AM
Unable to Find a Valid Frame Buffer Device newinlinux Linux - Newbie 0 01-15-2004 12:17 AM
Problems with changing the frame buffer setting in console. adz Linux - Software 1 10-23-2003 02:25 AM
How to enable frame buffer device? suriyamohan Programming 2 04-03-2003 10:45 PM


All times are GMT -5. The time now is 11:14 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration