LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Non-*NIX Forums > Programming
User Name
Password
Programming This forum is for all programming questions.
The question does not have to be directly related to Linux and any language is fair game.

Notices

Reply
 
Search this Thread
Old 04-03-2003, 09:35 AM   #1
suriyamohan
Member
 
Registered: Mar 2003
Location: Coimbatore
Posts: 50

Rep: Reputation: 15
Smile How to enable frame buffer device?


Hi,
I am trying to build a user interface using DIRECTFB library (www.directfb.org) and gtk. Directfb requires a working frame buffer device. When i execute a sample program a run time error occurs indicating " Error opening `/dev/fb0'! --> No such device " . But when I execute "ls -l /dev/fb* ", the system prints all the available frame buffer devices from fb0-fb31. How to enable the frame buffer device in linux based system? I am currently working in Red HAt Linux 7.2, Kernel 2.4.7-10.
 
Old 04-03-2003, 01:32 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,414

Rep: Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967
you need to set it at boot. are you not currently using a framebuffer to boot to at all? if you're booting with lilo, set an option saying "vga=788" for 800x600 or "vga=791" for 1024x768. if it's grub just add the same to the end of teh kernel line and when you reboot it should start instantly (assuming you have it compiled into the kernel)
 
Old 04-03-2003, 11:45 PM   #3
suriyamohan
Member
 
Registered: Mar 2003
Location: Coimbatore
Posts: 50

Original Poster
Rep: Reputation: 15
Smile Enabling frame buffer to boot ...

Hi,
When i boot my system (Red Hat lInux 7.2, Kerenl 2.4.7-10, Intel(R) Celeron(TM) CPU 1000 MHZ), the sysytem diaplays the GRUB Version as 0.90 (639K lower / 129024K upper memory). In my system in "/etc" directory i can able to find only "lilo.conf.anaconda" file and the file "lilo.conf" is not available. so i appendded the following lines in the file "lilo.conf.anaconda".

append="video=vesa:ywrap,mtrr" // line 1
vga=791 // line 2

'ywrap' enables panning with wraparound.
'mtrr' enables setting caching type for the frame buffer to write-combining.

I appended line 1 and line 2 in "lilo.conf.anaconda", but still when i execute the program the run time error occurs. But as u said i did not compiled the kernel. is this may be the problem?

Now since my system use GRUB to load, do i have to compile the kernel after making changes in "lilo.conf.anaconda" file ? If so then how can we compile a kernel ? If not how to allow the system to use frame buffer to boot?

Help me to solve the aforesaid problem.

Last edited by suriyamohan; 04-03-2003 at 11:54 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
frame buffer problem sureshraju Linux - Software 3 06-29-2005 10:17 AM
frame buffer doesn't seem to work hubabuba Fedora 2 05-03-2005 01:39 PM
Unable to Find a Valid Frame Buffer Device newinlinux Linux - Newbie 0 01-15-2004 01:17 AM
Frame buffer bkeating Linux - Newbie 6 04-22-2003 07:09 PM
lilo (frame buffer maybe??) watashiwaotaku7 Linux - Software 6 03-10-2003 05:25 PM


All times are GMT -5. The time now is 04:17 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration